Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Jun 2, 2020
Messages
145
Motherboard
Gigabyte Z490 Vision G
CPU
i7-10700K
Graphics
Intel UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Tested BIOS F20d on my Vision G.
All works fine, but I want to make two comments:
1. If you need to change option "Initial Display Output" (for example, I use RTX 3080 in PCI-E Slot 1 and RX 570 in Slot 2 and need to set initial display output to "PCI-E slot 2") you need to turn on "CSM Support", change "Initial Display Output" option and then turn off "CSM Support". If CSM Support disabled you have not option "Initial Display Output" in BIOS menu. Looks like a bug in BIOS interface.
2. You need to set "ReSize BAR": "Disabled", macOS can't boot in "Auto" mode.
 
Last edited:

jd6

Joined
Mar 29, 2011
Messages
124
Motherboard
Gigabyte GA-Z490 Vision G
CPU
i5-11600k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
hi guys i just installed BIG SUR on a NVMe Samsung 970 Pro 512GB, but the first boot of the install keeps rebooting at same stage of the install. Does any one know why ?

my MB Z490 vision G
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,213
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
hi guys i just installed BIG SUR on a NVMe Samsung 970 Pro 512GB, but the first boot of the install keeps rebooting at same stage of the install. Does any one know why ?

my MB Z490 vision G
To clarify:
  • Big Sur installation completed successfully on Z490 Vision G?
  • Welcome screen appeared and you created user account, etc.?
  • But next reboot hangs?
  • Or Welcome screen never appears because the system goes into a reboot loop?
Have you tried:
  • Pressing CMD-V at OpenCore Picker before selecting macOS boot disk? This enables Verbose mode for the current boot.
 
Last edited:
  • Like
Reactions: jd6

jd6

Joined
Mar 29, 2011
Messages
124
Motherboard
Gigabyte GA-Z490 Vision G
CPU
i5-11600k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
To clarify:
  • Big Sur installation completed successfully on Z490 Vision G?
  • Welcome screen appeared and you created user account, etc.?
  • But next reboot hangs?
  • Or Welcome screen never appears because the system goes into a reboot loop?
Have you tried:
  • Pressing CMD-V at OpenCore Picker before selecting macOS boot disk? This enable Verbose mode for the current boot.
i have just now as we speak reinstalled the os again only this time on the holl disk before i did it on partition and now the installation seems to kick off ,

before when i did the installation on the partition of the disk at installed from the usb to the disk than when go to first boot i get in opencore "install" when i select that one at boot but than after looks like the install is doing its thing but No at keeps restarting

but now it good is wroking thnax CaseySJ

_________________


but now i have another questions


about the Config.plist

about Platforminfo

do we have to fill only in the Generic section info or also in others like

DataHub:
PlatformNVRAM
SMBIOS:


i ask you this because in my old build i filled all of this and my hackintosh boots up and everything works great even drm, but now if i fill all of this the systeem wont boot on this new MB Z490 vision g.

also in my old build with this all filled the hardware acceleration work nice but now nothing

if i filled datahub, platformnvram, and smbios the hackintosh system wont boot and says:

this version of mac os x is not supported on this platform reason mac-f4208cc8


so what do you think s.v.p......
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,213
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
i have just now as we speak reinstalled the os again only this time on the holl disk before i did it on partition and now the installation seems to kick off ,

before when i did the installation on the partition of the disk at installed from the usb to the disk than when go to first boot i get in opencore "install" when i select that one at boot but than after looks like the install is doing its thing but No at keeps restarting

but now it good is wroking thnax CaseySJ

_________________


but now i have another questions


about the Config.plist

about Platforminfo

do we have to fill only in the Generic section info or also in others like

DataHub:
PlatformNVRAM
SMBIOS:


i ask you this because in my old build i filled all of this and my hackintosh boots up and everything works great even drm, but now if i fill all of this the systeem wont boot on this new MB Z490 vision g.

also in my old build with this all filled the hardware acceleration work nice but now nothing

if i filled datahub, platformnvram, and smbios the hackintosh system wont boot and says:

this version of mac os x is not supported on this platform reason mac-f4208cc8


so what do you think s.v.p......
Simply use HackinDROM App, which can be downloaded from https://hackindrom.zapto.org (click the icon in the middle of the 'dock' that appears when you open the webpage). Then do the following:

Screen Shot 2021-04-14 at 2.42.40 PM.png
Screen Shot 2021-04-14 at 2.43.54 PM.png
Screen Shot 2021-04-14 at 2.44.08 PM.png

Regarding PlatformInfo:
  • We only need to set Datahub --> Generic.
Screen Shot 2021-04-14 at 2.52.44 PM.png
 

jd6

Joined
Mar 29, 2011
Messages
124
Motherboard
Gigabyte GA-Z490 Vision G
CPU
i5-11600k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Simply use HackinDROM App, which can be downloaded from https://hackindrom.zapto.org (click the icon in the middle of the 'dock' that appears when you open the webpage). Then do the following:

Regarding PlatformInfo:
  • We only need to set Datahub --> Generic.
Yes, I know about that, but I just wondering because of the hardware acceleration if the datahub, platformnvram, and SMBIOS can gets filled works, No? Or is it only in mine old hackintosh build on Z490 boards don't work anymore.

Only Datahub --> Generic. = no hardware acceleration on Z490 Vision G with iMac 20,1 or 20,2 or 19,1.

About the Hackindrom App, if I press Create EFI, the app shuts off and no EFI created.
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,213
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Yes, I know about that, but I just wondering because of the hardware acceleration if the datahub, platformnvram, and SMBIOS can gets filled works, No? Or is it only in mine old hackintosh build on Z490 boards don't work anymore.

Only Datahub --> Generic. = no hardware acceleration on Z490 Vision G with iMac 20,1 or 20,2 or 19,1.

...
Try it both ways and see for yourself what happens.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,213
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I already tried with at datahub, platformnvram, and SMBIOS filled

and says at boot: this version of mac os x is not supported on this platform reason mac-f4208cc8

hackintosh won't boot.
Some DRM operations do not work with iMac20,1 and 20,2 in Big Sur. See "DRM Compatibility on macOS 11" here:
 

jd6

Joined
Mar 29, 2011
Messages
124
Motherboard
Gigabyte GA-Z490 Vision G
CPU
i5-11600k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Some DRM operations do not work with iMac20,1 and 20,2 in Big Sur. See "DRM Compatibility on macOS 11" here:
Then it's very strange on my old hackintosh build GA-Z97M-D3H with Big Sure on it, iMac 19,1 20,1 and 20,2
DRM works just fine, with no boot arguments at all.
 
Top