Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

nss

Joined
Sep 16, 2019
Messages
89
Motherboard
Z490 Vision D
CPU
i7-10700
Graphics
RX 5700 XT
Mobile Phone
  1. Android
I wonder if the coin cell battery on the motherboard is depleted...
You think I should replace the motherboard's battery?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,859
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
You think I should replace the motherboard's battery?
If the board is not remembering BIOS settings and/or time, then a dead battery could be the cause. It's worth trying.
 
  • Like
Reactions: nss
Joined
Mar 30, 2021
Messages
17
Motherboard
Vision D z490
CPU
i9 10850K
Graphics
intel UHD 630
Hi @CaseySJ, my Hackintosh almost performs like a real Mac now. However, sometimes I get a black screen on the login page when I turn my Hackintosh on, but if I turn off my monitor then everything will be fine again, is there any solution to that? Also, I noticed that the Gigabyte smart fans system is not working on Hackintosh. No matter how high the temperature of my CPU is, the fans won't speed up. I have an i9 10850K and NZXT Kraken Z73, however, there's no NZXT support on Mac OS(I mean why would they support Mac OS ever......), so there is no way I can monitor the CPU temperature and control the Fan speed of my system while running Mac OS. Please help, thank you!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,859
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi @CaseySJ, my Hackintosh almost performs like a real Mac now. However, sometimes I get a black screen on the login page when I turn my Hackintosh on, but if I turn off my monitor then everything will be fine again, is there any solution to that?
I know AMD GPUs are very expensive and very difficult to find at this time so I will not harp about getting one! :) Instead, to make the best of the UHD 630 at this time, here are some things to try. No guarantees they'll work, but they're worth doing:
  • BIOS Setup --> Increase DVMT Pre Alloc.
  • BIOS Setup --> CSM Support --> Enabled.
If no help, try adding these Boot Args to OpenCore config.plist (one at a time):
  • gfxrst=1
  • gfxrst=4
If no help, then try these Boot Args as well (one or both at the same time is okay):
  • igfxagdc=0
  • igfxonln=1
By the way, what is the make/model of your monitor?
And are you using HDMI or DisplayPort (with a USB-C to DP cable)?


Also, I noticed that the Gigabyte smart fans system is not working on Hackintosh. No matter how high the temperature of my CPU is, the fans won't speed up. I have an i9 10850K and NZXT Kraken Z73, however, there's no NZXT support on Mac OS(I mean why would they support Mac OS ever......), so there is no way I can monitor the CPU temperature and control the Fan speed of my system while running Mac OS. Please help, thank you!
The NZXT Kraken Z73 is supported in macOS through Jonas Malaco's liquidctl. Instructions for installing and configuring it are located here:

However, for information about controlling the Kraken Z73, please see:
 
Last edited:
Joined
Mar 30, 2021
Messages
17
Motherboard
Vision D z490
CPU
i9 10850K
Graphics
intel UHD 630
I know AMD GPUs are very expensive and very difficult to find at this time so I will harp about getting one! :) Instead, to make the best of the UHD 630 at this time, here are some things to try. No guarantees they'll work, but they're worth doing:
  • BIOS Setup --> Increase DVMT Pre Alloc.
  • BIOS Setup --> CSM Support --> Enabled.
If no help, try adding these Boot Args to OpenCore config.plist (one at a time):
  • gfxrst=1
  • gfxrst=4
If no help, then try these Boot Args as well (one or both at the same time is okay):
  • igfxagdc=0
  • igfxonln=1
By the way, what is the make/model of your monitor?
And are you using HDMI or DisplayPort (with a USB-C to DP cable)?



The NZXT Kraken Z73 is supported in macOS through Jonas Malaco's liquidctl. Instructions for installing and configuring it are located here:

However, for information about controlling the Kraken Z73, please see:
Thank you so much, I used MSI Optix MAG27CQ
and here is the link: https://www.newegg.com/p/N82E16824475009
I am currently using DisplayPort(with a USB-c to DP cable)
I have tried USB-c to HDMI cable in the past and find it has a black screen that appears on the login page more frequently than the USB-c to DP port. Also, the black screen issue does not happen every time I turn on my Hackintosh, it only happens sometimes(like 1/3 possibilities, and if turn off my monitor and turn it back on, then it will resolve the issue) Also, I sort to find the solution on not having DP/HDMI audio sound output. I noticed that if I plug in both HDMI and USB-c to DP cable to the motherboard, then it will show up under the sound audio output setting, however, it will show two HDMI and DP output.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,859
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thank you so much, I used MSI Optix MAG27CQ
and here is the link: https://www.newegg.com/p/N82E16824475009
I am currently using DisplayPort(with a USB-c to DP cable)
I have tried USB-c to HDMI cable in the past and find it has a black screen that appears on the login page more frequently than the USB-c to DP port. Also, the black screen issue does not happen every time I turn on my Hackintosh, it only happens sometimes(like 1/3 possibilities, and if turn off my monitor and turn it back on, then it will resolve the issue) Also, I sort to find the solution on not having DP/HDMI audio sound output. I noticed that if I plug in both HDMI and USB-c to DP cable to the motherboard, then it will show up under the sound audio output setting, however, it will show two HDMI and DP output.
  • Have you tried just HDMI to HDMI (not USB-C to HDMI)?
  • Are you connecting one monitor or multiple monitors?
 
Joined
Mar 30, 2021
Messages
17
Motherboard
Vision D z490
CPU
i9 10850K
Graphics
intel UHD 630
  • Have you tried just HDMI to HDMI (not USB-C to HDMI)?
  • Are you connecting one monitor or multiple monitors?
I have tried HDMI to HDMI(not USB-C to HDMI), and find it about the same.
Also, I am only connecting to one monitor but if I have two cables plug in both the motherboard and the monitors, the audio output of the monitor will appear under the sound output setting. (one HDMI to HDMI and one USB-C to DP with one monitor only)
 
Joined
Sep 11, 2017
Messages
18
Motherboard
Gigabyte z490 vision D
CPU
i7-10700
Graphics
Intel® UHD Graphics 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Its working again! This was the solution! @CaseySJ Thanks for your help with this second Hackintosh now!
View attachment 492950
Hi,

I would like to know if your VRS8 is 100% functional. In my case, sometimes I have a problem with the inputs. I can hear the audio input in hardware monitoring on the VRS8, but with Logic or any other software I can't. The issue isn't always here. Sometimes I boot the pc and the inputs are ok and sometimes not.

If someone can help me.

Thank you,
 
Joined
Jul 31, 2015
Messages
81
Motherboard
Z490 Vision G
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Thank you so much, I used MSI Optix MAG27CQ
and here is the link: https://www.newegg.com/p/N82E16824475009
I am currently using DisplayPort(with a USB-c to DP cable)
I have tried USB-c to HDMI cable in the past and find it has a black screen that appears on the login page more frequently than the USB-c to DP port. Also, the black screen issue does not happen every time I turn on my Hackintosh, it only happens sometimes(like 1/3 possibilities, and if turn off my monitor and turn it back on, then it will resolve the issue) Also, I sort to find the solution on not having DP/HDMI audio sound output. I noticed that if I plug in both HDMI and USB-c to DP cable to the motherboard, then it will show up under the sound audio output setting, however, it will show two HDMI and DP output.

Switching to DP 1.1 on my monitor fixed iGPU black screen issues. Also I cannot boot with two monitors connected. I have to let macOS boot and then manually plugin in the second monitor. This is on a 10700K + Z490 Vision G.
 

jd6

Joined
Mar 29, 2011
Messages
117
Motherboard
Gigabyte GA-Z490 Vision G
CPU
i5-11600k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello, everyone. I have may have a strange question.

I bought Z490 Vision G and i5-11600k. To use this CPU, I had to upgrade the BIOS and because I don't have 10th gen.

I had to use the Qflash with USB BIOS update without CPU and RAM and GPU which worked. I ended to updating to the last BIOS version F20b. But the thing is, and I don't know or its only here with me or all Z490 vision G boards, are like that

I DON'T NOT HAVE THE OPTION IN BIOS FOR PCIE 1 SLOT AT ALL.

Like you can see in the photo here ( 1: intial Display, Output and next below is the 2: Internal Graphics, this photo is from CaseySJ's: guide out his Z490 Vision D which has that option and even my old Z.board from 2013 has that option

but i dont have that there by settings i have only Internal Graphics. option. anyone knows why or who has the same MB like mine and can look or make a photo to see or is the same like me, cause i cant change the Graphics inside bios


thanks in advance everbody.

F5d-IO Ports.png

I
 
Top