Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,817
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** HackinDROM App 1.2.0 Released **
Now supports both Catalina and Big Sur

Credit: @Inqnuam


The HackinDROM application now supports Catalina as well! (Mojave support is not planned.) Version 1.2.0 will download and install automatically when the previous version is launched. Please wait a few extra seconds for the application icon to appear in the menu bar.

Other improvements:
  • Drivers section now detects disabled drivers correctly
  • Performance optimizations
  • Report Archive now includes System Report file, but without personal data
  • Small graphical changes for better experience
  • Added description for the new -wegnoigpu boot argument
First time users may download the application from the HackinDROM website. HackinDROM Application mini-guide located here.
 

nss

Joined
Sep 16, 2019
Messages
89
Motherboard
Z490 Vision D
CPU
i7-10700
Graphics
RX 5700 XT
Mobile Phone
  1. Android
Hello @nss,
  • Do you have multiple operating systems installed such as Windows and/or Linux?
  • When you get this error, just go to BIOS Setup --> Boot and set first boot priority to the name of your macOS SSD.
Hi,
Thanks for your response, I've tried what you suggested, but the BIOS settings revert themselves every time I try this.
This is what I did:
Error pops on my screen as I try to boot macOS with "no entrance" sign,
restarted PC by clicking the physical PC restart button because I can't enter BIOS from OpenCore boot menu
entered BIOS settings,
entered Boot tab,
Boot order was:
1. OpenCore
2. name of macOS NVMe,
3. Windows Boot Manager.

Switched it to:
1. name of macOS NVMe,
2. OpenCore
3. Windows Boot Manager.

Also updated the time because it wasn't accurate, then Save & Exit, BOOT settings reverted and macOS somehow boots, until the error will happen once again.

Is there any solution to prevent BIOS settings from reverting themselves?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,817
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi,
Thanks for your response, I've tried what you suggested, but the BIOS settings revert themselves every time I try this.
This is what I did:
Error pops on my screen as I try to boot macOS with "no entrance" sign,
restarted PC by clicking the physical PC restart button because I can't enter BIOS from OpenCore boot menu
entered BIOS settings,
entered Boot tab,
Boot order was:
1. OpenCore
2. name of macOS NVMe,
3. Windows Boot Manager.

Switched it to:
1. name of macOS NVMe,
2. OpenCore
3. Windows Boot Manager.

Also updated the time because it wasn't accurate, then Save & Exit, BOOT settings reverted and macOS somehow boots, until the error will happen once again.

Is there any solution to prevent BIOS settings from reverting themselves?
I wonder if the coin cell battery on the motherboard is depleted...
 

nss

Joined
Sep 16, 2019
Messages
89
Motherboard
Z490 Vision D
CPU
i7-10700
Graphics
RX 5700 XT
Mobile Phone
  1. Android
I wonder if the coin cell battery on the motherboard is depleted...
You think I should replace the motherboard's battery?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,817
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
You think I should replace the motherboard's battery?
If the board is not remembering BIOS settings and/or time, then a dead battery could be the cause. It's worth trying.
 
  • Like
Reactions: nss
Joined
Mar 30, 2021
Messages
17
Motherboard
Vision D z490
CPU
i9 10850K
Graphics
intel UHD 630
Hi @CaseySJ, my Hackintosh almost performs like a real Mac now. However, sometimes I get a black screen on the login page when I turn my Hackintosh on, but if I turn off my monitor then everything will be fine again, is there any solution to that? Also, I noticed that the Gigabyte smart fans system is not working on Hackintosh. No matter how high the temperature of my CPU is, the fans won't speed up. I have an i9 10850K and NZXT Kraken Z73, however, there's no NZXT support on Mac OS(I mean why would they support Mac OS ever......), so there is no way I can monitor the CPU temperature and control the Fan speed of my system while running Mac OS. Please help, thank you!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,817
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi @CaseySJ, my Hackintosh almost performs like a real Mac now. However, sometimes I get a black screen on the login page when I turn my Hackintosh on, but if I turn off my monitor then everything will be fine again, is there any solution to that?
I know AMD GPUs are very expensive and very difficult to find at this time so I will not harp about getting one! :) Instead, to make the best of the UHD 630 at this time, here are some things to try. No guarantees they'll work, but they're worth doing:
  • BIOS Setup --> Increase DVMT Pre Alloc.
  • BIOS Setup --> CSM Support --> Enabled.
If no help, try adding these Boot Args to OpenCore config.plist (one at a time):
  • gfxrst=1
  • gfxrst=4
If no help, then try these Boot Args as well (one or both at the same time is okay):
  • igfxagdc=0
  • igfxonln=1
By the way, what is the make/model of your monitor?
And are you using HDMI or DisplayPort (with a USB-C to DP cable)?


Also, I noticed that the Gigabyte smart fans system is not working on Hackintosh. No matter how high the temperature of my CPU is, the fans won't speed up. I have an i9 10850K and NZXT Kraken Z73, however, there's no NZXT support on Mac OS(I mean why would they support Mac OS ever......), so there is no way I can monitor the CPU temperature and control the Fan speed of my system while running Mac OS. Please help, thank you!
The NZXT Kraken Z73 is supported in macOS through Jonas Malaco's liquidctl. Instructions for installing and configuring it are located here:

However, for information about controlling the Kraken Z73, please see:
 
Last edited:
Joined
Mar 30, 2021
Messages
17
Motherboard
Vision D z490
CPU
i9 10850K
Graphics
intel UHD 630
I know AMD GPUs are very expensive and very difficult to find at this time so I will harp about getting one! :) Instead, to make the best of the UHD 630 at this time, here are some things to try. No guarantees they'll work, but they're worth doing:
  • BIOS Setup --> Increase DVMT Pre Alloc.
  • BIOS Setup --> CSM Support --> Enabled.
If no help, try adding these Boot Args to OpenCore config.plist (one at a time):
  • gfxrst=1
  • gfxrst=4
If no help, then try these Boot Args as well (one or both at the same time is okay):
  • igfxagdc=0
  • igfxonln=1
By the way, what is the make/model of your monitor?
And are you using HDMI or DisplayPort (with a USB-C to DP cable)?



The NZXT Kraken Z73 is supported in macOS through Jonas Malaco's liquidctl. Instructions for installing and configuring it are located here:

However, for information about controlling the Kraken Z73, please see:
Thank you so much, I used MSI Optix MAG27CQ
and here is the link: https://www.newegg.com/p/N82E16824475009
I am currently using DisplayPort(with a USB-c to DP cable)
I have tried USB-c to HDMI cable in the past and find it has a black screen that appears on the login page more frequently than the USB-c to DP port. Also, the black screen issue does not happen every time I turn on my Hackintosh, it only happens sometimes(like 1/3 possibilities, and if turn off my monitor and turn it back on, then it will resolve the issue) Also, I sort to find the solution on not having DP/HDMI audio sound output. I noticed that if I plug in both HDMI and USB-c to DP cable to the motherboard, then it will show up under the sound audio output setting, however, it will show two HDMI and DP output.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,817
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thank you so much, I used MSI Optix MAG27CQ
and here is the link: https://www.newegg.com/p/N82E16824475009
I am currently using DisplayPort(with a USB-c to DP cable)
I have tried USB-c to HDMI cable in the past and find it has a black screen that appears on the login page more frequently than the USB-c to DP port. Also, the black screen issue does not happen every time I turn on my Hackintosh, it only happens sometimes(like 1/3 possibilities, and if turn off my monitor and turn it back on, then it will resolve the issue) Also, I sort to find the solution on not having DP/HDMI audio sound output. I noticed that if I plug in both HDMI and USB-c to DP cable to the motherboard, then it will show up under the sound audio output setting, however, it will show two HDMI and DP output.
  • Have you tried just HDMI to HDMI (not USB-C to HDMI)?
  • Are you connecting one monitor or multiple monitors?
 
Top