Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Nov 2, 2018
Messages
18
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
5700XT
Mac
  1. MacBook Pro
  2. Mac Pro
Hi @CaseySJ, I've got an issue I was hoping you would weigh in on. I am having a problem with a black screen booting into OC. After what seems like hours of troubleshoot I finally narrowed it down to my external drives. I have two external RAID drives. One is USB 3, the other is Thunderbolt. Both exhibit the same behavior. When connected OC won't boot. I have to disconnect them and the computer will boot like normal. I'm guessing it's the fact that these drives are set up in a software RAID configuration. I have two other USB 3 drives connected that are single drives and they don't cause this issue. Am I missing a KEXT? Thoughts? Thanks!!
 
Joined
May 19, 2019
Messages
44
Motherboard
Gigabyte Z390 Designare
CPU
i9
Graphics
Vega FE
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Please try alcid=11 and then Audio Out 0 to 4.
greetings hacklying @CaseySJ I have tried alcid=11 for green port on back I\O (aka ALC1220) I have also tried all alcid = 1, 2, 3, 5, 7, 11, 13, 15, 16, 21, 27, 28, 29, 34 according to oc guide that is associated with alc1220 on the vision d motherboard. alcid = 11 just gives me fewer selected audio choices and only headphones work as I carefully tried all options and the best for both front audio and green port (alc1220) working was alcid =28 layout; however I configured open core device properties for -> PciRoot(0x0)/Pci(0x1F,0x3) and added layout-id as type number which works the same as alcid =28 thus removing alcid from boot args and just moving it to the device property specs instead which both work just as well. please see screenshot showing layout id 28 is showing both internal speakers (green port / alc1220) and headphones as front panel. the concern is no matter how I set my settings to play through internal speakers as default through Audio_midi app or system setting the default always goes to headphones each boot not to mention no boot up sound on either headphones nor the green port. sound only becomes available after logging in to system but the default is always headphones which is strange I haven't found a way to override any system files to tweak to set internal speakers (green port) as default yet. thanks in advanced for reading ! much help very appreciated !
 

Attachments

  • Screen Shot PM.png
    Screen Shot PM.png
    458.9 KB · Views: 15
  • Screen ShotM.png
    Screen ShotM.png
    124 KB · Views: 15
  • Screen SM.png
    Screen SM.png
    456.5 KB · Views: 16

nss

Joined
Sep 16, 2019
Messages
89
Motherboard
Z490 Vision D
CPU
i7-10700
Graphics
RX 5700 XT
Mobile Phone
  1. Android
Hey,
I'm running Catalina 10.15.7 with OpenCore 0.6.3, and I would like to download the new "macOS Catalina 10.15.7 Supplemental Update". What do I have to prepare in order to do this? Do I have to upgrade to OpenCore 0.6.7?

Also, I've created a backup of the system on my SSD 6 months ago, but now I would like to create a new one since it's old, is there a way to override the old backup with a new one with Carbon Copy Cloner? or is there a better way to do this?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,883
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ thanks for the reply. I used the same Usac to DP cable but I couldn’t find the DP port output under the sound setting. However, if I turn off and turn back on my monitor, it might show up under the sound setting sometimes. Is there any solution to that? Also, I haven't flashed the TB3 BIOS yet. Could that be the reason why my DP port audio output is not showing under the sound setting? I am currently using the iMac 20,2. Should I use the iMac 20,1 instead of iMac20,2 since I don't have a dGPU? Thanks again, @CaseySJ.
We should not flash the Thunderbolt firmware unless we have a Thunderbolt device that simply won't connect otherwise. More than 90% of Thunderbolt devices will work without flashing the firmware.

As for sound output to the monitor, please check if using an HDMI cable avoids the problem. Use of iMac20,2 is perfectly okay with or without a discrete GPU.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,883
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi @CaseySJ, I've got an issue I was hoping you would weigh in on. I am having a problem with a black screen booting into OC. After what seems like hours of troubleshoot I finally narrowed it down to my external drives. I have two external RAID drives. One is USB 3, the other is Thunderbolt. Both exhibit the same behavior. When connected OC won't boot. I have to disconnect them and the computer will boot like normal. I'm guessing it's the fact that these drives are set up in a software RAID configuration. I have two other USB 3 drives connected that are single drives and they don't cause this issue. Am I missing a KEXT? Thoughts? Thanks!!
Hello @revmedia,

The troubleshooting process is generally the same; namely, we must isolate variables. For example:
  • How long was the system running fine, without this issue?
  • When did this problem start?
  • What changes were made just prior to the onset of this problem?
  • Additionally, please check if you're using HfsPlus.efi instead of OpenHfsPlus.efi. There are problems with OpenHfsPlus.efi, so we must avoid using it.
    • This can be checked by opening config.plist in OpenCore Configurator and looking at the UEFI --> Drivers page
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,883
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
greetings hacklying @CaseySJ I have tried alcid=11 for green port on back I\O (aka ALC1220) I have also tried all alcid = 1, 2, 3, 5, 7, 11, 13, 15, 16, 21, 27, 28, 29, 34 according to oc guide that is associated with alc1220 on the vision d motherboard. alcid = 11 just gives me fewer selected audio choices and only headphones work as I carefully tried all options and the best for both front audio and green port (alc1220) working was alcid =28 layout; however I configured open core device properties for -> PciRoot(0x0)/Pci(0x1F,0x3) and added layout-id as type number which works the same as alcid =28 thus removing alcid from boot args and just moving it to the device property specs instead which both work just as well. please see screenshot showing layout id 28 is showing both internal speakers (green port / alc1220) and headphones as front panel. the concern is no matter how I set my settings to play through internal speakers as default through Audio_midi app or system setting the default always goes to headphones each boot not to mention no boot up sound on either headphones nor the green port. sound only becomes available after logging in to system but the default is always headphones which is strange I haven't found a way to override any system files to tweak to set internal speakers (green port) as default yet. thanks in advanced for reading ! much help very appreciated !
There are two issues here, namely:
  1. Boot chime playback through rear green jack or front panel headphone port.
  2. Default sound device once macOS has booted.
Let's address item 1 first. This is of course done by changing Audio Out. But System Preferences --> Sound must also be configured properly as shown.

Screen Shot 2021-04-02 at 9.00.34 AM.png
Screen Shot 2021-04-02 at 9.01.24 AM.png
 
Joined
Jan 26, 2014
Messages
12
Motherboard
Gigabyte
CPU
intel
Graphics
cpu
So I recently had an email exchange with Gigabyte support in which I was told that the Z490 Vision D has been discontinued and is out of production, replaced with the Z590 Vision D. This was a little bit of a bummer for me, I had RMA'd my original board and was in the middle of shopping for a replacement. I found one overseas (for higher cost of course); but there will probably only be a limited supply out there assuming this is true. Hope our brave Z590 testers can find all the solutions for that board.
 

Attachments

  • Screen Shot 2021-04-02 at 4.51.33 PM.png
    Screen Shot 2021-04-02 at 4.51.33 PM.png
    120.1 KB · Views: 24
Joined
Mar 30, 2021
Messages
17
Motherboard
Vision D z490
CPU
i9 10850K
Graphics
intel UHD 630
We should not flash the Thunderbolt firmware unless we have a Thunderbolt device that simply won't connect otherwise. More than 90% of Thunderbolt devices will work without flashing the firmware.

As for sound output to the monitor, please check if using an HDMI cable avoids the problem. Use of iMac20,2 is perfectly okay with or without a discrete GPU.
I have tried the HDMI and USB-C to DP cable. macOS is not able to detect both the HDMI and DP audio under the sound output setting. Do you know why? Thank you!
 
Joined
Feb 19, 2018
Messages
790
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Hey,
I'm running Catalina 10.15.7 with OpenCore 0.6.3, and I would like to download the new "macOS Catalina 10.15.7 Supplemental Update". What do I have to prepare in order to do this? Do I have to upgrade to OpenCore 0.6.7?

Also, I've created a backup of the system on my SSD 6 months ago, but now I would like to create a new one since it's old, is there a way to override the old backup with a new one with Carbon Copy Cloner? or is there a better way to do this?

No you don't have to update OC but it wouldn't harm to do so.

As for CCC, it will update only the files it needs to, you don't need to start a new clone.
 
  • Like
Reactions: nss

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,883
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I have tried the HDMI and USB-C to DP cable. macOS is not able to detect both the HDMI and DP audio under the sound output setting. Do you know why? Thank you!
Unfortunately different monitors can react differently. We strongly discourage using the iGPU to drive a display monitor, but I do understand that AMD GPUs are very expensive and very difficult to find. It's best to wait for an AMD GPU to become available.
 
Top