Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
May 10, 2012
Messages
60
Motherboard
X299 PRO/SE
CPU
I7 10920X
Graphics
RX-580 DELL OEM
Mac
  1. Mac Pro
We will need to see:
  • Make/model of the expansion board
  • IOReg file
  • System DSDT
PCIe2-427
It must be something like this?:
 

Attachments

  • IORegistry.zip
    2.1 MB · Views: 8
  • ACPI Tables.zip
    154.3 KB · Views: 15
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,859
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
PCIe2-427
It must be something like this?:
Yes, that's the approach we need to take. Have you already tried it? If not, please post the IOReg file from IORegistryExplorer (File --> Save As...).
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,859
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
... is it now possible to have Intel Bluetooth and WIFI working decently on Big Sur (i.e. the same way as on Catalina) with @CaseySJ OpenCore configuration files?

...
Based on my definition of "working decently" the answer is easily "no". But others may find the drivers to be good enough for their purposes. I would encourage you to try the drivers for yourself to see if they're adequate for your needs.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,859
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ It does not work. Same issue that I had when I first used the SSDT from the Z390 page. Macos starts loading then around 50% on the progressing bar it resets. But if I use the one that I upload for you on the previous page, it does not crash. What changes did you make between the one I uploaded and the one you asked me to try?
Also not sure how this could be related but after it rebooted and I managed to disabled the SSDT via the OC editor, I lost bluetooth completely. Could not reconnect to the mouse, keyboard or soundbar.
Tried several times to reboot, remove then repair the bluetooth devices, nothing worked. Last solution, I shutdown the system, switched off the power supply for a couple of minutes, restarted and then bluetooth worked again.
It would appear that this technique of setting class-code to 0xFFFF no longer works in latest versions of macOS. Alas it may be necessary to wait until Radeon 6000-series drivers become available.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,859
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
The adata is a AHDD330

The RAID is a Promise Pegasus 3 R6

The thing is that I also noticed that whenever the render starts, it says for instance 20 minutes, but after like 5 minutes it starts to get slow, very very slow, and the computer is unusable, everything gets reall slow, the Finder, Chrome, very slow
Can you please answer the questions related to which USB/TB3 port each drive is connected to? Have you tried running Blackmagic Disk Speed Test on each of the two drives? The test should be run 3 times to see if performance slows down as the drives heat up.
 
Joined
May 10, 2012
Messages
60
Motherboard
X299 PRO/SE
CPU
I7 10920X
Graphics
RX-580 DELL OEM
Mac
  1. Mac Pro
Yes, that's the approach we need to take. Have you already tried it? If not, please post the IOReg file from IORegistryExplorer (File --> Save As...).
Here it is attached. This is booted through OC and WEG renames the GPU original name (attached in the previous post, which is booted natively) to GFX.
 

Attachments

  • Big Sur (2).zip
    3.6 MB · Views: 15

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,859
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Here it is attached. This is booted through OC and WEG renames the GPU original name (attached in the previous post, which is booted natively) to GFX.
Please try the attached SSDT. Some notes:
  • It's best to copy your working EFI folder to the EFI partition of a USB flash disk and add this SSDT to the USB flash disk. In case the boot process crashes, you can always boot from the normal EFI on the internal SSD.
  • To boot the system with the new EFI, press the appropriate function key at the BIOS Splash Screen to open your BIOS Boot Menu, then select the USB flash disk.
  • Also note that this method of disabling a GPU may no longer work under latest versions of Catalina and Big Sur.
 

Attachments

  • SSDT-Disable-GPU-Ext.aml
    227 bytes · Views: 24
Joined
May 10, 2012
Messages
60
Motherboard
X299 PRO/SE
CPU
I7 10920X
Graphics
RX-580 DELL OEM
Mac
  1. Mac Pro
Please try the attached SSDT. Some notes:
  • It's best to copy your working EFI folder to the EFI partition of a USB flash disk and add this SSDT to the USB flash disk. In case the boot process crashes, you can always boot from the normal EFI on the internal SSD.
  • To boot the system with the new EFI, press the appropriate function key at the BIOS Splash Screen to open your BIOS Boot Menu, then select the USB flash disk.
  • Also note that this method of disabling a GPU may no longer work under latest versions of Catalina and Big Sur.
It works. Thanks! So you used this path for construction of SSDT?
Code:
IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IOU1@7/IOPP/PXS2@0/IOPP/pci-bridge@4/IOPP/GFX1@0
Just curious what is the logic?
 
Joined
May 19, 2019
Messages
44
Motherboard
Gigabyte Z390 Designare
CPU
i9
Graphics
Vega FE
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Is there a way to set the default audio to load/boot on internal speakers ?

Every time the macOS boots up, it plays the chime through the headphones which is a good indication;
alcid = 28 in -> boot-args on the Z490 Vision D is working great as I have the green port on the back of the Vision D as set to internal. I got a front panel audio jack as set to headphones. For some reason it sets the default audio to play through headphones (Front Panel) not the green Rrear Back I\O.

I have OC 067 set in UEFI-> Audio -> audio device as (PciRoot(0x0)/Pci(0x1F,0x3)) which is correct.
I have UEFI -> Audio -> Play Chime -> enabled and audio support checked (true).
I tried UEFI -> Audio -> Audio out 0-4
None would play chime through the green port on Back I/O; only through the default headphones. Every boot sets the headphones as default audio no matter if I change to internal speakers in audio midi setup or system settings.

BTW, a side note. I had several issues with putting iMac 20,2 to sleep as it would wake from sleep instantly. How I solved this with even incorrect USB port map was I simply changed the BIOS operating system to BIOS -> Windows 10 instead of Other OS. For some reason Other OS in BIOS sets different power parameters and causes I/O internal display output along with sleep wake issues like others have XHCI , PEG1 ,PEG2 , and RP04. This tells the system to return zero and breaks the DSDT & SSDT patches. No matter how well the USB port map is configured, it still breaks the DSDT into multiple errors.

My system config as follows:
FenviT919 HS 11 internal port 2
USB 2.0 Front Panel HS 11 internal port 1
2 USB 3.0 Front Panel
Vega frontier liquid cool 16GB
Z490 Vision D
AIO Alpha Cool 360
i9-10900K
1TB SSD 970 Samsung Pro (macOS)
EVGA 1000W PSU
 

jd6

Joined
Mar 29, 2011
Messages
117
Motherboard
Gigabyte GA-Z490 Vision G
CPU
i5-11600k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi, guys! I just started buying parts to build my hackintosh again. So i bought the Z490 Vision G.

I want to ask about BIOS updates of the board .Does anyone know which version is stable, so that I can update to it.
To prevent any issues....with the build....?

Thanks.
 
Top