Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Feb 18, 2021
Messages
28
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900
Graphics
Radeon RX 580 8 GB
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
I would also recommend the following:
  1. BIOS F5 instead of the newer ones.
  2. Try disabling XMP Memory Profile in BIOS Setup.
Hi @CaseySJ,
  • 1. and 2. together worked! Nevertheless, the monitor must be reset manually to get the login screen. This seems to be a HDMI problem between the 4k monitor and the internal UHD 630 graphics.
  • With BIOS F5 and the XMP Memory Profile enabled the computer shuts down completely and reboots after "wakening" it up. Error message: Failed to get sleep type. rc:0xe00002c7
  • BIOS F20b and disabled XMP Memory Profile does not work, computer starts again within 2 seconds after sleep.
So it has something to do with the BIOS settings, but I do not want to loose 10% performance when disabling the XMP Memory Profile. Many thanks again for your help!
 
Joined
Sep 11, 2017
Messages
18
Motherboard
Gigabyte z490 vision D
CPU
i7-10700
Graphics
Intel® UHD Graphics 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi,

I just received all my parts and made an assembly without the case (not received yet) to check if everything is ok. The BIOS version is 5. It's better off sticking with this version of bios or updating.

Thank you,
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,279
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi @CaseySJ,
  • 1. and 2. together worked! Nevertheless, the monitor must be reset manually to get the login screen. This seems to be a HDMI problem between the 4k monitor and the internal UHD 630 graphics.
  • With BIOS F5 and the XMP Memory Profile enabled the computer shuts down completely and reboots after "wakening" it up. Error message: Failed to get sleep type. rc:0xe00002c7
  • BIOS F20b and disabled XMP Memory Profile does not work, computer starts again within 2 seconds after sleep.
So it has something to do with the BIOS settings, but I do not want to loose 10% performance when disabling the XMP Memory Profile. Many thanks again for your help!
Glad to hear it, sort of!

With XMP disabled we can set the memory multiplier to 26.66 or 29.33 to clock the memory at either 2666MHz or 2933MHz. Both of these are supported speeds in macOS and should allow sleep to work.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,279
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi,

I just received all my parts and made an assembly without the case (not received yet) to check if everything is ok. The BIOS version is 5. It's better off sticking with this version of bios or updating.

Thank you,
It is best to stay on BIOS version F5.
 
Joined
Sep 8, 2010
Messages
247
Motherboard
Gigabyte X299X-Designare-10G
CPU
i9-10980XE
Graphics
Radeon Pro WX 7100
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
- Yes, I did jumper wire connection like that
- It’s running the F16 Mod 11 Bios
- Ok, will try to flash it with that version.
-> what about you're NVM50 Mod for the Titan Ridge Card I found on a post of you?
Repository of Patched Thunderbolt Firmware Files

Extra note:
I accidentally flashed the ‘green’ chip too, but I had a backup made of it first so I flashed it back.


So I flashed it to the Z390 Firmware as you suggested, but no succes.
Still not seen by the system.
Can this be an SMBIOS issue? I'm using iMac13,2
@CaseySJ
I see that the Thunderbolt drivers also don't load on my system? Can this be an issue ?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,279
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ
I see that the Thunderbolt drivers also don't load on my system? Can this be an issue ?
Let’s take another look at your IOReg file. Please run IORegistryExplorer —> File —> Save As...

iMac13,2 is a 2012 model with Thunderbolt ports. So that should not be an issue.

Are you running Mojave, Catalina, or Big Sur?
 
Joined
Sep 8, 2010
Messages
247
Motherboard
Gigabyte X299X-Designare-10G
CPU
i9-10980XE
Graphics
Radeon Pro WX 7100
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Let’s take another look at your IOReg file. Please run IORegistryExplorer —> File —> Save As...

iMac13,2 is a 2012 model with Thunderbolt ports. So that should not be an issue.

Are you running Mojave, Catalina, or Big Sur?
@CaseySJ I will dump a IOReg tomorrow when I'm back in the studio.

Running Mojave latest version, up-to-date.

Where are you located ? I'm feeling a timezone difference :)
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,279
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ I will dump a IOReg tomorrow when I'm back in the studio.

Running Mojave latest version, up-to-date.

Where are you located ? I'm feeling a timezone difference :)
I am in the Pacific time zone. Same place where our favorite company (Apple) is located.
 
Joined
Sep 8, 2010
Messages
247
Motherboard
Gigabyte X299X-Designare-10G
CPU
i9-10980XE
Graphics
Radeon Pro WX 7100
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
I am in the Pacific time zone. Same place where our favorite company (Apple) is located.
Can it be that my modded BIOS is the problem?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,279
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Can it be that my modded BIOS is the problem?
Could be. Some BIOSes, whether modded or not, don't play well with GC-Titan Ridge.
 
Top