Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Feb 14, 2020
Messages
16
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10850K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
I managed to both install (from usb) and boot Mojave on Z490 Vision D with i9 10850K.
Use iMac19,1 as SystemProductName and for Emulate area (i9 9900K):View attachment 509377
Hi, can I use OpenCore install of Catalina for make installer for Mojave? Thanks.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,205
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi, can I use OpenCore install of Catalina for make installer for Mojave? Thanks.
Yes you can, but it will be necessary to make the change described here (see Troubleshooting / FAQs in Post 1):

Screen Shot 2021-02-19 at 4.56.04 AM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,205
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey @CaseySJ ! Sorry to bug you again...
As I was sayin last time I started typing, I'm growing a tiny bit of confidence so decided to experiment and see if I can make BT and Wifi work, so I've been trying with 0.6.6 from the *** Using Intel WiFi 6 and Intel Bluetooth 5 on Z490 Vision D *** guide, but had no luck.

I made the necessary changes to adapt the config.plist to my working config.plist (besides transferring platformNVRAM stuff), but after enabling verbose I see I'm getting stuck at this point:

View attachment 509833

Is this relevant to think about a possible solution or workaround or should I send you some other info?
Thanks in advance!
Please compress and post your EFI folder, but remove serial numbers from PlatformInfo --> DataHub.
 
Joined
Feb 14, 2020
Messages
16
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10850K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
Yes you can, but it will be necessary to make the change described here (see Troubleshooting / FAQs in Post 1):

View attachment 509871
OK, Are there any stability issues or other issues using Mojave? I have a Z490 Vision G with i9 10850k and RX 570 8GB that works perfectly, but Catalina is unusable for more than 50% of applications and therefore I would like to switch to Mojave. Thank you.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,205
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
OK, Are there any stability issues or other issues using Mojave? I have a Z490 Vision G with i9 10850k and RX 570 8GB that works perfectly, but Catalina is unusable for more than 50% of applications and therefore I would like to switch to Mojave. Thank you.
There are very few Mojave users in this thread (probably one or two), but I expect that Mojave is quite stable. System stability depends very much on whether the applications and third-party peripherals you use are compatible and tested with a given operating system.
 
Joined
Feb 14, 2020
Messages
16
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10850K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
There are very few Mojave users in this thread (probably one or two), but I expect that Mojave is quite stable. System stability depends very much on whether the applications and third-party peripherals you use are compatible and tested with a given operating system.
the hardware configuration is:

Gigabyte Z490 Vision G
Intel i9 10850K
64Gb Ram (2x 32Gb DDR4 3200Mhz)
WiFi & Bluetooth - MQUPIN BCM94360CD Fenvi FV T919
2x NVME Samsung EVO 970 1Tb SSD

I think it should all be compatible with Mojave, but not being an expert the only solution is to try and check what doesn't work
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,205
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
the hardware configuration is:

Gigabyte Z490 Vision G
Intel i9 10850K
64Gb Ram (2x 32Gb DDR4 3200Mhz)
WiFi & Bluetooth - MQUPIN BCM94360CD Fenvi FV T919
2x NVME Samsung EVO 970 1Tb SSD

I think it should all be compatible with Mojave, but not being an expert the only solution is to try and check what doesn't work
The hardware components are okay. Do you plan to use an AMD GPU or the iGPU? System stability will be impaired if you use iGPU for some A/V applications. For example, iMovie and Final Cut Pro will crash immediately. So AMD GPU is highly recommend (if you can find one, that is)!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,205
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Long time no see, teacher. I'm going to build a new system using MSI Z490i this time. Do I have to make a firmware to upgrade the Thunderbolt firmware of MSI Z490i?
Hello @REXXVER,

The MSI Z490i has one Thunderbolt 3 port, which will work with most Thunderbolt devices. It is not necessary to flash the firmware in most cases. My recommendation is to test your Thunderbolt devices first and let us know if they don't work.
 
Joined
Dec 10, 2018
Messages
15
Motherboard
Gigabyte Z490 Vision D
CPU
Intel Core i9 10900
Graphics
-
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Hello ! some news of my issues !

Your hardware profile says Asrock Z390 Phantom Gaming. Is that the mobo you are using ?
That was indeed my first build ! but I move to this one !
Please check if OpenCore Configurator --> Misc --> Security --> SecureBootModel is set to Default (not Disabled). This is a prerequisite for the OpenIntelWireless driver (AirportItlwm).
Does this happen on certain pages only or on all pages? Have you tried clearing history (History --> Clear History...)?

It was that ! (SecureBootModel) Thank you !
But that's where the trouble begins haha

Regarding the problem on Safari, I had no problem on my first attempt to install
(I had used the EFI provided in the first post but putting iMac20,2 in the model and everything worked fine)

When I used the wireless EFI I encountered other issues.
A few plug-ins in my DAW just didn't want to run.
I managed to get one to work (after some hard research) by executing a command in the terminal that allowed to disable Graphics acceleration for plug-ins "com.fabfilter.Common GraphicsAcceleration -int 0"
But some just didn't want to boot, or made me crash my DAW.

So I decided to do a new installation this morning, based on the EFI from the first post (OC-066-VISION-D) and based on the iMac20,2 model.
Everything works very well (safari, daw, plugins ... without any intervention)

But when I switch on the EFI Wireless (By recovering all the serial numbers etc) the problems on safari, my DAWs and plug-ins come back... But wifi and bluetooth is ok haha.

thank you in advance for your help !
 
Top