Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Jul 14, 2020
Messages
173
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
Sapphire RX6800
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thank you for clarifying. Alas @Higgie is not going to be happy. Unfortunately I mentioned incorrectly that someone had reported the Razer Core X to work with original firmware.
I experimented some more today and couldn’t get it to work, so unfortunately that looks to be correct! No problem though. It was a long shot to begin with. I got a good deal so I doubt I will lose money. If any of my fellow UK Hackintoshers with flashed firmware are after a Razer Core X, hit me up!
 
Joined
Feb 15, 2021
Messages
6
Motherboard
Gigabyte Z490 Vision G
CPU
i7-10700K
Graphics
RX 5500 XT
Hello @JMMeFF,

I noticed that there's no Serial number assigned to your system. Your first screenshot (About this Mac) shows that serial number is ** Enter System Serial Number **. Have you specified System Serial Number, Board Serial Number (MLB), System UUID, and ROM in the PlatformInfo --> DataHub section of config.plist as indicated in the guide?

Also note that F1/F2 are meant to change screen brightness. They are not associated with sleep/wake. It sounds as if your monitor does not wake from sleep unless you disconnect and reconnect the video cable. Is that right? If so, what is the make/model of the monitor and are you using the HDMI port on one of the two Thunderbolt ports?
i haven't done entering those serial numbers as i'm confused on where to get it. Is it base on the iMac19.1 system provided in hackintool or should i use the z490 board details? sorry for the question i don't really get this section.

My monitor is ASUS VA24E connected via iGPU HDMI, it's behaving exactly as what your saying. when the monitor turned-off, either i off/on the power switch or disconnect/reconnect the cable to get it back
 
Joined
Oct 27, 2010
Messages
133
Motherboard
Gigabyte P55A-UD4
CPU
i7 860
Graphics
Radeon HD 5670
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. LC
  2. PowerBook
  3. SE
Mobile Phone
  1. iOS
Strange behavior in Mojave, internal audio ALC1220 and Intel's i225-V don't work. For audio Lilu, AppleALC and AppleHDAController is shown in kextstat. In Catalina is all up and running with same config.plist. Is there supplemental work to do on audio for Mojave ?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,851
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
i haven't done entering those serial numbers as i'm confused on where to get it. Is it base on the iMac19.1 system provided in hackintool or should i use the z490 board details? sorry for the question i don't really get this section.

My monitor is ASUS VA24E connected via iGPU HDMI, it's behaving exactly as what your saying. when the monitor turned-off, either i off/on the power switch or disconnect/reconnect the cable to get it back
The easiest way to populate serial numbers is by visiting the HackinDROM website and doing the following:
Screen Shot 2021-02-16 at 6.32.16 AM.png


Screen Shot 2021-02-16 at 6.35.02 AM.png
 
Joined
Sep 25, 2018
Messages
241
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
  2. Mac mini
Mobile Phone
  1. Android
- All above statements are correct
- OC 0.66 following your EFI and upgrade process since the beginning
- No other third part apps except Firefox. The purpose on this install is to run Photo apps on V 5.0 for a customer. My BS OS would upgrade his library and this is obviously not suitable.
- The KP happens really at random, initially sometimes even as early as during the the install process.
- When install is fine, the boot is always normal but then KP can happen when Photo is running and going into the "curating best photos" process
- The KP can happen even if I don't interfere with the machine, just looking at the progress of the job
- I don't have screen capture but, looking at the log, it seems that the main issues (at random) are linked to mds and mdworker.

Once again, thanks for your time...

A little up in case someone has any idea ;-)
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,851
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Strange behavior in Mojave, internal audio ALC1220 and Intel's i225-V don't work. For audio Lilu, AppleALC and AppleHDAController is shown in kextstat. In Catalina is all up and running with same config.plist. Is there supplemental work to do on audio for Mojave ?
Which build guide did you follow?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,851
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
A little up in case someone has any idea ;-)

- All above statements are correct
- OC 0.66 following your EFI and upgrade process since the beginning
- No other third part apps except Firefox. The purpose on this install is to run Photo apps on V 5.0 for a customer. My BS OS would upgrade his library and this is obviously not suitable.
  • Are you building and selling a Hackintosh to a customer?
- The KP happens really at random, initially sometimes even as early as during the the install process.
- When install is fine, the boot is always normal but then KP can happen when Photo is running and going into the "curating best photos" process
- The KP can happen even if I don't interfere with the machine, just looking at the progress of the job
- I don't have screen capture but, looking at the log, it seems that the main issues (at random) are linked to mds and mdworker.
 
Joined
Sep 25, 2018
Messages
241
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
  2. Mac mini
Mobile Phone
  1. Android
  • Are you building and selling a Hackintosh to a customer?


No :)
I am upgrading a Macbook Air for him from Mountain Lion to Catalina with 2 huge Photo libraries.
The purpose is to merge the libraries on a Catalina session running on the hackintosh, as copies and post treatment run much faster than on his poor MBA with only 4Go RAM, and then transfer back the final directory on the MBA.
I can't run it on BS as the libraries would be upgraded and no longer compatible back to Catalina.
 
Joined
Oct 27, 2010
Messages
133
Motherboard
Gigabyte P55A-UD4
CPU
i7 860
Graphics
Radeon HD 5670
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. LC
  2. PowerBook
  3. SE
Mobile Phone
  1. iOS
Which build guide did you follow?
This guide for Catalina, then changed SystemProductName to 19,1 and CPUID in kernel -> emulate as described in my previous post. Have tried also other layout id.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,851
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
No :)
I am upgrading a Macbook Air for him from Mountain Lion to Catalina with 2 huge Photo libraries.
The purpose is to merge the libraries on a Catalina session running on the hackintosh, as copies and post treatment run much faster than on his poor MBA with only 4Go RAM, and then transfer back the final directory on the MBA.
I can't run it on BS as the libraries would be upgraded and no longer compatible back to Catalina.
Understood.

Because Catalina is working properly on the migrated disk, have you considered doing this on that system? If you launch the Photos app with Option key held down, you will get this dialog:
Screen Shot 2021-02-16 at 7.05.44 AM.png

If your friend's library is on a separate disk, you can click "Other Library..." to open your friend's library and make all the changes to that disk without affecting your own Photos library.

But always good to make a full backup of your system first!
 
Top