Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,288
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,805
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** CORRECTION to OpenCore 0.6.3 Mini-Guide **

If you recently upgraded to OpenCore 0.6.3, please note that the instructions for Board Serial Number were wrong.
  • The original OpenCore 0.6.3 mini-guide instructed you to copy Board ID from Hackintool into the MLB field in OpenCore Configurator.
  • However, we need to copy Board Serial Number from Hackintool (as shown below) into MLB.
  • Please make this correction. Your original Board Serial Number can be found in the previous OpenCore 0.6.2 config.plist.

Screen Shot 2020-11-06 at 3.47.17 AM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,805
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
hey Casey:

My build is using iMacPro1,1 and I have the Device Property for iGPU enabled. Everything seems to be running smooth. Should I disable the entry?
Technically we should disable the Device Property entry for iGPU when iGPU is disabled in BIOS. Keeping it won't cause any harm, but it's best to disable it.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,805
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Here it is.
As shown below, your Thunderbolt configuration is half good, half bad. The bad part includes the USB ports and both of the Thunderbolt ports.

Please post your Thunderbolt SSDT.

Screen Shot 2020-11-06 at 4.06.24 AM.png
 
Joined
Jun 2, 2020
Messages
39
Motherboard
GIGABYTE Z490 Aorus Master
CPU
i9-10900K
Graphics
RX 580
@CaseySJ Ok, this happens, when using your SSDT-TB3HP.aml. Now i've tried my old tb.aml and everything looks fine again.
 

Attachments

  • TB-ACPI.zip
    4 KB · Views: 26

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,805
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ Ok, this happens, when using your SSDT-TB3HP.aml. Now i've tried my old tb.aml and everything looks fine again.
Interesting! The main difference between the two files is that mine is enclosed in the conditional block:
Code:
if (_OSI ("Darwin"))
{
    // Create Thunderbolt device tree
}
Anyway, please continue to use your file.
 
Joined
Apr 25, 2011
Messages
31
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 5700 XT
Technically we should disable the Device Property entry for iGPU when iGPU is disabled in BIOS. Keeping it won't cause any harm, but it's best to disable it.
My iGPU is enabled in BIOS but I can't see it in System Information. So it's not in headless mode, right?

Maybe because my hackintosh is configured as an iMacPro1,1?
 
Joined
Feb 23, 2020
Messages
126
Motherboard
Dell Precision M4700
CPU
i7-3740QM
Graphics
M4000
My iGPU is enabled in BIOS but I can't see it in System Information. So it's not in headless mode, right?

Maybe because my hackintosh is configured as an iMacPro1,1?
macOS doesn't show the iGPU anywhere if it's in headless mode. Only well to tell is to see if the Intel iGPU driver is attached to the iGPU in the IORegistry.
 
Joined
Oct 22, 2020
Messages
40
Motherboard
Gigabyte Z490 Vision D
CPU
i9 10900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Found a weird issue with Catalina on my i9 490 D build. In System Prefs it says not connected to network, but I am. I have an IP address when I scan for it, but it is not connected in Network settings. If I turn it off in Network settings, I am still connected. Any ideas what is going on?
 
Joined
Jun 1, 2013
Messages
215
Motherboard
Gigabyte Z490 Vision D
CPU
I7-10700K
Graphics
5600XT & 6800 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
Is Automatic Login enabled?
Yes it is. Note that this issue does not happen all the time when I boot but it is common
 
Top