Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Dec 23, 2019
Messages
4
Motherboard
Z490 Vision D
CPU
10700K
Graphics
Radeon 580
@CaseySJ Thanks a lot for such a very thorough guide. I was able to install Catalina with i7-10700K on Vision D in almost one click with modified Thunderbolt ROM. Works like a charm, didn't figure out any issues.

Hardware I used:
Intel Core i7-10700K Desktop Processor
GIGABYTE Z490 Vision D
Samsung 970 PRO 512GB NVMe M.2 Internal SSD (MZ-V7P512BW) [Canada Version]
AC1750 Dual Band Wireless Card, BCM94360CD Desktop 5G
Corsair CP-9020178-NA RMX Series RM650x 80 Plus Gold Fully Modular ATX Power Supply
G.SKILL Ripjaws V Series DDR4 3600MHz 32GB(16GBx2) Memory Kit
Corsair 4000D Tempered Glass Mid-Tower ATX PC Case - White, CC-9011199-WW
MSI Radeon 580 8Gb
KeeYees SOP8 SOIC8 Test Clip and CH341A USB Programmer (as a SOIC8 clip only)
Raspberri Pi Zero W (via SSH :))

Few pics attached :)

IMG_1649.jpeg
IMG_1650.jpeg
IMG_1652.jpeg
IMG_1651.jpeg
IMG_1653.jpeg
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,188
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Yes, all was working flawlessly with the z390 and mojave, later I update to catalina and still was working properly.
I believed that with the z490 and opencore was gonna working equally, but I think I should have reading more information before the upgrade
Do I remember correctly that you flashed the Z390 Designare in order to use the Slate VRS8? Were there some other settings that needed to be applied? There was some mention of "luckyal" and his findings.

Meanwhile, it is also possible to flash the firmware from Z390 Designare to the Z490 Vision D. However, it seems that Thunderbolt is NOT the issue now. The Slate VRS8 is connecting, but the Slate drivers are not recognizing the device.

Also do the following:
  • With the Slate connected, run IORegistryExplorer and select File --> Save As..., then post the saved file.
  • With the Slate connected, open Terminal and type kextstat | grep -v apple and post the output.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,188
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ Thanks a lot for such a very thorough guide. I was able to install Catalina with i7-10700K on Vision D in almost one click with modified Thunderbolt ROM. Works like a charm, didn't figure out any issues.

Hardware I used:
Intel Core i7-10700K Desktop Processor
GIGABYTE Z490 Vision D
Samsung 970 PRO 512GB NVMe M.2 Internal SSD (MZ-V7P512BW) [Canada Version]
AC1750 Dual Band Wireless Card, BCM94360CD Desktop 5G
Corsair CP-9020178-NA RMX Series RM650x 80 Plus Gold Fully Modular ATX Power Supply
G.SKILL Ripjaws V Series DDR4 3600MHz 32GB(16GBx2) Memory Kit
Corsair 4000D Tempered Glass Mid-Tower ATX PC Case - White, CC-9011199-WW
MSI Radeon 580 8Gb
KeeYees SOP8 SOIC8 Test Clip and CH341A USB Programmer (as a SOIC8 clip only)
Raspberri Pi Zero W (via SSH :))

Few pics attached :)
Hello @happyjohn78,

Welcome to the forum, and what an entrance!
  • No issues with installation.
  • Thunderbolt firmware flashed.
  • And I trust you're also using a custom Thunderbolt DROM?
Flashing the Thunderbolt firmware (successfully) also inducts you into the Society of Mad Scientists. :)

Good job.
 
Joined
Dec 23, 2019
Messages
4
Motherboard
Z490 Vision D
CPU
10700K
Graphics
Radeon 580
Hello @happyjohn78,

Welcome to the forum, and what an entrance!
  • No issues with installation.
  • Thunderbolt firmware flashed.
  • And I trust you're also using a custom Thunderbolt DROM?
Flashing the Thunderbolt firmware (successfully) also inducts you into the Society of Mad Scientists. :)

Good job.
LOL - I like that name - Society of Mad Scientists :D

I didn't dig deep into the customizing Thunderbolt DROM - I used one you prepared and uploaded in your tutorial. Read it, checked it (manually) and used after that. Just need machine to be in work condition today.
 
Joined
Jun 22, 2019
Messages
52
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700
Graphics
Rx 580
Do I remember correctly that you flashed the Z390 Designare in order to use the Slate VRS8? Were there some other settings that needed to be applied? There was some mention of "luckyal" and his findings.

Meanwhile, it is also possible to flash the firmware from Z390 Designare to the Z490 Vision D. However, it seems that Thunderbolt is NOT the issue now. The Slate VRS8 is connecting, but the Slate drivers are not recognizing the device.

Also do the following:
  • With the Slate connected, run IORegistryExplorer and select File --> Save As..., then post the saved file.
  • With the Slate connected, open Terminal and type kextstat | grep -v apple and post the output.
I don't remember the tutorial of flashing the z390 was available, I think it was on testing back then. According to @luckyal , the changes we had to do to make it work was add VirtualSMC, aptiofix kexts and the VT-d enabled removing dart-0. This was the solution to get the VRS8 to work finally, thanks to this post.
I attached the IOregistry explorer file, and here its the terminal output:
Code:
Last login: Fri Oct 23 10:44:04 on console
favius@iMac-de-Favio ~ % kextstat | grep -v apple
Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
   44    6 0xffffff7f83ee4000 0x2b000    0x2b000    as.vit9696.Lilu (1.4.7) 141DD55D-6559-32B6-8DBF-7DA82899F24C <8 6 5 3 2 1>
   45    0 0xffffff7f83f28000 0x73000    0x73000    as.vit9696.WhateverGreen (1.4.2) BB5F3959-8912-38FC-A69D-C462DAADABF5 <44 13 8 6 5 3 2 1>
   46    0 0xffffff7f83fbf000 0x10000    0x10000    com.rehabman.driver.USBInjectAll (0.7.6) 6C5A1DEA-E541-3792-81AF-D18B6E8D4877 <13 12 5 3>
   47    0 0xffffff7f83fdc000 0x152000   0x152000   as.vit9696.AppleALC (1.5.2) B92552C1-342C-3F6C-98E7-29114F153FB2 <44 13 8 6 5 3 2 1>
   48    0 0xffffff7f84161000 0xd000     0xd000     org.acidanthera.NVMeFix (1.0.3) 8A509CC1-2E1F-3BE8-B49E-B0EBF9456DBD <44 8 6 5 3 2 1>
   49    2 0xffffff7f83f0f000 0x19000    0x19000    as.vit9696.VirtualSMC (1.1.6) 98DF55F9-208E-33F2-9D45-B6996F04B981 <44 12 8 6 5 3 2 1>
   50    0 0xffffff7f83fa1000 0xb000     0xb000     as.vit9696.SMCProcessor (1.1.6) BABDA5A4-2011-3AAF-BA37-9B43399675B5 <49 44 12 8 6 5 3 2 1>
   73    0 0xffffff7f84138000 0x29000    0x29000    as.acidanthera.mieze.IntelMausi (1.0.3) 3AF5B32A-0530-3745-A3E4-9874C5F629A5 <32 13 6 5 3 1>
   74    0 0xffffff7f83fac000 0x10000    0x10000    ru.joedm.SMCSuperIO (1.1.6) 61A38355-DF29-36A6-9A80-8BD1D508C25D <49 44 12 8 6 5 3 2 1>
   79    0 0xffffff7f83fcf000 0xd000     0xd000     org.rehabman.driver.FakePCIID (1.3.15) B185B092-1FC9-308E-B093-32FD88E5822D <13 8 6 5 3 1>
  112    3 0xffffff7f84176000 0xf2000    0xf2000    org.virtualbox.kext.VBoxDrv (6.1.14) 66D76320-0587-357B-A765-7F23556169B6 <8 6 5 3 1>
  129    0 0xffffff7f8496e000 0x16000    0x16000    net.egosys.driver.VRS8Audio (1.03) 67404F56-C667-3B52-BFBA-20C29DD51F3D <86 13 6 5 3>
  134    0 0xffffff7f849c7000 0x11000    0x11000    jp.co.roland.RDUSB0156Dev (1.0.3) EED87B79-9EB6-3E3D-9603-B8A0477A894E <21 6 5 3>
  153    0 0xffffff7f84d6d000 0x9000     0x9000     com.Sonarworks.driver.Sonarworks (1.8.11) EB8C008E-8442-36E1-AEA6-2C9717CD3D71 <86 6 5 3 1>
  160    0 0xffffff7f84e02000 0xb000     0xb000     org.virtualbox.kext.VBoxUSB (6.1.14) C57E35FF-8F45-3CAF-801A-3A65B4BF367D <159 112 66 8 6 5 3 1>
  161    0 0xffffff7f84e0d000 0x6000     0x6000     org.virtualbox.kext.VBoxNetFlt (6.1.14) D7389BD6-6A3D-3956-A1A7-85463D0DC8B0 <112 8 6 5 3 1>
  162    0 0xffffff7f84e13000 0x7000     0x7000     org.virtualbox.kext.VBoxNetAdp (6.1.14) 71E63654-374F-38B3-BA55-22231400D3D3 <112 6 5 1>
 

Attachments

  • IO Registry Explorer Fabrizzioa04.ioreg
    13.9 MB · Views: 18
Joined
Jun 22, 2019
Messages
52
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700
Graphics
Rx 580
@CaseySJ I just noticed that I can't see or use the internal audio of the Z490 on the macOS, I don't know if this may be related with the mainly issue.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,188
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I don't remember the tutorial of flashing the z390 was available, I think it was on testing back then. According to @luckyal , the changes we had to do to make it work was add VirtualSMC, aptiofix kexts and the VT-d enabled removing dart-0. This was the solution to get the VRS8 to work finally, thanks to this post.
I attached the IOregistry explorer file, and here its the terminal output:
Have you tried enabling VT-d in BIOS on the Z490 Vision D and making the following changes to OpenCore config.plist?
  • WARNING:
    • Copy your EFI folder to the EFI partition of a USB flash disk. Do not make these changes to the EFI folder on the internal SSD.
  • Enable VT-d in BIOS.
  • On the USB flash disk, mount EFI partition and make these changes to OpenCore config.plist:
    • NVRAM --> Boot-Args: Remove dart=0 from the boot argument string
    • Kernel --> DisableIOMapper: uncheck this as shown:
      Screen Shot 2020-10-23 at 11.53.11 AM.png
  • Reboot and press F12 at BIOS splash screen. Then select USB flash disk from BIOS Boot Menu.
  • Boot macOS.
  • NOTE:
    • MacOS may or may not boot
Also, we can see from the Terminal output that the VRS8 driver has loaded, so this is a good sign:

129 0 0xffffff7f8496e000 0x16000 0x16000 net.egosys.driver.VRS8Audio (1.03) 67404F56-C667-3B52-BFBA-20C29DD51F3D <86 13 6 5 3>


@CaseySJ I just noticed that I can't see or use the internal audio of the Z490 on the macOS, I don't know if this may be related with the mainly issue.
This is most likely an unrelated issue. We can come back to this later.
 
Joined
Jun 22, 2019
Messages
52
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700
Graphics
Rx 580
Have you tried enabling VT-d in BIOS on the Z490 Vision D and making the following changes to OpenCore config.plist?
  • WARNING:
    • Copy your EFI folder to the EFI partition of a USB flash disk. Do not make these changes to the EFI folder on the internal SSD.
  • Enable VT-d in BIOS.
  • On the USB flash disk, mount EFI partition and make these changes to OpenCore config.plist:
    • NVRAM --> Boot-Args: Remove dart=0 from the boot argument string
    • Kernel --> DisableIOMapper: uncheck this as shown: View attachment 492947
  • Reboot and press F12 at BIOS splash screen. Then select USB flash disk from BIOS Boot Menu.
  • Boot macOS.
  • NOTE:
    • MacOS may or may not boot
Also, we can see from the Terminal output that the VRS8 driver has loaded, so this is a good sign:

129 0 0xffffff7f8496e000 0x16000 0x16000 net.egosys.driver.VRS8Audio (1.03) 67404F56-C667-3B52-BFBA-20C29DD51F3D <86 13 6 5 3>



This is most likely an unrelated issue. We can come back to this later.
Its working again! This was the solution! @CaseySJ Thanks for your help with this second Hackintosh now!
Screen Shot 2020-10-23 at 14.33.46.png
 
Joined
Feb 20, 2015
Messages
8
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX570
Mac
  1. iMac
Mobile Phone
  1. iOS
*** Using Intel WiFi 6 and Intel Bluetooth 5 on Z490 Vision D ***
Fantastic guide! Thank you! Everything works good so far. Just Wifi is not working. Bluetooth is fine, no problems. But Wifi is not shown in System Report.
 
Top