Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,286
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey Guys,
Need a little advice on choosing a second NVME for the middle M.2 slot.
Its down to either the Sabrent Rocket or the Rocket Q. The non Q version
seems to be a little faster but not that much and has a little bit newer tech in it.

Are they both compatible with this build ? Is it worth the extra $ or would I just be paying for that bump in speed.

Any knowledge anyone has about this would be great.

Thanks!
The Q series uses quad-level cells that increase storage density and reduce cost at the expense of a bit of read/write performance. In most real-world applications you won't notice the difference. Quad cell devices provide higher capacities at lower cost and are well worth considering.
 
Joined
Dec 26, 2010
Messages
85
Motherboard
Gigabyte Designare Z490
CPU
i9-10850K
Graphics
Sapphire AMD Radeon RX 5700 XT Pulse (SLOT-1), MSI Nvidia GeForce 980 Ti (SLOT-2)
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
@CaseySJ Is there a new version for the "SSDT-GPRW.aml" : "Disable wake from USB/Bluetooth; wake only with power button" ? I activated the one from the OC161 bundle in the OpenCore config, but USB keypresses still wake the system, unfortunately.
Would be very cool!

I only had it working on the Z390 Designare with Clover.
 
Joined
May 31, 2016
Messages
939
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
I updated my system to 10.15.7, and it seems to (partially) address my question about the 2nd boot stage; the driver seems to connect to my RX 5700 XT much quicker now. The monitors do not go into sleep (but they do go black for a few seconds), and the graphics card immediately shows up in 'About This Mac' and System profiler now; before they would take a few seconds to populate.

If it's helpful, I'm on Sapphire Nitro+ and it -seems- the the video card ports dynamically enumerate in some fashion. I might try and hard code the connector types and see if it locks them in.
 
Joined
Sep 23, 2020
Messages
7
Motherboard
Gigabyte Z490 Vision D
CPU
i9 10900
Graphics
RX 580
Other users have had problems with the Fenvi FV-T919 WiFi/BT card, try sleep with this card removed.

Well... this was interesting. I removed the Fenvi and sleep worked... the first time I tested it. Though the fans never fully shut off, it acted like it was sleeping. I put the case back together and sleep never worked again. No matter what I tried, it would always just shut down. So, I decided to rebuild the EFI from scratch (keeping the same serial numbers). I still left the Fenvi card out. I booted the BIOS and rebuilt the settings, then proceed to Mac boot with the "new" EFI. No difference except... now there is no entity (BIOS or Opencore) that can see my windows SSD to boot from it. The BIOS can see the disk, just not enough to see the boot files. What could have caused this?? I should have known better than to start this before the weekend. :lol: Oh, the NZXT controller has been disconnected the whole time.

I guess I'll try doing a fresh install this weekend on a spare drive and see if sleep starts to work then. BTW, does it matter what fan profile I set in the BIOS? Or does the MacOS always do its own thing after booting?

Thanks for the advice so far. I'll let everyone know how it goes.

Ed
 
Joined
Aug 22, 2020
Messages
25
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700k
Graphics
6800xt
Well... this was interesting. I removed the Fenvi and sleep worked... the first time I tested it. Though the fans never fully shut off, it acted like it was sleeping. I put the case back together and sleep never worked again. No matter what I tried, it would always just shut down. So, I decided to rebuild the EFI from scratch (keeping the same serial numbers). I still left the Fenvi card out. I booted the BIOS and rebuilt the settings, then proceed to Mac boot with the "new" EFI. No difference except... now there is no entity (BIOS or Opencore) that can see my windows SSD to boot from it. The BIOS can see the disk, just not enough to see the boot files. What could have caused this?? I should have known better than to start this before the weekend. :lol: Oh, the NZXT controller has been disconnected the whole time.

I guess I'll try doing a fresh install this weekend on a spare drive and see if sleep starts to work then. BTW, does it matter what fan profile I set in the BIOS? Or does the MacOS always do its own thing after booting?

Thanks for the advice so far. I'll let everyone know how it goes.

Ed

I built mine in a H710i and used the NZXT controller for the case fans. It never affected sleep/wake for me. Only the Fenvi card cause sleep/wake issues which I eventually replaced with a Youbo. So it may not be the controller.
 
Joined
Jul 1, 2015
Messages
9
Motherboard
Gigabyte Z490 Vision G
CPU
i7-10700K
Graphics
RX 570
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I had a problem with sleep mode - the display became off and the computer shut down for a second but then start working again.
So I start searching for resolving this and... it was pretty simple - I just forget to uncheck "Wake for network access" (Energy Saver --> Wake for network access)
Now all works fine.

The only question I have - there are a lot of values for AAPL,ig-platform-id (that you can find here https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md), so what is the best one for my Core i7-10700K that I want to use in headless mode?
 
Joined
Sep 23, 2020
Messages
14
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 5700 XT
Have a few questions if grace can be extended for me

Again on my setup:

Vision D z490
I9-10900k
32GB 3600 RAM
GPU - Saphire RX 5700 XT Nitro+ SE

1. saw someone chose at setup iMac 20,1 vs per tutorial iMac19,1. Should I have done the same with my setup. Was there any benefit in choosing a newer iMac vs?

2. I have 2 x NVMe M.2 drives installed - one for Windows and one for macOS. First Windows drive is installed closest to CPU. I have the macOS drive installed in M2P_SB. Is that the right place to do install it or M2M_SB? Does it change anything if I get a second GPU for windows (RTX)

3. I was able to stabilize the monitor going off at load up using HDMI cable and switching the ports. I purchased the displayport but I can't make it work with that. Any suggestions?

Thank you
 
Joined
Jul 1, 2015
Messages
9
Motherboard
Gigabyte Z490 Vision G
CPU
i7-10700K
Graphics
RX 570
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
1. saw someone chose at setup iMac 20,1 vs per tutorial iMac19,1. Should I have done the same with my setup. Was there any benefit in choosing a newer iMac vs?

As I understand from some articles for i9-10900K you should use iMac 20,2, not the iMac 20,1. (It should be used for i5 and i7 CPU's configurations.)
 
Top