Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Apr 5, 2016
Messages
949
Motherboard
GIGABYTE Z170X-Gaming 7
CPU
i7-6700K
Graphics
GTX TITAN X
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Apple
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
yeah just deleted overrides and the display now recognized itself as usual 'Dell P4317Q' with color format YPbPr
and if I change in Monitor to RGB format it looks all red:(

I really don't know how to fix the Lilu + WhateverGreen and make correct patch which will allow to use the RGB format on display?

format YPbPr

format RGB
What does Input Source say?
 
Joined
Apr 27, 2013
Messages
157
Motherboard
GA-Z490 Vision D
CPU
i9-10900K
Graphics
UHD 630
Mac
  1. iMac
What does Input Source say?

says that's DP is on using 2560x1440, 60Hz

also I discover that my usb-c to DP cable is DP1.2, but not 1.4 version and I don't know if it's really so critical:confused:
Recently I have a problem with this cable, sometimes it flickers and display goes black for a few seconds.:-X

Pic3.jpg
 
Last edited:
Joined
Apr 5, 2016
Messages
949
Motherboard
GIGABYTE Z170X-Gaming 7
CPU
i7-6700K
Graphics
GTX TITAN X
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Apple
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
says that's DP is on using 2560x1440, 60Hz

also I discover that my usb-c to DP cable is DP1.2, but not 1.4 version and I don't know if it's really so critical:confused:
Recently I have a problem with this cable, sometimes it flickers and display goes black for a few seconds.:-X
DP1.2 is sufficient. I think the only problem is that it is defaulting to YCbCr color instead of RGB and that you can't get it to output 4K 60Hz. Consider looking at Hackintool and Whatevergreen. There are separate threads for those.
 
Joined
Dec 26, 2010
Messages
85
Motherboard
Gigabyte Designare Z490
CPU
i9-10850K
Graphics
Sapphire AMD Radeon RX 5700 XT Pulse (SLOT-1), MSI Nvidia GeForce 980 Ti (SLOT-2)
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Does anyone else here with an RX 5700XT experience a behavior that the monitor goes to sleep (black screen) between the Apple logo/progress bar and the desktop login?

-D

Yes. I also have a Z490 Vision G and installed a Sapphire Radeon RX 5700 XT Pulse.
I am currently troubleshooting these problems with the help of some wonderful people on this forum. However, I have ordered a Vision D motherboard for testing and will report if the situation is motherboard dependent in my case.


Stay tuned!
 
Joined
Dec 11, 2015
Messages
7
Motherboard
Z490 Vision D
CPU
10700K
Graphics
5700 XT
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hi CaseySJ,

Thank you very much for this great build! I've finished a setup with Vision D motherboard, Installation was very smooth with your guide! The only problem that I have experience is mouse feels like bit delayed. (I'm using a USB mouse and keyboard). It is not lagging but I feel like there is a input delay. I have 5700XT GPU. Finally I have a question about WIFI/BT options for vision d.


Is it possible to use m.2 Wlan unit with Vision D motherboards ? Thanks!

https://www.amazon.ca/dp/B083YXS7VF/?tag=tonymacx86c0c-20
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,153
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi CaseySJ,

Thank you very much for this great build! I've finished a setup with Vision D motherboard, Installation was very smooth with your guide! The only problem that I have experience is mouse feels like bit delayed. (I'm using a USB mouse and keyboard). It is not lagging but I feel like there is a input delay. I have 5700XT GPU. Finally I have a question about WIFI/BT options for vision d.


Is it possible to use m.2 Wlan unit with Vision D motherboards ? Thanks!

https://www.amazon.ca/dp/B083YXS7VF/?tag=tonymacx86c0c-20
Hello @Enceylan,

Glad to hear the build is up and running. If you're using a wired USB mouse, try another USB port. If you're using a wireless USB mouse (such as Logitech Unifying mice) check for any metal objects in the line of sight between the USB Unifying Receiver and the mouse.

As for the BCM94360NG or any other M.2 WiFi/BT card, I'm afraid only Intel CNVi modules will work there. That is not a general purpose M.2 slot, but an Intel proprietary slot.
 
Joined
May 15, 2020
Messages
1,306
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Glad to hear the build is up and running. If you're using a wired USB mouse, try another USB port. If you're using a wireless USB mouse (such as Logitech Unifying mice) check for any metal objects in the line of sight between the USB Unifying Receiver and the mouse
I would like to add that if there's a USB stick or external storage drive near of the wired USB device port that can create interferences.
I know wired is for wired connection but a little usb cable extension can help with that
 
Joined
Oct 24, 2013
Messages
1,021
Motherboard
Asus ROG Z690 Formula
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
For those having black screen issues with AMD cards in the Vision D, I was having a black screen/flickering issue. I’m running a dual 1440p monitor setup, one monitor is 144hz the other is 60 Hz.

With my Radeon 7, the 144 Hz monitor (over hdmi) was encountering flickering and an eventual black screen (in both Catalina and Big Sur) soon after macOS boot if my fenvi wifi card had WiFi enabled and was connected to a network. However, either switching off WiFi or switching to DisplayPort (from HDMi) fixed the issue for me.
 
Last edited:
Joined
Apr 27, 2013
Messages
157
Motherboard
GA-Z490 Vision D
CPU
i9-10900K
Graphics
UHD 630
Mac
  1. iMac
DP1.2 is sufficient. I think the only problem is that it is defaulting to YCbCr color instead of RGB and that you can't get it to output 4K 60Hz. Consider looking at Hackintool and Whatevergreen. There are separate threads for those.
could you tell me where such thread is located...?, that I don't go wrong, thanks!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,153
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi! I'm using the same hardware, used your EFI folder and all seem to work great. I have some questions. Is there a way to change the standard SATA controllers name and SSD/NVMe controller name to something else? Right now they show as GENERIC. I'm not sure if it is just cosmetic or they do affect performance. Thanks for the great guide.
This is purely cosmetic, but we can still change it in 2 steps:
Screen Shot 2020-09-22 at 2.23.28 AM.png
Screen Shot 2020-09-22 at 2.23.22 AM.png
 
Top