Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,096
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** Guides have been updated for OpenCore 0.6.1 **
Please see this post:
It is necessary once again to copy the following values into one of the new config files:
  • Serial Number
  • Board Serial Number
  • System UUID
These are easily copied-and-pasted from Hackintool:
Screen Shot 2020-09-07 at 2.33.52 PM.png
 
Last edited:
Joined
Mar 22, 2013
Messages
40
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 5600 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi! I´m back with new questions...
I´m wondering if there´s any kext I could try to boost my radeon 5600xt card.
I´ve been using cinema4d and prorender to test some 3d renders and I´m getting 2 minutes 50 seconds per frame in a scene on OSX (using metal) and 1:40 for the same scene in Windows (using openCl). If I use just OpenCl in OSX the render time reduces to 2:09.
Any help will be appreaciated!
 
Joined
Mar 22, 2013
Messages
40
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 5600 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
7-Sep-2020: Added EFI for OpenCore 0.6.1
Hey Casey! Thanks for bringing us this new update! you´re the best... I´m having a problem with my EFI:
I tried updating and everything worked ok in the USB drive, but when I try to copy it over the EFI partition in my internal drive, it says there is no more space left (I can copy the OC EFI folder but there´s no space for one addition kext I need (for openIntel bluetooth driver). However when I check the partition it tells me it is 200mb and your EFI foler is just 7mb.. so how can this be possible? I tried checking for hidden files but .trashes, .spotlight-V100, .fseventsd and system volume information are very lightweight. There should be enough space...
 
Joined
Nov 24, 2010
Messages
199
Motherboard
Gigabyte Z490 Vision D
CPU
i7-11700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey Casey! Thanks for bringing us this new update! you´re the best... I´m having a problem with my EFI:
I tried updating and everything worked ok in the USB drive, but when I try to copy it over the EFI partition in my internal drive, it says there is no more space left (I can copy the OC EFI folder but there´s no space for one addition kext I need (for openIntel bluetooth driver). However when I check the partition it tells me it is 200mb and your EFI foler is just 7mb.. so how can this be possible? I tried checking for hidden files but .trashes, .spotlight-V100, .fseventsd and system volume information are very lightweight. There should be enough space...
Have you emptied your trash?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,096
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi! I´m back with new questions...
I´m wondering if there´s any kext I could try to boost my radeon 5600xt card.
I´ve been using cinema4d and prorender to test some 3d renders and I´m getting 2 minutes 50 seconds per frame in a scene on OSX (using metal) and 1:40 for the same scene in Windows (using openCl). If I use just OpenCl in OSX the render time reduces to 2:09.
Any help will be appreaciated!
If you're using iMac19,1 it may be good to try temporarily switching to iMacPro1,1 or even MacPro7,1 (but MacPro7,1 may require MacProMemoryNotificationDisabler.kext (attached). iMacPro1,1 is the safer of the two options to try first.
 

Attachments

  • MacProMemoryNotificationDisabler.kext.zip
    15.3 KB · Views: 58
Joined
Nov 24, 2010
Messages
199
Motherboard
Gigabyte Z490 Vision D
CPU
i7-11700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Yup.. It was completely empty.
This is what I got:

View attachment 487263View attachment 487264
I am not sure I am reading your EFI folder correctly but I would completely delete everything in the EFI folder. Empty trash and then check info again and see if everything is free. I you have 206MB available, then you should be good to go with your replacement EFI. If there is still only 24mb free then there must be something hidden in the folder.
 
Joined
Nov 24, 2010
Messages
199
Motherboard
Gigabyte Z490 Vision D
CPU
i7-11700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Moving to another problem, I am getting regular hangs at the Gigabyte Splash Screen which I recover from by doing a Reset and Reboot or a Power Down and Reboot. I have even had to do a Clear CMOS on a couple of occasions.

Any idea what may be causing this as it is somewhat frustrating not knowing if my Hackintosh is actually going to boot successfully?
I have been having the same problem. I did get in touch with Gigabyte but I have not heard back from them. I also had this same problem with my Designare. After reading that people were having trouble with the Fenvi T919, I disconnected the Bluetooth USB cable and the machine started booting quickly into Catalina. (It was hanging on code 64 which can be usb related.) Today I replaced the T919 with the Fenvi 1200 and so far it seems ok. Don't know if it is a compatibility issue or if my card was bad. Once booted the BT and Wi-Fi did work properly.
 
Joined
Mar 22, 2013
Messages
40
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 5600 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I am not sure I am reading your EFI folder correctly but I would completely delete everything in the EFI folder. Empty trash and then check info again and see if everything is free. I you have 206MB available, then you should be good to go with your replacement EFI. If there is still only 24mb free then there must be something hidden in the folder.
I tried doing that but it didn´t work.. I ended up going to recovery mode and copying my entire EFI from the USB drive to the one inside the SDD and that worked perfectly. The command used was dd if=/dev/disk1s1 of=/dev/rdisk0s1
 
Top