Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Oct 17, 2015
Messages
2
Motherboard
B460 Phantom Gaming 4
CPU
Intel® Core™ i5-10400
Graphics
iGPU
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
The CPUID fields are not needed for Catalina -- at least not for my i5-10400. I use CPUID for Big Sur, but hopefully that too will become unnecessary with SMBIOS iMac20,1 when OpenCore 0.6.1 is released.
Thank you for the information, I think I will back to Catalina.
 
Joined
May 30, 2016
Messages
983
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
That means it's not loading. Have you configured the OpenCore config.plist correctly? Please post screenshot of OpenCore Configurator --> Kernel.
Is radeonboost a plist-only kext? If so it will not show up in kextstat...
 
Joined
Jun 17, 2016
Messages
64
Motherboard
Gigabyte z490 Vision D
CPU
i9 10900k
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
That means it's not loading. Have you configured the OpenCore config.plist correctly? Please post screenshot of OpenCore Configurator --> Kernel.

I think it is there when I tried again but still Final Cut rendering is so slow. I even found my old post where with z390 with radeonboost.kext and patched intel igpu together with Radeon VII my rendering of the same video was 2:47 and now is 7 minutes...

now geekbench GPU is 170k vs 130k without the radeonboost.kext but on z390 with i9900k I had 220k

Now they have i9 9900k for 370$ which looking how that worked faster is maybe better option for me but not sure since I did not try i9 9900k on big sur
 

Attachments

  • 1.png
    1.png
    695.2 KB · Views: 61
  • 2.png
    2.png
    141.7 KB · Views: 67
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
21,068
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I think it is there when I tried again but still Final Cut rendering is so slow. I even found my old post where with z390 with radeonboost.kext and patched intel igpu together with Radeon VII my rendering of the same video was 2:47 and now is 7 minutes...

now geekbench GPU is 170k vs 130k without the radeonboost.kext but on z390 with i9900k I had 220k

Now they have i9 9900k for 370$ which looking how that worked faster is maybe better option for me but not sure since I did not try i9 9900k on big sur
Are you running these Z490 benchmarks on Big Sur or Catalina?
 
Joined
Jun 24, 2011
Messages
42
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 580 Pulse 8GB
Everything checked out fine, but it just wouldn't work in Yosemite. Then I remembered I had a Sierra OS I could boot into and it worked fine in Sierra. :think: So I didn't feel like troubleshooting any further. Phew!

I managed to get everything up and running easily with a few issues I hope can be easily fixed.

1a. My main issue: The desktop background images won’t stay as what I set them too. They keep resetting to that default island.

I’ll reboot the computer, and the screen background on both monitors will be the correct image, then I enter my login password and when it loads the desktop it reverts back to the default island…. Very annoying.

1b. Possibly related with that problem: I have a dual monitor setup. I went into System Pref > Displays > Arrangement and moved the menu bar/dock to my main monitor. But when I start computer, the login screen defaults to the 2nd monitor which is usually powered off unless needed. If I just logout and login again, it is correctly on my main monitor but after a restart it is on the 2nd monitor.

As an update to this, incase it helps anyone in the future:

I seem to have fixed the background images resetting and have them correctly stay for now.

My original monitor configuration was:
Main Monitor: Connected via HDMI port on RX580
2nd Monitor: Connected via DVI port on RX580

I changed out the DVI cable and replaced it with a DVI to HDMI cable. So now both monitors are connected with the HDMI ports on my RX580. After doing this, and rebooting multiple times, it seems my background images are staying with what I set them to instead of constantly resetting to the default Dynamic Island when I login.

I'm hoping that the background images will stay now and this fixed it.
Appears the Hackintosh doesn't like having a DVI monitor connected in my case for some reason.

Unfortunately, it did not fix the Login screen. It is still appearing on the 2nd Monitor instead of my main one that I setup in preferences.
 
Joined
Jun 17, 2016
Messages
64
Motherboard
Gigabyte z490 Vision D
CPU
i9 10900k
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Are you running these Z490 benchmarks on Big Sur or Catalina?

Big Sur now but I went yesterday and installed Catalina to try it there and I am getting the same results.

Also I had z390 only for a month when I decided to wait for z490 and i9 10900k but I remember how I got 220k points for GPU on Geekbench 4 and what I posted here numbers from my benchmarks for rendering 3 minutes and something was ok but I was able to get it down to 2:47 I just found my notes with Imac pro 1.1 on asus prime a z390 with i9900k with radeonboost.kext and also correct patch for igpu where igpu was showing in system report - graphics/display together with radeon vii where here now only radeon VII is showing up and I only see intel 630 on PCI report. Also hackintool is showing this in attachment.
 

Attachments

  • Screen Shot 2020-08-27 at 10.24.37 PM.png
    Screen Shot 2020-08-27 at 10.24.37 PM.png
    214.3 KB · Views: 53
Last edited:

nss

Joined
Sep 16, 2019
Messages
99
Motherboard
Z490 Vision D
CPU
i7-10700
Graphics
RX 5700 XT
Mobile Phone
  1. Android
Agreed -- given the small price difference between the K and KF, it's better to go with the K because iGPU can be useful in emergencies. Also, macOS will utilize Intel QuickSync on the iGPU.
Alright, I'm thinking about taking the i7 10700. Is it compatible with macOS?
I see it's base frequency is kinda low-2.9 GHz, would it badly affect my performance when gaming/programming?
 
Joined
Jun 17, 2016
Messages
64
Motherboard
Gigabyte z490 Vision D
CPU
i9 10900k
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Big Sur now but I went yesterday and installed Catalina to try it there and I am getting the same results.

Also I had z390 only for a month when I decided to wait for z490 and i9 10900k but I remember how I got 220k points for GPU on Geekbench 4 and what I posted here numbers from my benchmarks for rendering 3 minutes and something was ok but I was able to get it down to 2:47 I just found my notes with Imac pro 1.1 on asus prime a z390 with i9900k with radeonboost.kext and also correct patch for igpu where igpu was showing in system report - graphics/display together with radeon vii where here now only radeon VII is showing up and I only see intel 630 on PCI report. Also hackintool is showing this in attachment.


now adding this

I just tried to replicate patch that I had for my z390 630 igpu and I copied this to OC. What I got is closer little bit from what I had there , 175k result but final cut does not work. I also got that now GeekBench shows both cards for test and you can select 630 and do the test and that is how it was on my z390 when I was getting 220k geekbench 4 gpu and 2:47 minutes rendering 8 min. 4k in h264 vs now 7 minutes...

also when I had that patched on z390 in the system report under graphics/display I was able to see both card Radeon VII and 630. I tried now since it is showing as a card for tests with patch to change gpu to igpu but still did not get final cut to open...

in my attachment gpu.png there we have to see both cards to get those results from z390.


now editing this since I posted...

I tried to delete some of the rows there for PciRoot(0x0)/Pci(0x2,0x0) where I added my full patch in the screenshot included from z390 which gave me 630 as an option to do the test on geeekbench and that is what I had with z390. Only thing extra that I had is that both cards should show under system reports/ graphics/display

with full patch final cut was not working I tried to delete some of the stuff there and left just those below and now final cut works and I got 5:12 rendering time result vs above 7 minutes before. Still way off from z390 and 2:47 minutes but at least two minutes better. Also geekbench 4 GPU 175k now vs 130k without this and geekbench 5 60k vs 48k ... I think some fine tuning is needed here for patching this igpu and that is causing that rendering is so slow

PciRoot(0x0)/Pci(0x2,0x0)

AAPL,ig-platform-id 07009B3E Data
AAPL,slot-name [email protected],2,0 String
device-id 9B3E0000 Data
device_type Display controller
framebuffer-con0-index 02000000 Data
framebuffer-patch-enable 01000000 data
framebuffer-unifiedmem 00000080 data
model Intel UHD Graphics 630 (Desktop 9 Series) String
 

Attachments

  • patch.png
    patch.png
    209.9 KB · Views: 52
  • gpu.png
    gpu.png
    369.5 KB · Views: 66
  • bb.png
    bb.png
    167.7 KB · Views: 51
Last edited:
Joined
Jul 31, 2015
Messages
80
Motherboard
Z490 Vision G
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Unfortunately, it did not fix the Login screen. It is still appearing on the 2nd Monitor instead of my main one that I setup in preferences.

For boot, monitor preferences set in macOS are somewhat ignored. For my RX 580 Pulse, I had to swap the order in which the monitors were connected to the GPU.

Based on this image, the leftmost display port has the highest priority and the right most hdmi port has the least priority and everything in between follows that order. No idea where DVI sits in that priority order.
 
Joined
Feb 10, 2019
Messages
324
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Wow.. the price has gone down for the Vision D!

Anyone predicts this will go lower?
 
Top