Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Aug 16, 2020
Messages
20
Motherboard
Z490
CPU
i7 10700k
Graphics
Radeon Sapphire RX580 8gb
Mac
  1. iMac
If it’s any help, I’ve found the latest version of Logic to be rock solid on Catalina with the Z490/10700K combo.
Thanks for that... Logic isn’t my main concern as it’s Apple, but I have to use both Pro Tools and Cubase Pro.
I guess the alternative is to have a Windows 10 boot just in case.
 
Joined
May 25, 2012
Messages
91
Motherboard
GIGABYTE Z490 Vision D
CPU
i9-10900K
Graphics
Radeon 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Hi there,

I see that you have got Logic and Pro Tools up and running. What version of PT are you running and Catalina? Seeing this is giving me hope as I too use Logic, Pro Tools and Cubase. I’m feeling this build is probably the way forward as the Z390 appears to be a bit more difficult to get hold of.
What UA device are you using too? I have an Apollo Quad with a TB3 card installed ready to make the move to a newer system.

Rob


Hello Rob,

ProTools Version 20.5.0.207, (2020.R1.0).
Logic 10.5.1
Luna 1.0.8

Catalina: 10.15.16

Three rooms and four systems operational. All Vision D Z490.
We previously used three Z390 builds and have zero regrets
migrating to the Z490 chipset.

The 390 Designare and processors are now retired in the Z490 boxes.

We use a few UA Apollo 8x and 8xP interfaces with UA Octo’s with these
Systems daily.


I am confident you will be pleased with. We are.


Tony…..
 
Joined
May 25, 2012
Messages
91
Motherboard
GIGABYTE Z490 Vision D
CPU
i9-10900K
Graphics
Radeon 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. Android
  2. iOS
If it’s any help, I’ve found the latest version of Logic to be rock solid on Catalina with the Z490/10700K combo.


@SpinRD
ProTools Version 20.5.0.207, (2020.R1.0).
Logic 10.5.1
Luna 1.0.8

Catalina: 10.15.6

Zero stability issues

Tony…..
 
Last edited:
Joined
Aug 16, 2020
Messages
20
Motherboard
Z490
CPU
i7 10700k
Graphics
Radeon Sapphire RX580 8gb
Mac
  1. iMac
Hello Rob,

ProTools Version 20.5.0.207, (2020.R1.0).
Logic 10.5.1
Luna 1.0.8

Catalina: 10.15.16

Three rooms and four systems operational. All Vision D Z490.
We previously used three Z390 builds and have zero regrets
migrating to the Z490 chipset.

The 390 Designare and processors are now retired in the Z490 boxes.

We use a few UA Apollo 8x and 8xP interfaces with UA Octo’s with these
Systems daily.


I am confident you will be pleased with. We are.


Tony…..
This is what I need to hear.
I think I shall start getting things on order and get cracking into this Hackintosh game.
I assume you have used OC 0.5.9 or 0.6.0?
You may get the odd query at some point

Thanks again for your response

Rob
 
Joined
Aug 19, 2020
Messages
5
Motherboard
Gigabyte Z490 Vision D
CPU
i7 10700K
Graphics
RX 5700TX
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Thank you, all based on your excellent work. My monitor has Thunderbolt 3 input, so maybe I can plug an USB-C to USB-C cable?
Congratulations! The iGPU supports a maximum of 30Hz at 4K over HDMI because it still uses the older HDMI 1.4 spec. The two Thunderbolt ports (USB-C) support DisplayPort 1.2 that supports full 60Hz at 4K and above. To use those ports we can use either of these cables:

I found jvm awt based app will crash on launch relating to iGPU.
Certain applications such as (a) Final Cut Pro, (b) iMovie, (c) Firefox, (d) ACDSee Photo Editor for Mac, etc. will crash on launch. Certain web pages will not open in Safari. So use of iGPU is not recommended for daily use.

On-board HDMI broke somewhere around Catalina 10.15.5, but has now been fixed with today's release of WhateverGreen 1.4.1. However, the above listed apps still crash on launch.

PyCharm-crash.png
 

Attachments

  • PyCharm crash.txt
    129.5 KB · Views: 7
Last edited:
Joined
Aug 22, 2020
Messages
22
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700k
Graphics
5700xt
Hello fellow Mac users! I just built my first Hackinosh this week and it has been running beautifully. The only problem is I haven’t been able to get sleep to work properly. When I set the cpu to sleep the display goes to sleep, but the fans and motherboard RGB stay on. I’d appreciate any recommendations on what I should try changing?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
13,463
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thank you, all based on your excellent work. My monitor has Thunderbolt 3 input, so maybe I can plug an USB-C to USB-C cable?
Yes certainly -- you can use a Thunderbolt cable (which is a USB-C cable with the Thunderbolt lightning logo) to connect your monitor. Some Thunderbolt monitors will accept DisplayPort over a USB-C (USB 3.x) cable, but the safest bet is to use a proper Thunderbolt cable. But if you have an AMD RX 5700 XT, then the iGPU should not be used for video. It should be placed in headless mode (Platform ID 0x3E980003).
I found jvm awt based app will crash on launch relating to iGPU.
This could happen if Platform ID is set to 0x3E9B0007 (non-headless for iGPU).
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
13,463
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello fellow Mac users! I just built my first Hackinosh this week and it has been running beautifully. The only problem is I haven’t been able to get sleep to work properly. When I set the cpu to sleep the display goes to sleep, but the fans and motherboard RGB stay on. I’d appreciate any recommendations on what I should try changing?
Hello @OskiTheBear,

Welcome the forum and glad to hear the build is (mostly) working. If the system is unable to enter sleep, we need to see which components are installed in the system:
  • What is the make/model of the CPU cooler?
  • Is CPU cooler connected to internal USB 2.0 header?
  • What devices are connected to internal USB 2.0 header?
  • Do you have a WiFi/BT card? If so, what make and model?
  • Are there any other PCIe devices?
  • Are there any Thunderbolt devices connected?
 
Joined
Feb 1, 2011
Messages
95
Motherboard
Gigabyte Z490 Vision D rev 1.1
CPU
i7-10700
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Things are mostly working for me. But my Sabrent Rocket NVMe4 Crystal benchmarks at about half what others report in Windows 10 Pro. I have the latest drivers from Gigabyte. And the Intel Power Gadget won't open at all in Windows.

Something else I'm noticing is that despite pretty light use my Samsung Evo is down to 92% "life". A Hackintosh seems to really shorten the life of an SSD. My last Samsung seemed to be doing the same thing.
 
Last edited:
Joined
Feb 5, 2013
Messages
58
Motherboard
Gigabyte Z490 Vision G
CPU
i9 10900K 3.7 GHz
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Hi
I am trying to install my hack using OC 0.6 and the directions I found from this thread. After booting from OC the Apple logo keeps on screen and nothing happens. Is there a way to troubleshoot using a "-v" parameter in order to see what is going on behind the scene? My motherboard is Gigabyte Z490 vision G.
Thanks
 
Top