Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Oct 24, 2013
Messages
795
Motherboard
Gigabyte Z590 Vision D
CPU
i7-11700K OC @ 5.2GHz
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Joined
Nov 29, 2012
Messages
116
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700
Graphics
Radeon Pro WX 4100 4 GB
My biggest annoyance at present with this build is I cannot wakeup my machine from sleep with my OSXWiFi BCM943602CDP combo card via Keyboard/Mouse. I have to use the Power button on my case to do so (or any non-Bluetooth USB peripheral). This card has a blue power light that shuts off when I go into Sleep. I have Wake on LAN disabled in BIOS (and in MacOS) and ErP disabled. I have this model plugged into my PCI-e x4 slot since it's the only one still accessible as the PCI-e x 16 slot is consumed by my RX 580 and that covers the PCI-e x1 slot).

Otherwise, everything is working perfectly. A little assistance would be great.
 
Joined
Aug 3, 2020
Messages
3
Motherboard
Z490 Vision D
CPU
10900k
Graphics
Gigabyte RX 5700 XT 8G
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@jminiman Hey, I have Fenvi T919 and had similar issue but then I changed this setting and it works with apple keyboard:
1596754501148.png


Although mine is BCM4360, I think it worth a try.
 
Joined
Jul 18, 2020
Messages
2
Motherboard
gigabyte z490 D
CPU
i7-10700K
Graphics
Sapphire Radeon PULSE RX 580 8GB
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello @Hoasuthai07,

Are you using Platform ID 0x3E9B0007? In other words, in Step 4 of the build guide, did you choose config-Intel-iGPU.plist? Because you have an AMD GPU, the correct choice would be config-AMD-GPU.plist.

Everything is working properly now. Many thanks.
 
Joined
Oct 11, 2015
Messages
55
Motherboard
Asus Prime H470-Plus
CPU
i7-10700
Graphics
Sapphire RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Many thanks to the build guide. I used it to install on my Asus Prime H470-Plus with an i7-10700 switching out original Ethernet kext to the RT8111 kext. Still testing. My Geekbench should be over 9K but am getting around 7.5K multicore. Not sure what the issue is. I will report as I continue.....:headbang:

Update (8/7/20): changed BIOS on motherboard from Auto to Performance mode in AI tweaks and got 8.5K multicore. Cinebench improved from 3677 to 4975 as well. :eek:
 
Last edited:
Joined
Nov 25, 2015
Messages
29
Motherboard
Gigabyte z490 Vision D
CPU
i7 - 10700K
Graphics
Asus RX 580 8 GB
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
Thanks to you guys, I have a very smooth running dual boot Gigabyte Z490 Vision D System.

I just installed a 2nd NVMe disk (in the slot closest to the cpu) and installed Windows on it. I know the guide said to install Windows first, but that wans't an option back then. My computer now boots directly to Windows, which I won't be using that often. Do you know how to change it back to open core? The only boot device I see in the bios is Windows.
 
Joined
Apr 30, 2020
Messages
72
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I just installed a 2nd NVMe disk (in the slot closest to the cpu) and installed Windows on it. I know the guide said to install Windows first, but that wans't an option back then. My computer now boots directly to Windows, which I won't be using that often. Do you know how to change it back to open core? The only boot device I see in the bios is Windows.

Please try if you can still boot into macOS with an USB stick. If it’s possible you should be able to use a tool to mount the EFI partition and set it back up on your macOS SSD. This might cause Windows boot issues though
 
Last edited:
Top