Contribute
Register

Gigabyte Z390 UD working system (shutdown, sound, sleep)

Joined
Aug 9, 2019
Messages
1
Hey folks,

my working setup with this motherboard I would like to share. I had several problems, didn't exspect that as its coverd by the buying guide. As everything runs now, I want to share my settings. Especially shut down and sleep were big problems as the most advices and guides did not work. Iam not really professional and if there is room for improvements please share:

- Gigabyte Z390 UD
- Core I5 8400
- AMD Radeon RX580

my problems with tonymacx86 guide were:
- shutdown not working
- no sound
- no ethernet
- smaller things I forgot

everything is solved, I would like to share it now:

------------------------------------------
BIOS (Version F8):
- BIOS: Fast boot disabled
- BIOS: Windows 8/10 Features: Other OS
- BIOS: CSM Support: Enabled
- BIOS: LAN PXE Boot Option ROM: Disabled
- Storage Boot Option Control: UEFI

Peripherals:
- Intel Platform Trust Technology (PTT): Disabled
- Software Guard Extensions (SGX): Software Controlled
- Security Device Support: Disable

Peripherals - USB Configuration:
- Legacy USB Support: Enabled
- XHCI Hand-off: Enabled
- USB Mass Storage Driver Support: Enabled
- Port 60/64 Emulation: Disabled

Peripherals - Super IO Configuration:
- Serial Power: Enabled

Chipset:
VT-d: Disabled
Internal Graphics: Disabled
Audio Controller: Enabled
Above 4G Devoding: Enabled
IOAPIC 24-119 Entries: Enabled
Aperture Sizre: 256MB

Peripherals - Network Stack Configuration:
- disabled

Peripherals - SATA and RST Configuration:
- SATA Controller(s): Enabled
- SATA Mode Selection: AHCI
- Agressive LPM Support: Disabled

Power:
- Platform Power Management: Disabled
- AC Back: Always Off
- ErP: Enabled

------------------------------------------

drivers64UEFI loaded with Clover:

- ApfsDriverLoader-64.efi
- AudioDxe-64.efi
- DataHubDxe-64.efi
- EmuVariableUefi-64.efi ***see below
- FSInject-64.efi
- OsxAptioFix2Drv-free2000.efi ***see below
- PartitionDxe-64.efi
- SMCHelper-64.efi
- VBoxHfs-64.efi

*** !!!!!! IMPORTANT: OsxAptioFix2Drv-free2000.efi and EmuVariableUefi-64.efi BOTH REQUIRED for working shutdown!!!!!!

------------------------------------------

kexts list / Other folder:

- AppleALC.kext
- FakeSMC.kext
- Lilu.kext
- RealtekRTL8111.kext
- WhateverGreen.kext

------------------------------------------

Clover:

ACPI Tab:
nothing selected

config.plist boot options:
- dart=0
- nv_disable=1
- slide=0
- darkwake=0

Devices Tab:
USB - FixOwnership (selected)

SMBIOS (not really necessary):
- iMac 19,2
 
Last edited:
Joined
Nov 14, 2019
Messages
1
Motherboard
z390ud
CPU
i5-8400
Graphics
rx 570
Hey folks,

my working setup with this motherboard I would like to share. I had several problems, didn't exspect that as its coverd by the buying guide. As everything runs now, I want to share my settings. Especially shut down and sleep were big problems as the most advices and guides did not work. Iam not really professional and if there is room for improvements please share:

- Gigabyte Z390 UD
- Core I5 8400
- AMD Radeon RX580

my problems with tonymacx86 guide were:
- shutdown not working
- no sound
- no ethernet
- smaller things I forgot

everything is solved, I would like to share it now:

------------------------------------------
BIOS (Version F8):
- BIOS: Fast boot disabled
- BIOS: Windows 8/10 Features: Other OS
- BIOS: CSM Support: Enabled
- BIOS: LAN PXE Boot Option ROM: Disabled
- Storage Boot Option Control: UEFI

Peripherals:
- Intel Platform Trust Technology (PTT): Disabled
- Software Guard Extensions (SGX): Software Controlled
- Security Device Support: Disable

Peripherals - USB Configuration:
- Legacy USB Support: Enabled
- XHCI Hand-off: Enabled
- USB Mass Storage Driver Support: Enabled
- Port 60/64 Emulation: Disabled

Peripherals - Super IO Configuration:
- Serial Power: Enabled

Chipset:
VT-d: Disabled
Internal Graphics: Disabled
Audio Controller: Enabled
Above 4G Devoding: Enabled
IOAPIC 24-119 Entries: Enabled
Aperture Sizre: 256MB

Peripherals - Network Stack Configuration:
- disabled

Peripherals - SATA and RST Configuration:
- SATA Controller(s): Enabled
- SATA Mode Selection: AHCI
- Agressive LPM Support: Disabled

Power:
- Platform Power Management: Disabled
- AC Back: Always Off
- ErP: Enabled

------------------------------------------

drivers64UEFI loaded with Clover:

- ApfsDriverLoader-64.efi
- AudioDxe-64.efi
- DataHubDxe-64.efi
- EmuVariableUefi-64.efi ***see below
- FSInject-64.efi
- OsxAptioFix2Drv-free2000.efi ***see below
- PartitionDxe-64.efi
- SMCHelper-64.efi
- VBoxHfs-64.efi

*** !!!!!! IMPORTANT: OsxAptioFix2Drv-free2000.efi and EmuVariableUefi-64.efi BOTH REQUIRED for working shutdown!!!!!!

------------------------------------------

kexts list / Other folder:

- AppleALC.kext
- FakeSMC.kext
- Lilu.kext
- RealtekRTL8111.kext
- WhateverGreen.kext

------------------------------------------

Clover:

ACPI Tab:
nothing selected

config.plist boot options:
- dart=0
- nv_disable=1
- slide=0
- darkwake=0

Devices Tab:
USB - FixOwnership (selected)

SMBIOS (not really necessary):
- iMac 19,2
Hi, could you share your clover and efi files?
 
Joined
Dec 7, 2019
Messages
1
Motherboard
Z390 UD
CPU
i3
Graphics
RX580
This helped me finally fix the sleep/shut down/reboot issues on my Z390 UD system! Thank you very much :)
 
Joined
Jan 4, 2011
Messages
9
Motherboard
Gigabyte Z390 UD
CPU
i5-9400F Coffee Lake
Graphics
XFX Radeon RX590
Mac
iMac, Mac Pro
Mobile Phone
Android, iOS
Hi @dabrorius and @bersercore, wow so happy to to have found this thread. Yes, can you guys post your conflig.plist file for the rest of us? Thanks!!!
 
Joined
Apr 17, 2019
Messages
185
Motherboard
Q77 Board
CPU
I7 3770
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
Android
Thinking of doing this setup any luck on the config file or EFI folder?
 
Top