Contribute
Register

Gigabyte Z390 M Gaming build with working NVRAM

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,699
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
@pastrychef I've just inherited a 2013 i7 Haswell iMac 27" 4K. I am planning to use it basically as a monitor for my Z390M hackintosh. Of course, I could swap out the iMacs installed HDD for an SSD but then I can't run Big Sur only Catalina hence basically thinking of using it as a monitor. I don't currently have Thunderbolt enabled on my hack, could I use a DisplayPort to Thunderbolt cable you think from my RX580 to the iMac?

I don't know. I don't have any experience Target Display Mode.
 
Joined
Mar 4, 2014
Messages
442
Motherboard
Gigabyte Z390 M Gaming
CPU
i5 9400F
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
I don't know. I don't have any experience Target Display Mode.
Cable arrives later today, I'll let you know what happens. If the DisplayPort to Thunderbolt on the iMac doesn't work, then I may have to enable Thunderbolt on the hack which I haven't done yet. You have TB working right?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,699
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Cable arrives later today, I'll let you know what happens. If the DisplayPort to Thunderbolt on the iMac doesn't work, then I may have to enable Thunderbolt on the hack which I haven't done yet. You have TB working right?

I had a Thunderbolt card installed but had no Thunderbolt devices so I ended up pulling out the card. Lol
 
Joined
Sep 10, 2017
Messages
320
Motherboard
Gigabyte Z590M GAMING X
CPU
i9-10900
Graphics
Vega 56+UHD 630
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
Here I use Thunderbolt, in my case a TB3 SSD, so that it works hot plug, and native on MacOS, it will be necessary to change the Titan Ridge firmware.
 
Joined
Sep 10, 2017
Messages
320
Motherboard
Gigabyte Z590M GAMING X
CPU
i9-10900
Graphics
Vega 56+UHD 630
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
Captura de Tela 2021-06-01 às 11.47.21.png
 
Joined
Mar 4, 2014
Messages
442
Motherboard
Gigabyte Z390 M Gaming
CPU
i5 9400F
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
OK, I have taken the plunge and purchased a 4k monitor, its a LG 27UL850 27" UHD. I have no experience with 4k monitors but have read they can be tricky. I am connected with a Display Port to HDMI cable. I am getting 4k in windows but not on the hackintosh. Here is what I am seeing in system report:

Screenshot 2021-06-03 at 19.18.28.png


Can anyone help me with this?

 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,699
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
OK, I have taken the plunge and purchased a 4k monitor, its a LG 27UL850 27" UHD. I have no experience with 4k monitors but have read they can be tricky. I am connected with a Display Port to HDMI cable. I am getting 4k in windows but not on the hackintosh. Here is what I am seeing in system report:

View attachment 520639

Can anyone help me with this?


It's working fine at 4K resolution. You just have it scaled to 1080p.

Screenshot 2021-06-03 at 19.18.28.png


If you want a useable 4K, don't scale.
 
Top