Contribute
Register

Gigabyte Z390 M Gaming build with working NVRAM

Joined
Sep 10, 2017
Messages
343
Motherboard
Gigabyte Z590M GAMING X
CPU
i7-11700K
Graphics
RX6800 XT 16GB
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
Unfortunately I'm not having any luck with MacOS 11.3, even though making the changes reported here, my machine continued to crash and had to shut down manually.
I had to do a clean install for 11.2.3.
I made the USB MAP for safety and still keeps crashing.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,683
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Unfortunately I'm not having any luck with MacOS 11.3, even though making the changes reported here, my machine continued to crash and had to shut down manually.
I had to do a clean install for 11.2.3.
I made the USB MAP for safety and still keeps crashing.

I don't know what's causing your crashes. Do you have any crash logs? Have you tried my EFI unmodified? I haven't had a crash in a long long long long long time and my system runs 24/7.
 
Joined
Sep 10, 2017
Messages
343
Motherboard
Gigabyte Z590M GAMING X
CPU
i7-11700K
Graphics
RX6800 XT 16GB
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
I don't know what's causing your crashes. Do you have any crash logs? Have you tried my EFI unmodified? I haven't had a crash in a long long long long long time and my system runs 24/7.
I tested it yesterday with your EFI with the Bootloader Clover, during and after upgrading to MacOS 11.3. However, at all times, it is stopped in the last reboot with the remaining time of 7 minutes, being forced to manually reset to enter the system.
This week I did this process 4 times, with different EFIs, both the one I made specifies for my configuration in OpenCore 0.6.8, and with its 2 EFIs, Clover and Opencore, and I have the same problem.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,683
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I tested it yesterday with your EFI with the Bootloader Clover, during and after upgrading to MacOS 11.3. However, at all times, it is stopped in the last reboot with the remaining time of 7 minutes, being forced to manually reset to enter the system.
This week I did this process 4 times, with different EFIs, both the one I made specifies for my configuration in OpenCore 0.6.8, and with its 2 EFIs, Clover and Opencore, and I have the same problem.

Do it in verbose mode and see where it stops.
 
Joined
Feb 14, 2019
Messages
203
Motherboard
Gigabyte Z390M
CPU
i5-8400
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
If you use iMacPro1,1, there's no need to redo the USB ports fix. It's already done.

Set your Serial, Board Serial, and UUID. Then see if your color profiles stick.

Just use Clover Configurator to generate your Serial, Board Serial, and UUID. All you have to do is click on the following button and select iMacPro1,1.

View attachment 517112

Finally, I selected iMacPro1.1. Thanks for your detailed guide and quick replies. :)
 
Joined
Sep 23, 2016
Messages
52
Motherboard
Gigabyte Z390 Designare, AERO G DDR5
CPU
i9 9900k, 12900K
Graphics
Radeon VII, 5700XT, 6900XT TOXIC
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Mobile Phone
  1. iOS
I am going to migrate from Clover to OC.
Is F9m BIOS version (19/01/2021) for Gigabyte Z390M Gaming OK? Or should I stay on F9g? Are there any differences for OpenCore?
 
Joined
Feb 14, 2019
Messages
203
Motherboard
Gigabyte Z390M
CPU
i5-8400
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
One final question. I remember in previous BIOS version I was selecting gaming profile from somewhere I can't find in the latest version... I was getting 200 more score in Geekbench when in gaming mode...

Do you know where can I change it in the f9l ??
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,683
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I am going to migrate from Clover to OC.
Is F9m BIOS version (19/01/2021) for Gigabyte z390M Gaming ok? Or should i stay on F9g? Are there any differences for OPENCORE?

F9l or F9m are probably a bit better but F9g will work fine too.

Once booted in to macOS, I can't tell if OpenCore or Clover was used.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,683
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
one final question, I remember in previous bios version I was selecting gaming profile from somewhere I can't find in the latest version... I was getting 200 more score in Geekbench when in gaming mode...

do you know where can I change it in the f9l ??

I don't know where "Gaming profile" is. It probably did some sort of minor overclocking. That can be done manually.
 
Top