Contribute
Register

Gigabyte Z390 M Gaming build with working NVRAM

Joined
Apr 20, 2020
Messages
66
Motherboard
Gigabyte Z390 M GAMING
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Are you sure there's nothing wrong with your USB flash drive?

Which USB ports are not working?

I hava a Kingston Datatraveler USB flash drive that causes my system to freeze for long moments. It never operated faster than USB 2 speeds. It would constantly eject itself for no reason. It is the worst piece $#!@ that I've ever owned.
View attachment 511954

You can use either M2P or M2Q. Both work fine. Both are in use on my system. Just keep in mind that by using M2P, one of your SATA ports will be disabled.

Personal communications is in violation of forum rules and can get you banned. Don't even ask.
No, the key under my real MacBook Pro works perfectly. Otherwise for the M2Q port ok I see,
and, if not for the teamwiever, I did not think, but in any case thank you for warning me;)

After is there a software to check if all the parameters of the mac are active and functional?

Thank you for your patience it's great to be so responsive.

DiABLONY
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,549
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
No, the key under my real MacBook Pro works perfectly. Otherwise for the M2Q port ok I see,
and, if not for the teamwiever, I did not think, but in any case thank you for warning me;)

After is there a software to check if all the parameters of the mac are active and functional?

Thank you for your patience it's great to be so responsive.

DiABLONY

Which USB ports are not working? Try using some other USB devices to test.

I don't know of any software to check all parameters. Just use the system.
 
Joined
Mar 1, 2021
Messages
5
Motherboard
Gigabyte Z390 M Gaming
CPU
i5-9500
Graphics
UHD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I think it's a Big Sur issue.

Try booting in the Recovery and use Time Machine to Restore to your new drive.
It is more difficult to make a bootable clone of a Big Sur drive. The CCC website has a good explanation of the changes that Apple made, and a workaround:

Edit -- actually, I've gotten in trouble for posting external links before, so just Google "Carbon Copy Cloner Big Sur" and it should pull up a link to Bombich's FAQ
Thanks @pastrychef @tedyun this did the trick. It looks like there's something still afoot with CCC and latest Big Sur.

In recovery mode, I couldn't restore directly from a Time Machine Backup, but I used recovery mode to do a fresh install of Big Sur on a freshly wiped APFS drive. At the completion of Big Sur install, it prompts you to pull data using Migration Assistant. Using MA to target the Time Machine backup has resulted it a full dupe of my original drive. After OSX booted the first time with my existing data, I copied the EFI folder from my old drive to the new drive's blank EFI. Everything's identical to before, so I'm happy with the results. Thanks for all the help!
 
Last edited:

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
8,021
Motherboard
Gigabyte Z590i Aorus Ultra - OC 0.8.0
CPU
i5-10600k
Graphics
Dell RX560
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
a technique to run 3.1 and USB-C on the motherboard?

Are you using @pastrychef 's EFI ? He has done all the work for you in USBPorts-with-Power.kext. Check out ports SS01 and SS02.
 
Joined
Apr 20, 2020
Messages
66
Motherboard
Gigabyte Z390 M GAMING
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Are you using @pastrychef 's EFI ? He has done all the work for you in USBPorts-with-Power.kext. Check out ports SS01 and SS02.
I did or maybe badly but I did not see its famous ss01 and ss02 port that's why I'm struggling with my usb ports
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,549
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I did or maybe badly but I did not see its famous ss01 and ss02 port that's why I'm struggling with my usb ports

Where are you looking that you can't see SS01 and SS02?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,549
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
with the software which is provided in the beginner's tutorial which highlights the usb ports in green Do you see what I'm talking about ?

This is what I see.
Screen Shot 2021-03-12 at 4.49.58 PM.png
 
Top