Contribute
Register

Gigabyte Z390 M Gaming build with working NVRAM

Joined
Nov 24, 2018
Messages
283
Motherboard
ASUS TUF Z390M-PRO GAMING (WI-FI)
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
@pastrychef

Have you seen this. I moved some SATA drives over from my system with the ASUS board to the gigabyte z390M gaming and when I booted it throw these errors and boots to windows every time.

IMG_4556.jpeg


and every time it boots into windows 10. How do I get rid of this and what does that error mean?
I mean I don't even have a nada card. I was able to see the OC boot menu one time but I couldn't figure out and when I rebooted it went right back to windows
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,221
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
@pastrychef

Have you seen this. I moved some SATA drives over from my system with the ASUS board to the gigabyte z390M gaming and when I booted it throw these errors and boots to windows every time.

View attachment 452914

and every time it boots into windows 10. How do I get rid of this and what does that error mean?
I mean I don't even have a nada card. I was able to see the OC boot menu one time but I couldn't figure out and when I rebooted it went right back to windows

The first line means you don't have a Thunderbolt card installed. If you disable the SSDT in config.plist, you shouldn't see it anymore.
I don't know what the second one is but I see it too. I'll have to investigate what is causing that.
The third line is an Nvidia setting that can be deleted from config.plist > NVRAM > Add > 7C436110-AB2A-4BBB-A880-FE41995C9F82.
I've never seen the 4th and 5th lines. Don't know what causes that.
The sixth line should be fixed once you set a default boot drive from System Preferences > Startup Disk.

None of these should prevent booting if you don't want to mess with things.

Go to System Preferences > Startup Disk and set the default boot drive and it won't keep booting to Windows anymore. This is one of the post installation steps on post #1.
 
Joined
Jul 10, 2011
Messages
35
Motherboard
Gigabyte Z390 M GAMING
CPU
i7-8700K OC'd @ 4.5 GHz
Graphics
RX 570
Mac
  1. MacBook Air
  2. Mac mini
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
Hi pastrychef, have you ever encountered that putting in a discrete graphics card (like my Ry570) prevents the system from staying asleep?
--> sleep (and staying asleep) worked fine before puttin in the RX570
--> actually i put in my original EFI-Folder again... but to no success...
Thanks again!
Stefan
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,221
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi pastrychef, have you ever encountered that putting in a discrete graphics card (like my Ry570) prevents the system from staying asleep?
--> sleep (and staying asleep) worked fine before puttin in the RX570
--> actually i put in my original EFI-Folder again... but to no success...
Thanks again!
Stefan

No.

Please enter the following in Terminal and post the output:
Code:
log show --style syslog | fgrep "Wake reason"
 
Joined
Jul 10, 2011
Messages
35
Motherboard
Gigabyte Z390 M GAMING
CPU
i7-8700K OC'd @ 4.5 GHz
Graphics
RX 570
Mac
  1. MacBook Air
  2. Mac mini
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
Hi,
this is the output from today:

2020-03-04 14:48:24.176949+0100 localhost powerd[164]: [powerd:sleepWake] Wake reason: "<private>" identity: "<private>"
2020-03-04 14:48:48.873551+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:48:48.873551+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:52:31.415055+0100 localhost powerd[164]: [powerd:sleepWake] Wake reason: "<private>" identity: "<private>"
2020-03-04 14:52:54.761072+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:52:54.761073+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:57:22.458252+0100 localhost powerd[164]: [powerd:sleepWake] Wake reason: "<private>" identity: "<private>"
2020-03-04 14:57:47.073211+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:57:47.073212+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW

Thanks!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,221
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi,
this is the output from today:

2020-03-04 14:48:24.176949+0100 localhost powerd[164]: [powerd:sleepWake] Wake reason: "<private>" identity: "<private>"
2020-03-04 14:48:48.873551+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:48:48.873551+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:52:31.415055+0100 localhost powerd[164]: [powerd:sleepWake] Wake reason: "<private>" identity: "<private>"
2020-03-04 14:52:54.761072+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:52:54.761073+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:57:22.458252+0100 localhost powerd[164]: [powerd:sleepWake] Wake reason: "<private>" identity: "<private>"
2020-03-04 14:57:47.073211+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
2020-03-04 14:57:47.073212+0100 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW

Thanks!

Please try sleep with no USB devices plugged in except for mouse and keyboard.
 
Joined
Jul 10, 2011
Messages
35
Motherboard
Gigabyte Z390 M GAMING
CPU
i7-8700K OC'd @ 4.5 GHz
Graphics
RX 570
Mac
  1. MacBook Air
  2. Mac mini
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
ok, thanks - found the culprit - its the old usb-scanner - i changed usb-ports back und forth and now have a constellation that works... just strange, that after installing the RX570 there's need to change the ports...
but now, everythings working - and 60 Hz on my Ultra wide 4 K Display...
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,221
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I updated the OpenCore 0.5.6 EFI. I previously forgot to delete my Radeon VII info... :banghead:
 
Joined
May 22, 2011
Messages
1,041
Motherboard
ASUS TUF Z390 Plus Gaming
CPU
i9-9900K
Graphics
UHD 630
Mac
  1. iMac
Mobile Phone
  1. iOS
@pastrychef

Do you know how to use a headless IGPU setup on OpenCore?

What kind of type sound are you using device-properties or alcid=1?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,221
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
@pastrychef

Do you know how to use a headless IGPU setup on OpenCore?

What kind of type sound are you using device-properties or alcid=1?

Just enable IGPU in BIOS. You don't have to configure anything. The same is true of Clover.

For audio, I use device properties.
 
Top