Contribute
Register

Gigabyte Z390 M Gaming build with working NVRAM

Joined
Mar 15, 2013
Messages
37
Motherboard
Gigabyte Z390 M Gaming
CPU
i5 9600k
Graphics
Sapphire Radeon Nitro+ RX 580 8GB
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
@pastrychef - have you updated your Z390 rig to the latest Big Sur (version ending in "g" that came out last week)? My update was working fine until yesterday, and now it doesn't automatically go to sleep. I can command it to sleep just fine. I've reset the NVRAM, CMOS, pared down my config.plist, but I haven't nailed down the cause.

Very strange....
I also updated Big Sur and now it wont go to sleep anymore now.. Here is the out from (pmset -g assertions)

Code:
2020-10-19 09:13:25 -0500
Assertion status system-wide:
   BackgroundTask                 1
   ApplePushServiceTask           0
   UserIsActive                   1
   PreventUserIdleDisplaySleep    0
   InteractivePushServiceTask     1
   PreventSystemSleep             0
   ExternalMedia                  0
   PreventUserIdleSystemSleep     0
   NetworkClientActive            0
Listed by owning process:
   pid 139(WindowServer): [0x00000016000980d6] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:1000004d7 name:AppleUserHIDEventSe product:USB Receiver eventType:3" 
    Timeout will fire in 900 secs Action=TimeoutActionRelease
   pid 264(mds_stores): [0x00000006000b800b] 00:00:48 BackgroundTask named: "com.apple.metadata.mds_stores.power" 
   pid 96(mds): [0x00000006000b800a] 00:00:48 BackgroundTask named: "com.apple.metadata.mds.power" 
   pid 109(apsd): [0x000000210012822d] 00:00:20 InteractivePushServiceTask named: "com.apple.apsd-outgoingmessage" 
    Timeout will fire in 160 secs Action=TimeoutActionTurnOff
   pid 109(apsd): [0x0000002c00128288] 00:00:10 InteractivePushServiceTask named: "com.apple.apsd-recreatecourierstate-sandbox.push.apple.com" 
    Timeout will fire in 170 secs Action=TimeoutActionTurnOff
   pid 109(apsd): [0x0000002e0012828d] 00:00:08 InteractivePushServiceTask named: "com.apple.apsd-recreatecourierstate-push.apple.com" 
    Timeout will fire in 172 secs Action=TimeoutActionTurnOff
Kernel Assertions: 0x4=USB
   id=500  level=255 0x4=USB creat=10/19/20, 9:19 AM description=com.apple.usb.externaldevice.14200000 owner=USB Receiver
Idle sleep preventers: IODisplayWrangler
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,359
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I also updated Big Sur and now it wont go to sleep anymore now.. Here is the out from (pmset -g assertions)

Code:
2020-10-19 09:13:25 -0500
Assertion status system-wide:
   BackgroundTask                 1
   ApplePushServiceTask           0
   UserIsActive                   1
   PreventUserIdleDisplaySleep    0
   InteractivePushServiceTask     1
   PreventSystemSleep             0
   ExternalMedia                  0
   PreventUserIdleSystemSleep     0
   NetworkClientActive            0
Listed by owning process:
   pid 139(WindowServer): [0x00000016000980d6] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:1000004d7 name:AppleUserHIDEventSe product:USB Receiver eventType:3"
    Timeout will fire in 900 secs Action=TimeoutActionRelease
   pid 264(mds_stores): [0x00000006000b800b] 00:00:48 BackgroundTask named: "com.apple.metadata.mds_stores.power"
   pid 96(mds): [0x00000006000b800a] 00:00:48 BackgroundTask named: "com.apple.metadata.mds.power"
   pid 109(apsd): [0x000000210012822d] 00:00:20 InteractivePushServiceTask named: "com.apple.apsd-outgoingmessage"
    Timeout will fire in 160 secs Action=TimeoutActionTurnOff
   pid 109(apsd): [0x0000002c00128288] 00:00:10 InteractivePushServiceTask named: "com.apple.apsd-recreatecourierstate-sandbox.push.apple.com"
    Timeout will fire in 170 secs Action=TimeoutActionTurnOff
   pid 109(apsd): [0x0000002e0012828d] 00:00:08 InteractivePushServiceTask named: "com.apple.apsd-recreatecourierstate-push.apple.com"
    Timeout will fire in 172 secs Action=TimeoutActionTurnOff
Kernel Assertions: 0x4=USB
   id=500  level=255 0x4=USB creat=10/19/20, 9:19 AM description=com.apple.usb.externaldevice.14200000 owner=USB Receiver
Idle sleep preventers: IODisplayWrangler

There's nothing there preventing sleep. What exactly is happening? Does it try to sleep and instantly wake up?
 
Joined
May 29, 2012
Messages
468
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
There's nothing there preventing sleep. What exactly is happening? Does it try to sleep and instantly wake up?

Yes, same here, after a couple of successful sleeps, the problem is back again.

With me, normally if I leave the rig idle for a bit, it will eventually automatically go to sleep. I can set the time using Energy Settings. I usually have it for 1 h to power down.

Since this update, it worked normally for a couple days, but then on Fri night, it did not go to sleep for the entire night.

I rebooted from my Catalina backup, and from that drive, it sleeps fine. I'm going to try reinstalling Big Sur. Maybe it's just something funky with this update. There seems to be a lot of minor changes.
 
Joined
Mar 15, 2013
Messages
37
Motherboard
Gigabyte Z390 M Gaming
CPU
i5 9600k
Graphics
Sapphire Radeon Nitro+ RX 580 8GB
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Yes, same here, after a couple of successful sleeps, the problem is back again.

With me, normally if I leave the rig idle for a bit, it will eventually automatically go to sleep. I can set the time using Energy Settings. I usually have it for 1 h to power down.

Since this update, it worked normally for a couple days, but then on Fri night, it did not go to sleep for the entire night.

I rebooted from my Catalina backup, and from that drive, it sleeps fine. I'm going to try reinstalling Big Sur. Maybe it's just something funky with this update. There seems to be a lot of minor changes.
This is a clean install as of this weekend. My installer is an older version. And sleep will work, But once I do the update that came out last week I lose sleep. The monitor will go off but that's all it does.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,359
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I just updated to the latest public beta and sleep worked fine for me. I have no software installed on that drive.
 
Joined
May 29, 2012
Messages
468
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I just updated to the latest public beta and sleep worked fine for me. I have no software installed on that drive.

With a fresh install of the latest update and nothing else, except signing into AppleID, sleep works fine. After I migrate everything over from my working drive, it looks like something disables the auto sleep. Next, I will try migrating things piece by piece, ie., Applications, Settings, tech, and see if I can narrow it down.
 
Joined
Oct 29, 2019
Messages
14
Motherboard
Z390 m gaming
CPU
i3-9100
Graphics
iGPU
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
So I still can't find the solution to do a factory bios reset (F4).
I made a new clear Cmos, the F9j is well cleaned :)
I put the variable 0x5C1 0x0 back to 0x1.
the cfg lock is changed from enable to disable.
When I extract this bios (after optimal settings), we can see that we find "cfg lock" in 2 different places.


Screenshot 2020-10-19 at 20.00.10.png


Screenshot 2020-10-19 at 20.00.36.png


by digging a little, I find 2 times internal graphics. we can see that it is on "Auto" (0x2). var name : 0x91A.
which means that I should have a display (motherboard) if I remove the graphics card. which is not the case
I'm going to set it to enable 0x1 -> set_var_3 0x91A 0x1
then disconnect my graphics card and connect to the igpu
what do you think?
but it doesn't say why the option disappeared from the bios.

Screenshot 2020-10-19 at 20.43.22.png

Screenshot 2020-10-19 at 20.43.37.png
 
Last edited:
Joined
Mar 15, 2013
Messages
37
Motherboard
Gigabyte Z390 M Gaming
CPU
i5 9600k
Graphics
Sapphire Radeon Nitro+ RX 580 8GB
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
With a fresh install of the latest update and nothing else, except signing into AppleID, sleep works fine. After I migrate everything over from my working drive, it looks like something disables the auto sleep. Next, I will try migrating things piece by piece, ie., Applications, Settings, tech, and see if I can narrow it down.
Mines a clean install with only istats installed and signed in to apple account. I’ll reload it again tonight.
 
Joined
Oct 29, 2019
Messages
14
Motherboard
Z390 m gaming
CPU
i3-9100
Graphics
iGPU
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
diging again...
by searching Initial display Output, we can see that there is a condition for in IGPU that depends on the value of 0xEDB
Screenshot 2020-10-19 at 21.25.03.png

looking for it : Non Snoop Latency Value

Screenshot 2020-10-19 at 21.25.55.png

So I think i'll just go for a setup_var_3 0x16A8 0x0 !

EDIT : Don't do that. you'll to clean Cmos ;)
 
Last edited:
Joined
Mar 29, 2014
Messages
56
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
XFX RX580 GTS Black
So I still can't find the solution to do a factory bios reset (F4).
I made a new clear Cmos, the F9j is well cleaned :)
I put the variable 0x5C1 0x0 back to 0x1.
the cfg lock is changed from enable to disable.
When I extract this bios (after optimal settings), we can see that we find "cfg lock" in 2 different places.


View attachment 492404

View attachment 492405

by digging a little, I find 2 times internal graphics. we can see that it is on "Auto" (0x2). var name : 0x91A.
which means that I should have a display (motherboard) if I remove the graphics card. which is not the case
I'm going to set it to enable 0x1 -> set_var_3 0x91A 0x1
then disconnect my graphics card and connect to the igpu
what do you think?
but it doesn't say why the option disappeared from the bios.

View attachment 492407
View attachment 492408
I think I know the answer to your OEM mismatch problem. This can happen if your new bios files is a different size than your prior one. To fix it you will have to use the efiflash tool with the command
Code:
efiflash biosfilename /x \NoOemID
The reference for this advice is https://www.tweaktownforum.com/foru...gigabyte-latest-beta-bios?p=747861#post747861

Here’s some info on using efiflash.
 
Top