Contribute
Register

Gigabyte Z390 M Gaming build with working NVRAM

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,910
Motherboard
Mac Studio - Mac13,1
CPU
M1 Max
Graphics
M1
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
For some reason that link isn't "click-able"? And when I copy/paste the link info I get a 524 error?

Google "TweakTown Z390 overclocking guide".
 
Joined
Feb 14, 2020
Messages
31
Motherboard
GIGABYTE Z390 M Gaminig
CPU
i5-9600K
Graphics
RX 580 4GB
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Hi there, I just installed RX 580 4GB, I've been using iGPU until now.

I used EFI folder that you provided @pastrychef for integrated GPU installation.
I deleted the parameter PciRoot(0x0)/Pci(0x2,0x0) as specified in post #1360.

It seems to work just fine but macOS is not recognizing the card.
Geekbench is detecting it.

I tried to googling it, but didn't find any solution.

Graphics is RX580 4GB Sapphire Nitro+, bios is set to quiet.
Screenshot 2020-08-21 at 19.38.24.png


Screenshot 2020-08-21 at 19.25.45.png

Screenshot 2020-08-21 at 19.43.17.png
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,910
Motherboard
Mac Studio - Mac13,1
CPU
M1 Max
Graphics
M1
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi there, I just installed RX 580 4GB, I've been using iGPU until now.

I used EFI folder that you provided @pastrychef for integrated GPU installation.
I deleted the parameter PciRoot(0x0)/Pci(0x2,0x0) as specified in post #1360.

It seems to work just fine but macOS is not recognizing the card.

I tried to googling it, but didn't find any solution.

Graphics is RX580 4GB Sapphire Nitro+, bios is set to quiet. View attachment 485186

View attachment 485184

That's cosmetic. Your video card is working fine. If you want, you can edit it to say anything you like. Please see bottom of post #3 for instructions. Look in the "How to populate System Information > PCI" section.
 
Joined
Feb 22, 2020
Messages
8
Motherboard
Gigabyte Z390 M Gaming
CPU
i5-9600K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi there pastrychef, thanks for all your hard work especially on the OC/SSDT side of things. I just have a small problem with the latest OC version. All was working perfect on a previous version, I transferred all serial numbers and the boot arg adgpmod=pikera for my 5700XT (like I've done for previous OC versions), rebooted as normal until the login screen, but my main displayport monitor is not detected, just my TV over the HDMI shows as the only monitor connected. It boots up fine showing the apple logo, but then just goes blank to no signal. I've had a look through the config.plist but honestly don't know what I'm looking for. Any suggestions? Maybe I missed something. Thanks
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,910
Motherboard
Mac Studio - Mac13,1
CPU
M1 Max
Graphics
M1
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi there pastrychef, thanks for all your hard work especially on the OC/SSDT side of things. I just have a small problem with the latest OC version. All was working perfect on a previous version, I transferred all serial numbers and the boot arg adgpmod=pikera for my 5700XT (like I've done for previous OC versions), rebooted as normal until the login screen, but my main displayport monitor is not detected, just my TV over the HDMI shows as the only monitor connected. It boots up fine showing the apple logo, but then just goes blank to no signal. I've had a look through the config.plist but honestly don't know what I'm looking for. Any suggestions? Maybe I missed something. Thanks

Open your config.plist with a plist editor and navigate to configs.plist > Kernel > Add and set WhateverGreen to enabled.
 
Joined
Apr 12, 2014
Messages
252
Motherboard
Gigabyte Z390 M Gaming
CPU
i7-9770K
Graphics
GTX 760
Mac
  1. iMac
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Classic
  2. SE
Mobile Phone
  1. iOS
- I have a AeroCool Cylon RGB case, this is a Mid tower, is this enough or should I buy a new one?

That case will support motherboard sizes ATX, micro-ATX and mini-ITX. The M Gaming is a micro-ATX size. However, what originally led me to a Silverstone PS07 case 6 years ago (and the same one I’ll be using for this next iteration) is that it supported 5.25” devices. I wanted a CD/DVD drive, so I needed that size space.

- About the power supply you mentioned I cannot found it on Amazon, I found this one. Just to know, what's is the limit down for this board? 600x?

My previous build had an i7-4700K. I built it with a Silverstone 600W power supply, but a different model from what is listed here. My new setup will have a 750W Silverstone unit. (Also a different series from what is listed here). Basically I wanted to have things covered if I decide to overclocking or swap for a more powerful graphics card. The 600W never got above luke warm so I think the 750 should not have a problem.
 
Top