Contribute
Register

Gigabyte Z390 I AORUS ITX + i9-9900K + Gigabyte GTX 1070 mini + High Sierra 10.13.6

Joined
Dec 26, 2018
Messages
25
Motherboard
Asus H110T
CPU
i5-7600
Graphics
HD 630
dust261's Build:
Gigabyte Z390 I AORUS ITX + i9-9900K + GTX 1070


406920


Components

Intel i9-9900K Processor
https://www.amazon.com/dp/B005404P9I/?tag=tonymacx86com-20

Gigabyte Z390 I AORUS PRO WiFi
https://www.amazon.com/dp/B07JBX52TM/?tag=tonymacx86com-20

XPG Spectrix D40 RGB DDR4 3600MHz 16GB
https://www.amazon.com/dp/B07C9BZQ13/?tag=tonymacx86com-20

CORSAIR SF450, 450 Watt, SFX Fully Modular Power Supply
https://www.amazon.com/dp/B01CGGOXWQ/?tag=tonymacx86com-20

Fractal Design Case FD-CA-NODE-202-BK Case
https://www.amazon.com/dp/B015MKDOPU/?tag=tonymacx86com-20

CSR Bluetooth 4.0 USB Adapter
https://www.amazon.com/dp/B07PDMY6B1/?tag=tonymacx86com-20


Already Owned


Samsung MZVLW256HEHP PM961 256GB M.2 SSD
https://www.amazon.com/dp/B06VYJMLS8/?tag=tonymacx86com-20

Crucial MX500 500GB 3D NAND SATA
https://www.amazon.com/dp/B0784SLQM6/?tag=tonymacx86com-20

Gigabyte GeForce GTX 1070 Mini ITX
https://www.amazon.com/dp/B01JD2OSX0/?tag=tonymacx86com-20


System Info


407111

406859

To make sure your igpu works in headless mode like a real mac does, check About this mac-->System Report
-->Graphics/Displays, if you see both igpu and dgpu info, then you failed
407089




Comments


I'm trying to build a dual boot machine which has Windows 10 for gaming and MacOS for coding, and I really need ITX case because I move a lot.
I know that AMD video card is the best choice for Mojave, but not perfect for Windows gaming and ITX case at the same time
Spend a lot time doing research on driving the IGPU to work in headless mode with GTX 1070 as main card properly, at the beginning FCPX kept crashing, didn't work at all, until I set up the proper ig-platform-id and device id.


BIOS Settings


  1. Chipset
    • Vt-d : Disabled
    • Internal Graphics : Enabled
    • Initial Display Output → PCIe 1 Slot
  2. Peripherals
    • USB Configuration
      • Legacy USB Support : Enabled
      • XHCI Hand-off : Enabled
  3. BIOS
    • Windows 8/10 Features : Other OS
    • CSM Support : Disabled

Installation

I have two 256 GB Samsung pm961 ssd, I've installed Windows 10 on the first one, just format the second pm961 as APFS for Mac OS


  1. Create High Sierra USB installer
  2. Install macOS High Sierra by booting the USB installer
  3. Boot into High Sierra with USB Clover
  4. Install latest Lilu, WhateverGreen, VirtualSMC, AppleALC, USBInjectAll kexts
  5. Install Nvidia web driver, set up proper ig-platform id to have full hardware acceleration
  6. Fix audio problem by set audio layout id = 7 (only work for my motherboard come with alc1220-vb) and latest Applealc.kext
406861


406862

If you have a desktop Coffee Lake/Coffee lake R CPU and Pascal Nvidia video card, you can always try this setting above. the wired thing is that when I set ig-platform-id to 3e920003 as iGPU UHD 630 suppose to be, hardware acceleration didn't work at all. I guess maybe High Sierra is too old?


Benchmarks

FCPX BruceX 5k test: 25 seconds

Geekbench 4 CPU and GPU score:
406851


406852


SSD(Samsung pm961 256gb) speed test:
406853


What Works
LAN
Bluetooth with a USB adapter
All USB ports including front ports
Audio including front ports
GPU hardware acceleration
CPU turbo boost
RAM XMP
Shutdown, Restart, Sleep/Wake


What Does Not Work
WiFi: I don’t really need it, so it doesn’t matter
Thunderbolt 3: I don't have any tb3 device to test, unknown


Update:
5/20/2019:
Customized the usb map for this motherboard by my own, 2 x Front usb 3.0 (HS/SS 09-10) and 5 x Rear usb 3.0 (HS/SS 03,04,05,07) work at 480mbps/5Gbps, Rear type c (HS06) port only works at 480 mbps mode, I also disabled internal USB (HS/FS 11-14) as the internal intel bluetooth/wifi card doesn't work. In brief, all front/rear include rear type port are working.
407140


Here is my Clover folder, for anyone who need it.
CLOVER.zip
 

Attachments

Last edited:
Top