Contribute
Register

Gigabyte Z390 Gaming X, i9-9900K, Radeon RX580, Catalina 10.15.2

Status
Not open for further replies.
Joined
Feb 13, 2013
Messages
9
Motherboard
Customac Budget ATX
CPU
i7-3770k
Graphics
EVGA Geforce GTX 650
Mac
  1. Mac mini
Classic Mac
Mobile Phone
Components
Motherboard: Gigabyte Z390 Gaming X, BIOS Version F7
CPU: Intel Core i9-9900K Coffee Lake CPU
Ram: Crucial Sport LT 16 GB (2-8GB Sticks) DDR4-3000 (PC3-24000)
Video Card: Sapphire Pulse Radeon RX580
CPU Cooler: Noctua NH-U14S
SSD: Crucial BX500 2.5 SSD, 240GB
Power Supply: Seasonic USA Focus Plus 750 Watt 80 Plus Gold ATX Fully Modular
Wireless: none
Case: Corsair Carbide Clear 400C
Monitor: Ben-Q BL2711U 4K
Keyboard/mouse: Wireless Logitech
Optical Drive: none

Comments
Software used:
UniBeast 10.0.0, MultiBeast 11.3.0
Install macOS Catalina Application 10.15.2 (8.19GB)
Clover Configurator app version 5.8.0.0

A USB 3 drive was used for the installer drive and was connected to a USB 3 port instead of a USB 2 port. HDMI connection was used between the Ben-Q monitor and the Radeon RX580 card on the Gaming X board.

Early on I experienced a problem whereby there was no display of the installer drive with MultiBeast during the final phase of macOS installation. I suspected an Internet related problem prevented the required mounting of the installer drive. So for subsequent Catalina installation attempts I decided to connect the Internet only after the installation was completed.

I used my old mid 2011 Mac Mini to clean all my SSDs, create macOS install drives and to download the 8.19GB macOS Catalina application using macOS Catalina patcher.dmg from dosdude1.com.

When consistent problems occurred and could not be resolved, I usually applied the following factory default:
Disconnect the power cord from the power supply
Press the power switch for about 15 seconds
Apply a jumper (such as a screwdriver blade) between two CLR_CMOS pins for a few seconds
Reconnect the power cord to the power supply

Creation of Installer USB Flash Drive
The installer USB drive was completed based on the following tonymacx86.com UniBeast procedure:
UniBeast: “Install macOS Catalina on Any Supported Intel-based PC”

The completed procedure resulted in an installer USB name of:
Install macOS Catalina, which contained the created EFI, the install macOS Catalina, MultiBeast-11.3.0 Mojave-Edition.zip and Clover Configurator 5.8.0.0.

Example of my installation of macOS Catalina on target ssd
After connecting the monitor, the target SSD initially entitled “Untitled”, the installer USB 3 flash drive and verifying the unconnected internet, power was then applied. Keys Delete and F7 were pressed to start the optimized default procedure for the following BIOS review.

BIOS
MIT
Adv Frequency Setting > Extreme Memory Profile(XMP) > Profile 1
BIOS
Windows 8/10 Features > Other OS
Peripherals
Trusted Computing > Security Device Support > Disabled
Super IO Configuration > Serial Port > Disable
USB Configuration > XHCI Hand-off > Enabled
Network Stack > Disabled
Chipset
VT-d > Disabled
Internal Controller > Enabled
Power
ErP > Enabled

F10 was pressed to save the changes and before the restart, F12 was pressed to select the
installer UEFI partition 1.

Initial Installation
1. On restart selected “Boot macOS Install from Install macOS Catalina” > entered.

2. After two filling bars appeared > language screen > continued

3. macOS Utility appeared > Disk Utility > continued

4. On Disk Utility > selected target ssd “Untitled” > erase > changed named from Untitled
to Catalina 15.2 and selected format APFS > erase > done > quit Disk Utility

5. macOS Utility again appeared > selected Install macOS > continued > continued> Agree >
Agree > Catalina 15.2 > Install

6. Catalina round image appeared and indicated was about 4 minutes remaining > restarted

Expanded Installation
7. On restart selected “Boot macOS Install Prebooter from Preboot > entered

8. After two filling bars > Catalina round image appeared and indicated was about 12 minutes
remaining > restarted

9. On restart selected “Boot Filevault Prebooter from Prebooter” > entered

10. Wellcome screen appeared followed by additional install instructions. Used finder to add
ssd Catalina 15.2 image to the screen.

11 The MultiBeast 11.3 part from installer Install macOS Catalina was next selected ]
The following MultiBeast 11.3 drivers and selections were installed or bypassed.
Drivers:
Quick Start > bypassed
Audo > AppleALC > bypassed
Misc > Fake SMC
Misc > Fake SMC Plugins
Misc > Fake SMC HWMonitor Application
Network > Intel > IntelMausiEthernet v2.4.0
USB > bypassed
Bootloaders > bypassed
Customize > System Definition > iMac > iMac 19,1

To end MultiBeast 11.3 > Build > Install > Agree > Password > install Helper
After Install Succeeded, closed MultiBeast and then reopened Install macOS Catalina.

12. On Install macOS Catalina > selected Clover Configurator > Mount EFI
On EFI on Install macOS Catalina part > selected Mount Partition > password >
opened partition > corresponding EFI displayed.

On EFI on APFS Container (Catalina 15.2 etc) > opened partition > no corresponding EFI
showed and I copied the EFI from the previous Install macOS Catalina part unto the
APFS partition

Closed the Clover Configurator, ejected installer Install macOS Catalina and then restarted
the computer. Selected “Boot Filevault Prebooter from Prebooter to start the new installation
but the start stalled. As a remedy, I reapplied optimized default and problem was solved.

Results
There is no audio output from the Gaming X board and the HDMI audio output is satisfactorily. The
USB 3 ports that I normally use appear to work ever though I have not activated the USB ports on
MultiBeast 11.3. Instead of shutting down completely, the computer restarts.
 
Joined
Feb 13, 2013
Messages
9
Motherboard
Customac Budget ATX
CPU
i7-3770k
Graphics
EVGA Geforce GTX 650
Mac
  1. Mac mini
Classic Mac
Mobile Phone
The audio output from the Z390 Gaming X board was fixed using the method by
Bleyses in his guide “Solved > Catalina easy update and sound fix found in Forum > Install
Catalina Desktop Support

Part of his audio fix includes a Sound Fix attachment which uses:
AppleALC.kext
AppleHDA.kext
Lilu.kext
Text file which shows the codes used for Terminal installation into Library/Extentions

After a restart both internal and HDMI audio outputs were good..
 
Joined
Jun 17, 2019
Messages
47
Motherboard
Gigabyte Z390 Gaming X
CPU
i7-9700
Graphics
UHD 630
Thank you for your posting.
I installed Catalina successfully, but Graphics don't work correctly.


Any advice?
 
Status
Not open for further replies.
Top