Contribute
Register

Gigabyte Z370 HD3P - i7 8700K - RX580 8GB - Catalina 10.15.4

Joined
Mar 9, 2018
Messages
9
Motherboard
Gigabyte Z370 HD3P
CPU
i7-8700
Graphics
RX 560
Mac
MacBook Pro
Classic Mac
Plus, SE/30
Mobile Phone
iOS
Great to hear. Have you tried Netflix since upgrading?
Yep, and no success. But I'm getting the very same error on Safari with my Macbook Pro when I connect an external screen
 
Joined
Feb 10, 2012
Messages
72
Motherboard
GB Z370-HD3P
CPU
i5 9600K
Graphics
RX 580
Mac
MacBook Pro
Classic Mac
512K
Mobile Phone
iOS
Yep, and no success. But I'm getting the very same error on Safari with my Macbook Pro when I connect an external screen
It should work on your MBP provided you use a HDCP compliant cable, just FYI in case you want that to work.
 
Joined
Dec 20, 2011
Messages
11
Motherboard
Gigabyte GA-Z68-UDH3-B3
CPU
i7-2600K
Graphics
HD6870
Mac
MacBook Pro
Mobile Phone
Other
Hi there and thank you for your guide.

I am totally unable to make USB3 ports running faster than USB2 speed, I am pretty sure I am missing something or doing something wrong. Can you help me?

I have a pretty much similar system as yours, except for:

- 64GB RAM
- Sapphire Radeon RX580
- Double boot: Windows10 and Mojave 14.2.
- An OTB fully working firewire card SYBA SD-PEX30009


What I have already done and tried, with no success:

- I have already configured a USBPorts.kext for my system, using Intel FB. It is attached with this message
- Included XHCI-200-series-injector.kext, USBPorts.kext, WhateverGreen.kext. and Lilu.kext in Efi/Clover/Kexts/Other
- Also tried installing them in Library/Extensions using Kextbeast
- Deleted USBInjectAll.kext from Library/Extensions.
- Included via Clover Config, synchronize and save, then reboot:

<dict>
<key>Comment</key>
<string>disable port limit in XHCI kext (credit DalianSky,Ricky)</string>
<key>MatchOS</key>
<string>10.14.1,10.14.2</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Find</key>
<data>g/sPD4OPBAAA</data>
<key>Replace</key>
<data>g/sPkJCQkJCQ</data>
</dict>

- also tried with

<dict>
<key>Comment</key>
<string>disable port limit in XHCI kext (credit PMHeart)</string>
<key>MatchOS</key>
<string>10.14.0</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Find</key>
<data>g/sPD4MDBQAA</data>
<key>Replace</key>
<data>g/sPkJCQkJCQ</data>
</dict>

Any idea? Thanks in advance!

Ok, so I have managed to reinstall Mojave and update to 10.14.3 and after a lot of tries and errors, I have a usbports.kext that works...partially. Seems that the problem in my previous installation was clover configurator changes not affecting the boot. Maybe they were saving in another place?

Anyway, after trying to detect all the ports, I have not managed to detect neither the usb C nor the usb 3.1 gen2 with Hackintool 1.8.1, so the usbports.kext generated archive does not include them but the USB 3.1 Gen 2 does accept usb 3.0 hard disks even when it does not show in hackintool or systems information and it's not included in the usbports.kext...very strange. I see that user maecsa's attached usbports.kext does neither include them.

I attach my usbports.kext and automatically generated SSDT-EC.aml in case they are useful for someone

Apart from that, I have a Viewsonic VP2785-4K which includes a usb 3.0 hub, which is detected by Hackintool and also appears in System's information as a 4 usb 3.0 hub, but I'm totally unable to use it, very weird, also.

Any help would be appreciated. Thanks!
 

Attachments

Joined
Mar 9, 2018
Messages
9
Motherboard
Gigabyte Z370 HD3P
CPU
i7-8700
Graphics
RX 560
Mac
MacBook Pro
Classic Mac
Plus, SE/30
Mobile Phone
iOS
Hi. Can you please attach a screen shot with what files you have in drivers64UEFI folder EFI/EFI/CLOVER/drivers64UEFI.
Thank you

Sure. Here's my EFI folder plus an screetshot of EFI/EFI/CLOVER/drivers64UEFI. EFI folder should be re-serialized, etc., etc. I'm in the same situation than sorginetxe with the extra problem that I don't own any 3.1 device to check it out.

Not an expert on this, but USB activity can be monitored plugging and unplugging USB (3.1 in this case) devices and showing activity with IORegistryExplorer. Maybe this is the way to follow but as I told you before, no 3.1 devices here to test it :(

Greets! :)
 

Attachments

Joined
Mar 15, 2014
Messages
4
Mac
Classic Mac
Mobile Phone
Hey just a heads up, that I updated to the F11b bios and could not get my system to boot. Tried every bios setting. I downgraded to F10, loaded defaults, made the usual changes and was back up and running. Friendly warning that might save some people the headache.
 
Joined
May 4, 2014
Messages
9
Motherboard
I still didn't read
CPU
the RULES
Graphics
so ignore me
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Hey just a heads up, that I updated to the F11b bios and could not get my system to boot. Tried every bios setting. I downgraded to F10, loaded defaults, made the usual changes and was back up and running. Friendly warning that might save some people the headache.
I updated to the last F11 BIOS and could not get my system to boot. :crazy:
 
Joined
Jun 24, 2018
Messages
1
Motherboard
Gigabyte GA-Z370 HD3P
CPU
i9 9900K
Graphics
UHD 630
Hello, are there any hints about F11/12 BIOS and the boot problems? I have the same motherboard with i9-9900K processor and have the same issues. Thanks a lot!
 
Joined
Mar 9, 2018
Messages
9
Motherboard
Gigabyte Z370 HD3P
CPU
i7-8700
Graphics
RX 560
Mac
MacBook Pro
Classic Mac
Plus, SE/30
Mobile Phone
iOS
Has anyone been able to get all the internal and external USB ports working on 10.14.4? I'm having a lot of issues with that. If you have, mind sharing any relevant config/dsdt/kexts?

Hi, no issues here. I connect 2.0 and 3.0 USB sticks with no problems on 10.14.4. Updated kexts and Clover before doing the macOS upgrade.

Enclosed my version (deserialized etc). Hope it works for you.
 

Attachments

Top