Contribute
Register

Gigabyte Z270X Gaming 9 - i7 7700k - GTX 1080 - Video Processing

Status
Not open for further replies.

SMW

Joined
May 12, 2013
Messages
21
Motherboard
GIGABYTE GA-Z270X-G9
CPU
i7 7700k
Graphics
EVGA GTX 1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Gigabyte Z270X Gaming 9 - i7 7700k - GTX 1080 - High Sierra & Win 10
Components_IMG_2822.jpg
Components

Intel i7-7700K CPU
https://www.amazon.com/dp/B01MXSI216/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16819117726

Corsair H60 CPU Water Cooler
https://www.amazon.com/dp/B00A0HZMGA/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16835181030

Gigabyte Z270X Gaming 9 Motherboard
https://www.amazon.com/dp/B01N4F25ZH/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16813128961

Crucial Ballistix Sport LT 64GB Kit (16GBx4) DDR4 2666
https://www.amazon.com/dp/B01B4F3MNQ/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16820164039

SAMSUNG 960 PRO M.2 512GB NVMe SSD
https://www.amazon.com/dp/B01LXS4TYB/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16820147596

EVGA GTX 1080 8GB GDDR5X Graphics Card (08G-P4-5180-KR)
https://www.amazon.com/dp/B01K1JW8CW/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16814487278

Enermax Revolution SFX 650W 80 PLUS Gold Power Supply
https://www.amazon.com/dp/B01MS0A71O/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=9SIA6ZP58K2006

iStarUSA E-40/ATX (steel chassis)
https://www.amazon.com/dp/B005SZ4RZ6/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16811165177


Comments

The primary purpose of this build is to have a decent video/data processing system that is still portable and relatively inexpensive, I had hoped for multiple thunderbolt ports but Gigabyte recently removed the Z270X Gaming 9 motherboard from the compatibility lists of it's thunderbolt add-on cards, guess the thunderbolt header is a waste of x4 PCI-e lanes.

The case is a compact steel chassis, a handle and extra case fans were added for better air flow and portability, it has one integrated thunderbolt 3 port. One USB 3.1 C port from an onboard header. Two eSATA ports from the onboard ASMedia SATA controller. Also runs an Areca HBA controller and (x8) 2.5" internal SAS drive RAID5 - 7 TB (read 800 MB/s write 700 MB/s).

Working
- USB 3.0 and 3.1 ports
- Thunderbolt 3
- Removed onboard killer wifi/bt card (added an OSXWifi card)
- Sound through Blackmagic 4k Monitor output card​

Didn’t Work
- Creative Sound Core 3D Audio (Works over HDMI only for now)
- Additional Gigabyte Thunderbolt 3 add on card is detected but doesn't work with current BIOS
- This motherboard was recently removed from the thunderbolt add-on card list
- Unable to install windows 10 from USB flash drive, had to install from a DVD​


Installation Notes

Duel boot macOS High Sierra 10.13.1 and Win 10, each on an M.2 512 GB NVMe.

Mac OS High Sierra: after installing the Fakesmc plugin options for HWSensor in MultiBeast remove the FakeGPU.kext or it causes a kernel panic, before you reboot, go to Library/Extensions and delete the FAKEGPU.kext. I had a lot of trouble with the iGPU HD630 and finally disabled it in favor of only using the GTX 1080 GPU.

Win 10: install a mac partition first, and include a primary (fat32) partition that will be used for the windows 10 boot drive later. Install windows in order to activate motherboard features and chipset firmware, such as the integrated thunderbolt 3 controller.


Installation
Rolled back the BIOS to F5, (the newer F6 and F7b didn't seem stable) then loaded optimized settings. I followed a couple of suggestions from a few of the 7700k Gigabyte Gaming 5 or 7 User Builds, but I primarily followed the macOS 10.13 installation guide (reference), as well as the trouble shooting guides at the bottom.

BIOS TAB
BIOS Features > Windows 8/10 Features > Other OS
BIOS Features > Storage Boot Option Control > UEFI Only
BIOS Features > Boot Option #1 > UEFI USB Drive​

Peripherals TAB
Initial Display Output > PCIe 1 Slot
Peripherals > XHCI Hand-off > Enable
Network Stack > Disabled
Thunderbolt Security Level > No Security​

Chipset TAB
VTd > Disabled
Internal Graphics > Disabled​

Testing


Geekbench 4 testing average out to around 21K, at the base 4.2/4.5 GHz clock speed. The system is able to view/playback 8K R3D clips in Redcine 50 at real time at 1/4 resolution. Full R3D Raw 8k playback in Davinci 14, at 1/4 resolution on a 4k time line.

Redcine50 transcoding tests, able to transcode 8k R3D files at 1/4 resolution to 1080p ProRes 422HQ at realtime or better, around 24 fps. Able to transcode 8k R3D files at 1/2 resolution to 4kHD ProRes 422HQ at around 15-18 fps.

Geekbench 2017-11-08.jpg

Updates 11-07-2017

Multibeast 10.1 for High Sierra

GC-ALPINE RIDGE & OTHER NOTES
1. I'm annoyed with Gigabyte, I picked up the GC-ALPINE RIDGE thunderbolt 3 addon card since (gen1 and 2) were listed as compatible with this Motherboard and this Motherboard has a TB header, after a few days of not getting it to work I contacted Gigabyte after a lot of difficulties and they eventually responded by saying no thunderbolt addon cards were compatible with this motherboard and then the next day this motherboard was removed from the compatibility list of all their GC-ALPINE RIDGE cards, so I guess the thunderbolt header is completely useless.

2. Additionally any USB-C cable attached to the onboard motherboard 3.1 header does nothing, it doesn't work, no connection or power provided, but it does short-out your motherboard or prevent it from booting up.

3. And this motherboard does not have one of the more standard integrated sound cards, so no luck with getting working onboard sound on the Mac Side. HDMI audio output does work at least.

4. Also this motherboard is not compatible with 64 GB RAM, not matter what I tried, different RAM and different motherboards (after a two week RMA), 64 GB RAM causes constant corruption and random reboot or failure to boot, So stick with 32 GB RAM.
 
Last edited:
Joined
Jul 1, 2017
Messages
40
Motherboard
GA-Z270-Gaming K3
CPU
i7 7700
Graphics
HD 630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
The Amazon link in SAMSUNG 960 PRO M.2 512GB NVMe SSD is wrong.

Could you share your Samsung 960 M2 performance? (BlackMagic Disk Speed Test)
and do you have a slow boot with it?

Thanks for share this build! :D
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,089
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Link fixed. Thanks, Aerz, for the oops.
 

SMW

Joined
May 12, 2013
Messages
21
Motherboard
GIGABYTE GA-Z270X-G9
CPU
i7 7700k
Graphics
EVGA GTX 1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
The Amazon link in SAMSUNG 960 PRO M.2 512GB NVMe SSD is wrong.

Could you share your Samsung 960 M2 performance? (BlackMagic Disk Speed Test)
and do you have a slow boot with it?

Thanks for share this build! :D

The system boots pretty quickly, about 10 seconds or less for both High Sierra or Windows 10, and the speed tests for both M.2 SSD are about the same, 1800 MB/s write and 2800 MB/s read speeds. Fast and Ultra-Fast boot options are disabled.

SpeedTest_2017-11-08.jpg
 
Last edited:
Joined
Nov 26, 2010
Messages
16
Motherboard
Gigabyte Aorus X299 Gaming 9
CPU
i9 7900x
Graphics
Gigabyte Aorus 1080 ti WB Waterforce x2
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Would you mind sharing your config with me? I've got the same board and I can't get HS to install for the life of me.
 
Last edited:

SMW

Joined
May 12, 2013
Messages
21
Motherboard
GIGABYTE GA-Z270X-G9
CPU
i7 7700k
Graphics
EVGA GTX 1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
The GA-Z270X-Gaming9 motherboard ended up having a defective Ram Dimm slot #3, which kept causing random shutdowns and OS corruption, I had to RMA the motherboard which has taken two weeks, hopefully I have time to rebuild this system over the weekend.
 
Joined
Nov 26, 2010
Messages
16
Motherboard
Gigabyte Aorus X299 Gaming 9
CPU
i9 7900x
Graphics
Gigabyte Aorus 1080 ti WB Waterforce x2
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
The GA-Z270X-Gaming9 motherboard ended up having a defective Ram Dimm slot #3, which kept causing random shutdowns and OS corruption, I had to RMA the motherboard which has taken two weeks, hopefully I have time to rebuild this system over the weekend.
That sucks man. Hope your new one is better. I haven't had any issues with that. I don't suppose you remember any specific kexts or drivers you used in your usb installer to get it to work? I managed to get through the first reboot but then the installer gives me an error about not being able to update firmware.
 

SMW

Joined
May 12, 2013
Messages
21
Motherboard
GIGABYTE GA-Z270X-G9
CPU
i7 7700k
Graphics
EVGA GTX 1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
The motherboard and system chipset firmware, such as USB C and Thunderbolt 3 controllers can only be activated and updated through Windows 7 or 10, unfortunately, but once that's done they all worked on my system.
 
Joined
Nov 26, 2010
Messages
16
Motherboard
Gigabyte Aorus X299 Gaming 9
CPU
i9 7900x
Graphics
Gigabyte Aorus 1080 ti WB Waterforce x2
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Yeah I'm on the latest firmware. It's more an issue of the installer not seeing a firmware value it likes from my config.plist I think. I've updated clover and tried a few different SMBIOS options, mainly iMac14,2 and iMac18,3, but none work. Same error. I guess I'll keep plugging away at it. If you get yours up and running again I'd love to see your efi folder.
 

SMW

Joined
May 12, 2013
Messages
21
Motherboard
GIGABYTE GA-Z270X-G9
CPU
i7 7700k
Graphics
EVGA GTX 1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I had to jump through a few hoops to get Sierra or High Sierra setup and running a few weeks ago, but this last week I used the new Unibeast + Multbeast release (downloaded HS again, new boot installer) and everything went super smooth, no issues or hoops to jump through this time. Try creating a new updated HS boot installer.

One issue, the new Z270X-G9 motherboard had the exact same problem of the previous RMA'd motherboard, seems it won't run 64 GB Ram, had to limit the build to x2 16GB DIMMs (32 GB RAM total) then everything ran smoothly, with all x4 DIMMs it was not stable and I had a lot of random issues, such as the installs and/or the OS and firmware kept ending up corrupted, maybe try installing everything with only x2 DIMMs installed on the motherboard. I also had a lot of problems until I disabled the IGPU.
 
Last edited:
Status
Not open for further replies.
Top