Contribute
Register

Gigabyte X299X - Catalina Support

Joined
Mar 6, 2013
Messages
273
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10980XE
Graphics
AMD 6900XT
Mobile Phone
  1. Android
Hi tosh, thank you very much for your detailed reply to my post. I've been super busy the last weeks and haven't been able to go through it in detail, but hope to soon.

I think I had exactly the same problem as you when I tried to update on BIOS F3f - the system freezing after a couple of minutes. I posted about it a couple of pages back. I was confused because other users were reporting that they were on F3f with no problems, but I guess that difference is because I was on 11.4 and they weren't. When I got that freeze I then got a Crash Report dialogue on the next boot, and this seemed to indicate the problem was related to NVMe somehow.

I'll try again soon with F3f and F3g on macOS 11.5 and see if it's any different - but based on your findings I'm not expecting it to be.

Thank you for your findings on VCCSA! Based on your view that this is purely a display problem, and that VCCSA is definitely set correctly, I have gone back to setting mine and not leaving it at AUTO. It is a weird problem, because even OS monitoring tools report it at 0.9v, not just the BIOS.

Also that's great info about how to get in touch with GB support. I will have to try messaging them sometime.

I will reply to your post with more details of my findings hopefully soon, when I can test the BIOS update again.

Does anyone have the same problem? Is there a solution?
Yes I have the same problem, and always have:

1628512816840.png


Others have reported it as well. I think it must be an issue with the Small Tree drivers.
 
Joined
Jan 25, 2010
Messages
11
Motherboard
Z390 Designare
CPU
9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. Mac Pro
Mobile Phone
  1. Android
OC 0.7.2
mobo Gigabyte X299X Designare 10G, F3C with 6800 XT on Big Sur 11.4.
There is still USB issue, all USB port was gone.
somebody resolve this issue?

And I have a question 6800 XT working on OC 0.6.8?
 

Attachments

  • EFI.zip
    49.1 MB · Views: 35
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,180
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Joined
Mar 6, 2013
Messages
273
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10980XE
Graphics
AMD 6900XT
Mobile Phone
  1. Android
OC 0.7.2
mobo Gigabyte X299X Designare 10G, F3C with 6800 XT on Big Sur 11.4.
There is still USB issue, all USB port was gone.
somebody resolve this issue?

And I have a question 6800 XT working on OC 0.6.8?
The 6800XT and 6900XT should work fine on any version of OC.

The USB issues are not related to the GPU. They're because you don't have a USB port map. Check for my earlier posts in this thread, where I uploaded my EFI including a USB port map. Some other people have uploaded theirs as well.
 
Joined
Jan 25, 2010
Messages
11
Motherboard
Z390 Designare
CPU
9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. Mac Pro
Mobile Phone
  1. Android
The 6800XT and 6900XT should work fine on any version of OC.

The USB issues are not related to the GPU. They're because you don't have a USB port map. Check for my earlier posts in this thread, where I uploaded my EFI including a USB port map. Some other people have uploaded theirs as well.
Thanks
I"ll check USB Map again.
 
Joined
Feb 5, 2012
Messages
3
Motherboard
Gigabyte X299X Designare 10G
CPU
Intel i7-7820X
Graphics
Sapphire RX VEGA 64 Nitro+
Mobile Phone
  1. iOS

Attachments

  • X29XD10G.F3h.zip
    7.5 MB · Views: 11
Joined
Feb 5, 2021
Messages
37
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10980xe
Graphics
AMD Pro w5700
Mac
  1. Mac Pro
Joined
Feb 5, 2012
Messages
3
Motherboard
Gigabyte X299X Designare 10G
CPU
Intel i7-7820X
Graphics
Sapphire RX VEGA 64 Nitro+
Mobile Phone
  1. iOS
HI

Since Big Sur 11.3 the recent bios do not work.

If you use Big Sur the only solution is the F3c BIOS
But this bios has a lot of bugs (I had a lot of problems personally).

I gave up Gigabyte and bought an Asus motherboard => No problem
Thank you for your answer. I think I should do the same. I think Hackintosh is difficult with the X299X Designare 10G board.
 
Joined
Aug 2, 2021
Messages
4
Motherboard
Gigabyte Designare X299X 10G
CPU
Intel i9-10980XE
Graphics
AMD 6900 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I got this board in September and have the F2 bios on it at the moment, I have got my settings dialled in fairly well but waiting on better cooling before trying to overclock (only have a EKWB 240mm AIO as it stands).

Should I upgrade the bios to F3C / if I do, can I go back? Sorry if this is obvious...!

Thanks for all your help so far!
 
Joined
Feb 5, 2021
Messages
37
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10980xe
Graphics
AMD Pro w5700
Mac
  1. Mac Pro
I got this board in September and have the F2 bios on it at the moment, I have got my settings dialled in fairly well but waiting on better cooling before trying to overclock (only have a EKWB 240mm AIO as it stands).

Should I upgrade the bios to F3C / if I do, can I go back? Sorry if this is obvious...!

Thanks for all your help so far!
Hi,
The F2 version is really an old version so yes, I advise you to use the F3c version.

Yes you can go back and put an old bios
 
Top