Contribute
Register

Gigabyte X299X - Catalina Support

Joined
Feb 15, 2018
Messages
320
Motherboard
Aorus Master Z490
CPU
i9-10900K
Graphics
Intel 630
Mac
  1. iMac
Mobile Phone
  1. iOS
It was posted here #441
My EFI is attached. Made for x299x Aorus Master BIOS F3d i9 10980 XE 18-core and 5700XT 8 GB. Catalina 10.15.6
You should check RTCMemoryFixup.kext and SSDT-UIAC-ALL.aml as these are system specific.

I have also attached BIOS settings file so you can Load it for use.
hi i’m almost done painting my house, i will give your efi a try, then later in a few weeks i will try to make my own efi but as right now i can use yours as starting point, i have the same board, the same card, my cpu is the 9980xe, tecnically the same, just a few less pci-e lanes and a little lower turbo boost, but if you overclock both cpu to the same frequency, they should be very similar

this is the reason why i stopped trying to install mac os, besides being busy and the boot bios failure

i have a complete aorus system, meaning everything is aorus brand

the m2 drives that i have are the aorus 1 tb pci-e 4.0

i’m not sure if mac os support those drives because it uses some kind of special controller

my question is, does anybody have install mac os using aorus m2 pci-e 4.0 drives?

thanks for the files
 
Joined
Jan 19, 2019
Messages
248
Motherboard
Z390 M Gaming
CPU
i9-9900
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I change IOCPUNumber to 19 but I still can't boot...
I have the same KP info:
x86_validate_topology() 20 threads but 21 registered from .......



It was posted here #441
My EFI is attached. Made for x299x Aorus Master BIOS F3d i9 10980 XE 18-core and 5700XT 8 GB. Catalina 10.15.6
You should check RTCMemoryFixup.kext and SSDT-UIAC-ALL.aml as these are system specific.

I have also attached BIOS settings file so you can Load it for use.
 
Joined
Jan 19, 2019
Messages
248
Motherboard
Z390 M Gaming
CPU
i9-9900
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
9820x has issues:

Will buy a 99xx or 109xx and try.

I change IOCPUNumber to 19 but I still can't boot...
I have the same KP info:
x86_validate_topology() 20 threads but 21 registered from .......
 
Joined
Jan 25, 2011
Messages
137
Motherboard
GA-X99-UD5-WIFI
CPU
i7 5960X
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I know I should change TSCAdjustReset.kext: IOCPUNumber should be 19 since I'm using 9820X.

What do I need to do with RTCMemoryFixup.kext?

SSDT-UIAC-ALL.aml is for USB mapping only and will not impact system boot up, right?
IOCPUNumber should be 19 since I'm using 9820X is correctly. RTCMemoryFixup you don't need but I have stripped all the unnecessary stuf and enabled portlimitpatch so you can create your own USB-SSDT.aml
With the BIOS settings of my previous post and this EFI you should be able to boot.
Good luck!
 

Attachments

  • EFI.zip
    2.8 MB · Views: 29
Joined
Jan 25, 2011
Messages
137
Motherboard
GA-X99-UD5-WIFI
CPU
i7 5960X
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
my question is, does anybody have install mac os using aorus m2 pci-e 4.0 drives?

thanks for the files
I would not try others M.2 drives then Samsung as they are in every Mac and will work with OSX.
 
Joined
Feb 15, 2018
Messages
320
Motherboard
Aorus Master Z490
CPU
i9-10900K
Graphics
Intel 630
Mac
  1. iMac
Mobile Phone
  1. iOS
I would not try others M.2 drives then Samsung as they are in every Mac and will work with OSX.
i always used samsung in the past
960 pro
970 pro

but this time i went with pci-e 4.0 and since i was building an aorus system

i also wanted the drives to be aorus

i know my board is only pci-e 3.0
but i get a bit faster writing speed by using pci-e 4.0 instead of pci-e 3.0

i think the 970 pro was only 2.2 writing speed

which in most cases might drop down to just 2 gbps

but by using a 4.0 drive on a 3.0 board, i get 3.5 in writing speed, it seems like 3.5 is the max, the pci-e 3.0 4x can handle

the good thing is that now my reading speed and my writing speed

both are at 3.5

instead of 3.5 and 2.2

the down side might be that my drive might not be supported on mac os

i had that idea on the back of my head when i ordered those drives

i will find out soon enough
if the drivers are compatible with mac or not

this was the last time i was running mac os until mr cook decided to ruin everything
 
Last edited:
Joined
Jan 19, 2019
Messages
248
Motherboard
Z390 M Gaming
CPU
i9-9900
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thank you! I'll try to 10900X and report back.

IOCPUNumber should be 19 since I'm using 9820X is correctly. RTCMemoryFixup you don't need but I have stripped all the unnecessary stuf and enabled portlimitpatch so you can create your own USB-SSDT.aml
With the BIOS settings of my previous post and this EFI you should be able to boot.
Good luck!
 
Joined
Aug 6, 2013
Messages
48
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10900X
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I'm on OC 0.6.0 and did not create my own SSDTs and using the OP ones, for now.

My sound works fine over BT. It's the analog output and HDMI I'm having problems with.

I temporarily solved the HDMI problem by installing RX 580 along with RX 5700 XT and plugging the HDMI TV in RX 580.
I'm curious if there are people for whom RX 5700 XT HDMI sound works as expected. It might be a problem with Apple drivers, or something I didn't do right.

I did get Thunderbolt working. I programmed the firmware per OP instructions using RPi 3B-based programmer.

I don't have many TB devices. I've found that the classic TB2 Apple Gigabit Ethernet adapter works, connected via Apple's TB2 <-> TB3 adapter.

I've just copied files from a 13" MBP booted in Target Disk Mode, to my Hack while writing this. That worked for a 6.7GB directory, uneventfully.

On the other hand, connecting a TB3 Belkin dock shows the device in System Information but nothing from the dock itself shows up.

I wish I could check a TB3 drive and somehow enable external display over TB3 but I have neither TB3 drive nor TB display.

As for USB, I only have a couple of ports on my case, haven't noticed any problems yet. Will keep an eye on it.
I use Intel BT driver, and I definitely need an external antenna to have a reliable connectivity for my BT devices. The antenna that comes with the motherboard works just fine for me.

I use Apple keyboards and mice and trackpads via Bluetooth and only connect my Logitech keyboard/touchpad combo to deal with BIOS, because the BT ones don't work in BIOS. I'm sure someone somewhere is working on UEFI driver for them. I'd love to know.

For USB keyboard/mouse receivers, sometimes I have a bad interference for my Logitech receiver and I then connect it using Apple USB2 extender cable, which fixes the problem. Naturally it does not have to be Apple USB2 extender.


@Dogman no, i am still using 0.5.9. i will post my bios settings a little later today for you guys. Standard settings though. I didn't do anything special. Could the different monitors we use have anything to do with it? I'm using a crg9.I did notice it is slow to show on the display upon wake but it seems to work fine.

@teosoft not sure if this helps, but check the efi i posted previously and test with the boot arguments I shared. Sound works for me, but only tested via bluetooth headphones as I don't have my thunderbolt audio interface working yet.

This leads me to my next question:

@teosoft @Dogman how did you guys get thunderbolt working? I tried connecting with my audio interface and external hard drives and it wouldn't ever be detected, though i was using a thunderbolt 2 to thunderbolt 3 adapter. Is modifying the motherboard as the OP did necessary to get thunderbolt working or do i just need certain files/kexts in my efi? Please note i'm using pre-built ssdt's.

Lastly, are either of you experiencing an issue where if all usb ports are full, certain things stop responding? For example, with my mouse and keyboard usb receivers in the computer ports, along with USB flash drives, my mouse or keyboard stops responding. They seem to work better if i relocate the placement of the USB drives/receivers. This concerns/puzzles me.
 
Joined
Jan 19, 2019
Messages
248
Motherboard
Z390 M Gaming
CPU
i9-9900
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
10900X works great! Thank you very much!

IOCPUNumber should be 19 since I'm using 9820X is correctly. RTCMemoryFixup you don't need but I have stripped all the unnecessary stuf and enabled portlimitpatch so you can create your own USB-SSDT.aml
With the BIOS settings of my previous post and this EFI you should be able to boot.
Good luck!
 
Joined
Jul 20, 2014
Messages
812
Motherboard
Asus ProArt B550 Creator
CPU
Ryzen 9 5900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
i always used samsung in the past
960 pro
970 pro

but this time i went with pci-e 4.0 and since i was building an aorus system

i also wanted the drives to be aorus

i know my board is only pci-e 3.0
but i get a bit faster writing speed by using pci-e 4.0 instead of pci-e 3.0

i think the 970 pro was only 2.2 writing speed

which in most cases might drop down to just 2 gbps

but by using a 4.0 drive on a 3.0 board, i get 3.5 in writing speed, it seems like 3.5 is the max, the pci-e 3.0 4x can handle

the good thing is that now my reading speed and my writing speed

both are at 3.5

instead of 3.5 and 2.2

the down side might be that my drive might not be supported on mac os

i had that idea on the back of my head when i ordered those drives

i will find out soon enough
if the drivers are compatible with mac or not

this was the last time i was running mac os until mr cook decided to ruin everything
Interesting
What is the brand and model of your PCIe 4 M.2 drives ?
EDIT
is it this one ? :
 
Top