Contribute
Register

Gigabyte X299X - Catalina Support

Joined
Jul 10, 2013
Messages
303
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10900X
Graphics
RX 5500 XT
Mac
iMac, MacBook Pro, Mac Pro
Classic Mac
eMac, iBook, iMac, PowerBook
Mobile Phone
Android
Disable thunderbolt in BIOS before taking photo.
The picture is with TB disabled
IMG_20191205_113148.jpg

2nd
IMG_20191205_113046.jpg

Sata=AHCI
It comes AHCI by default, also checked...
CSM=Disable
Always CSM=Off

All "basic" checks have been made, I have many machines running and I'm familiar with the drill, that's why I don't get why this isn't working :lol:.

@nmano find the DSDT, I have tried to pinpoint the TB location, but could be anywhere.. On X299 Designare EX I think it was RP05, who knows where it might be here..
 

Attachments

Joined
Jul 10, 2013
Messages
303
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10900X
Graphics
RX 5500 XT
Mac
iMac, MacBook Pro, Mac Pro
Classic Mac
eMac, iBook, iMac, PowerBook
Mobile Phone
Android
@dolgarrenan
Try OpenCore. This is the way :)
Attached is my EFI for OpenCore V 054. ( UUID & SN are removed ).
You only need to adapt the SSDTs & custom USB Kext to your Mobo/ACPI path/entries. ( Also ACPI Tables of your TB).
TSCAdjustReset.kext reflects your cpu ( 10 C. ).
If you change the names of SSDTs or Kexts, they also need to be reflected in the config.plist ( Use XCODE to edit ).
Cleaning/Resetting the NVRAM before changing EFI is recommended.
Best of Luck. Happy Holidays. ( Still retired )
I'll surely git it a go, I have my X299 Designare also with a OC boot as secondary (for messing around) and have tried with that boot and it also gives an error, I just can't recall which, I'll check later with your EFI!

Thanks my friend
 
Joined
Oct 12, 2010
Messages
700
Motherboard
X299-WU8
CPU
i9-9880XE
Graphics
Vega 64
Mac
iMac, Mac Pro
The picture is with TB disabled
View attachment 440877
2nd
View attachment 440878

It comes AHCI by default, also checked...

Always CSM=Off

All "basic" checks have been made, I have many machines running and I'm familiar with the drill, that's why I don't get why this isn't working :lol:.

@nmano find the DSDT, I have tried to pinpoint the TB location, but could be anywhere.. On X299 Designare EX I think it was RP05, who knows where it might be here..
Try This DSDT patch for change device address to Device (RP05)
Find
52503035 085F4144 520C0400 1C
Replace
52503035 085F4144 520C0900 1C
 
Last edited:
Joined
Nov 17, 2010
Messages
13
Motherboard
Hackintosh
CPU
Core i7 3770K
Graphics
GTX 670
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Did you have time to check these settings, @dolgarrenan ? No pressure but i'm planning on getting the same config :)
 
Joined
Apr 23, 2019
Messages
20
Motherboard
Asus z390 maximus xi extreme
CPU
I9-9900k
Graphics
UHD 630
Much thanks and recognition to all that are working on this Gigabyte x299x designare 10g motherboard. This motherboard will be the best for music production and content creators alike. Wish the best..Thanks!
 
Joined
Mar 18, 2017
Messages
719
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7940X
Graphics
2x Vega 56
Mac
iMac, Mac mini
Mobile Phone
iOS
NEW YEAR -----> New Build
I decided to choose a Gigabyte mobo and I just finished the setup of a new build:
- Mobo : Gigabyte X299 AORUS Ultra Gaming Pro / new bios PCIe Bifurcation and upcoming Cascade Lake-X 10 000 series
- Processor : i9 9940x (expecting soon delivery of an i9-10980 XE)
- Ram : 64 GB 8x8 GB Corsair Dominator Platinum
- PSU : 1000 W EVGA G3
- Vega 56 x2
- Asus Hyper M2 V2 PCIe Card
- Gigabyte Alpine Ridge Thunderbolt ( Titan Ridge unavailable actually here)
- Custom Alphacool watercooling ( 1 x 240 XT 60 + 1 x 240 XT 45 + 755 VPP waterpump on 5" bay station with 8 Noctua fans )


Everything works perfectly ( thanks @Ellybz for perfect OC EFI Folder)
Even Thunderbolt hut plug :thumbup:
( no exactly a X299X but almost the same...)


PCIe config:
- PCIE 16_1 Vega 56 running at 16X
- PCIE 16_2 Asus Hyper M2 V2 ( PCIe bifurcation 4x4)
- PCIE 4_2 GC Alpine Ridge
- PCIE 16_3 Vega 56 running at 16X

Happy New Year all the best

Lolo


IMG_0262.jpg
 
Last edited:
Joined
Nov 17, 2010
Messages
13
Motherboard
Hackintosh
CPU
Core i7 3770K
Graphics
GTX 670
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
NEW YEAR -----> New Build
I decided to choose a Gigabyte mobo and I just finished the setup of a new build:
- Mobo : Gigabyte X299 AORUS Ultra Gaming Pro / new bios PCIe Bifurcation and upcoming Cascade Lake-X 10 000 series
- Processor : i9 9940x (expecting soon delivery of an i9-10980 XE)
- Ram : 64 GB 8x8 GB Corsair Dominator Platinum
- PSU : 1000 W EVGA G3
- Vega 56 x2
- Asus Hyper M2 V2 PCIe Card
- Gigabyte Alpine Ridge Thunderbolt ( Titan Ridge unavailable actually here)
- Custom Alphacool watercooling ( 1 x 240 XT 60 + 1 x 240 XT 45 + 755 VPP waterpump on 5" bay station with 8 Noctua fans )


Everything works perfectly ( thanks @Ellybz for perfect OC EFI Folder)
Even Thunderbolt hut plug :thumbup:
( no exactly a X299X but almost the same...)


PCIe config:
- PCIE 16_1 Vega 56 running at 16X
- PCIE 16_2 Asus Hyper M2 V2 ( PCIe bifurcation 4x4)
- PCIE 4_2 GC Alpine Ridge
- PCIE 16_3 Vega 56 running at 16X

Happy New Year all the best

Lolo


View attachment 442928
Thats great news! Where can i find this EFI OpenCore folder? Would this also work for an ASUS PRIME X299-A motherboard that you know off?
 
Joined
Feb 5, 2011
Messages
125
Motherboard
Gigabyte X299 AORUS Gaming 7
CPU
i9-7900X
Graphics
2x GTX 1070 8GB
Mac
Mac Pro
Classic Mac
Apple, iBook, Performa, Power Mac, PowerBook, SE
Mobile Phone
Android
To start, take a look at this thread dedicated for X299 OC support :

X299 - Open Core support

:thumbup: ;)
NEW YEAR -----> New Build
I decided to choose a Gigabyte mobo and I just finished the setup of a new build:
- Mobo : Gigabyte X299 AORUS Ultra Gaming Pro / new bios PCIe Bifurcation and upcoming Cascade Lake-X 10 000 series
- Processor : i9 9940x (expecting soon delivery of an i9-10980 XE)
- Ram : 64 GB 8x8 GB Corsair Dominator Platinum
- PSU : 1000 W EVGA G3
- Vega 56 x2
- Asus Hyper M2 V2 PCIe Card
- Gigabyte Alpine Ridge Thunderbolt ( Titan Ridge unavailable actually here)
- Custom Alphacool watercooling ( 1 x 240 XT 60 + 1 x 240 XT 45 + 755 VPP waterpump on 5" bay station with 8 Noctua fans )


Everything works perfectly ( thanks @Ellybz for perfect OC EFI Folder)
Even Thunderbolt hut plug :thumbup:
( no exactly a X299X but almost the same...)


PCIe config:
- PCIE 16_1 Vega 56 running at 16X
- PCIE 16_2 Asus Hyper M2 V2 ( PCIe bifurcation 4x4)
- PCIE 4_2 GC Alpine Ridge
- PCIE 16_3 Vega 56 running at 16X

Happy New Year all the best

Lolo
Hi Loloflatsix I was wondering which SSDT are you using for the thunderbolt?

Also I am using Ellbyz OC EFI Folder but I have one issue I do not see the SSDT-X299-XHCI.aml as loaded however the SSDT-X299-XHCI II & III are loaded but not the first one do you See three devices for ASMEDIA in your PCI Devices in System Information
Screen Shot 2020-01-16 at 3.32.39 PM.png
 
Top