Contribute
Register

Gigabyte H61M-USB3-B3 [F5] running 10.10.0 Yosemite Guide

Status
Not open for further replies.
Joined
Jan 20, 2011
Messages
87
Motherboard
Gigabyte Z270X
CPU
i7-7700K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Here's my guide for the Gigabyte H61M-USB3-B3 [F5] running 10.10.0 - just got it working! It's successfully run each os since 10.6 but it's always a bit tricky and it's not a popular board so there's not a lot of info out there - trying to pay it forward.

[See my signature for specs, this is my HackServe machine].

I tried to just update over my existing install but as ever, ran into issues so I just wiped the drive and started again [I have a clone, it's fine].

-Boot with F12 and select unibeast USB [5.0.1, it appears in the boot menu as USB-HDD].
-At chameleon screen boot with flags: -v GraphicsEnabler=YES PCIRootUID=1
-Run through installer
-Restart
-F12 again and boot into new Yosemite install, using flags: -v GraphicsEnabler=YES PCIRootUID=1
-Go through the setup menus - I don't bother with icloud etc at this point, just use a generic computer name like test1, will explain in a bit...
-Run multibeast as follows:

MultiBeast Configuration
-----------------------------------------------------------------
Quick Start > UserDSDT - /Volumes/Vault/Hserve setup/DSDT-GA-H61M-USB3-B3- F5.aml
Drivers > Audio > Realtek ALCxxx > ALC889
Drivers > Disk > IOAHCIBlockStorageInjector
Drivers > Misc > FakeSMC v6.11.1328
Drivers > Network > Atheros > AtherosL1cEthernet 1.2.3
Drivers > System > AppleACPIPlatform Rollback > 10.9.5 AppleACPIPlatform Rollback
Bootloaders > Chimera v4.0.0
Customize > Boot Options > Basic Boot Options
Customize > Boot Options > Generate CPU States
Customize > Boot Options > GraphicsEnabler=Yes
Customize > Boot Options > Hibernate Mode - Desktop
Customize > Boot Options > Kext Dev Mode
Customize > Boot Options > PCI Root ID Fix
Customize > Boot Options > Use KernelCache
Customize > System Definitions > Mac Pro > Mac Pro 3,1
Customize > Themes > tonymacx86 Black

The DSDT adds some of them, but not all. DSDT is from the DSDT database on this site.

-Reboot without unibeast, shouldn't need any boot flags at this point.
-Go to system preferences, Sound, and select Internal Speakers from the Output options. ["Play feedback when volume is changed" - ie. the volume blips - on the Sound Effects Tab is now disabled by default, took some time banging my head against the wall thinking I had no audio before the penny dropped!]
-I like to clone at this point - I have a small drive partition called CleanClone, that I never clone to again after this point - that way I can always get back to a blank working system without having to reinstall everything.
-At this point, Reboot for luck.
-Then I used migration assistant to transfer apps and documents [but not system preferences] from my Mavericks clone drive. I know people have had bad experiences with migration assistant but I've used it the last few OS updates on this machine and never had a problem. I transfer my old user, rather than merging.
-Once that's done, boot into the old user, set up iCloud etc, and then delete the temporary user.
-A bit of niggling stuff about file ownership crops up, but I just Get Info on each drive, and select the ignore ownership checkbox.
-A couple of services had to be reinstalled, VNC, Java, CrushFTP [I use this machine as a server] but otherwise - it's back to business!

Hope someone finds this useful - if nothing else I know I will next time I upgrade!
 
Joined
Sep 18, 2011
Messages
58
Motherboard
Gigabyte GA-H67N-USB3-B3 H67
CPU
i5-2500k
Graphics
nVidia GeForce 210
@marked

I see in your profile it says you are using a EVGA G210 on one of your builds. Did this work with Yosemite and did you have to do anything special to get it to work?

Thanks in Advance,

MacNewGuy
 
Joined
Jan 20, 2011
Messages
87
Motherboard
Gigabyte Z270X
CPU
i7-7700K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
@MacNewGuy I actually bought it because it was the cheapest one on the list of confirmed working cards at the time on this site. When I bought my H61 card I planned to use the built in video outputs but ran into some troubles, so a cheap card was the solution. I have to use
Code:
GraphicsEnabler=YES
when updating but other than that I have no issues, running on VGA output. Have used HDMI as well [not audio] but now I'm just on VGA and it works fine for me.
 
Joined
Sep 18, 2011
Messages
58
Motherboard
Gigabyte GA-H67N-USB3-B3 H67
CPU
i5-2500k
Graphics
nVidia GeForce 210
@marked

Thanks for the info, if I install it in a machine that is already up and running do I need to do anything special to get it to see and use it instead of the built in Intel HD 3000 Graphics it is using right now.

Thanks Again,

MacNewGuy
 
Joined
Jan 20, 2011
Messages
87
Motherboard
Gigabyte Z270X
CPU
i7-7700K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
As I recall [some years ago now!] I don't think I had to do anything, it worked OOB. I'd recommend using VGA for setup, and if you do have trouble there should be a setting in the bios to disable onboard graphics, which should make your board default to the card.
 
Joined
Jan 20, 2011
Messages
87
Motherboard
Gigabyte Z270X
CPU
i7-7700K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
My scan invoice from 2012 (didn't realise it was that long ago!) lists this:

512MB EVGA G210, 1200MHz GDDR3, GPU 1 £20.21

Judging by price and spec, I'd say it's the same one. If not, it's very similar so you should be fine!

Speccing the system is always the worst part! Good luck to you!
 
Joined
May 6, 2012
Messages
7
Motherboard
GAQ-H67MA-USB3-B3
CPU
Core i3
Graphics
HD3000 / 512mb
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Classic Mac
  1. Power Mac
  2. Quadra
Mobile Phone
  1. iOS
This worked for me with only slight change since I was using the HD4000 graphics. Thank you for paying it forward.

Unfortunately, I have had no success building a Mavericks build on the same system. After the OS installs from the USB, all seems right, but on restart it just hangs. This process is not for quitters, that's for sure!
 
Status
Not open for further replies.
Top