Contribute
Register

Gigabyte GA-Z87X-UD7-TH - Install Outline, Test: File Copy Results

Joined
May 11, 2013
Messages
76
Motherboard
GA-Z87X-UD7 TH
CPU
Haswell i7 4770K
Graphics
EVGA GTX 770 4GB SC
Mac
Classic Mac
Mobile Phone
  1. iOS
I am installing OSX 10.9.1 on the new Gigabyte GA-Z87X-UD7-TH motherboard.

I have tried a couple different install paths, but the following one, outlined by genzai, seems to be the least troublesome. I expanded on genzai's steps to produce a full install with DSDT outlined below.

These Threads were helpful:
TonyMacx86's install outline
genzai's install outline
toleda's HDMI Audio reference
loginfailed's MaciASL Guide
MaciASL Sources

Hardware Setup:
BIOS:F2 GA-Z87X-UD7-TH firmware
CPU:i7-4770
SATA
INTEL​
C300-CTFDDAC25 (256G SSD) “admin,osx,shuffle”
HGST HDS724040 (4T DASD) “data” (destination)
HGST HDS724040 (4T DASD) “extra”
HITACHI HDS722 (2TB DASD) “DATAOLD” (source)​
MARVELL​
HL-DT-ST BD-RE ATAPI (BLU-RAY REC)
WDC WD5000AAKS (501G DASD) “WIN7”
VIDEO
ONBOARD: 1 MONITOR
GEFORCE GTX 690: 2 MONITORS​
USB
USB2: port 1: Memory card reader​
USB3: keyboard/mouse​
MEMORY: 4X8GB CORSAIR VENGEANCE DDR3 1600MHZ
POWER: CORSAIR HX850
Using added SATA power connector on motherboard and 8 wire CPU power (4wire cpu power connecter not used)​

Installation Outline:

BIOS setup:
F2 (text mode)
Save & Exit -> Load Optimized Defaults
M.I.T. -> Advanced Memory Settings -> X.M.P. -> Profile 1
BIOS Features -> VT-d -> Disabled​
(you may not see this option with an i7-4770K)​
Peripherals ->
Initial Display Output -> IGFX
Intel Processor Graphics Memory Allocation -> 64M
DVMT Total Memory Size -> MAX
SATA CONFIGURATION
Integrated SATA Controller -> Enabled
SATA Mode Selection -> AHCI
Marvell SATA Controller Configuration
GSATA Controller -> AHCI Mode
XHCI Hand-off -> Enabled
EHCI Hand off -> Enabled
Intel Thunderbolt
Security Level -> Legacy Mode
Wake from Thunderbolt Devices -> Disabled
Set Boot Order
DVDROM Boot drive 1
OS X Boot Drive 2
Windows Boot Drive 3
Save & Exit -> Save Profiles -> Profile 1: <yourname>
Save & Exit -> Save & Exit Setup

Windows Installation:
Skip this step if you are only installing OSX. If you decide to install windows to activate Thunderbolt hardware, you will need to do something like the following. As noted in other threads: in order for Thunderbolt to work, you will need to load the drivers in windows and plug in a Thunderbolt drive.
  • set boot order to 1) DVDROM, 2) Windows Boot, 3) OS X Boot)
  • install windows and drivers
  • plug in Thunderbolt drive
  • verify thunderbolt connected drive
  • restart and set boot drive back to 1) CDROM, 2) OSX Boot, 3) Windows

Prepare your UniBeast USB Thumb drive:
Follow TonyMacx86's instructions for creating Thumb drive, and come back
Add a few utilities to Thumb drive

  • MaciASL (v1.3 (246))
  • MultiBeast-Mavericks Edition (v6.1.0)
  • Chameleon

Install with Unibeast (v3.0.1 used to create USB from Mavericks 10.9.1):

  • press F12 to boot to BIOS Boot menu and select your USB drive
  • At BIOS Boot menu, Select unibeast thumb drive (you may need to reboot if you didn’t have your USB thumb drive inserted before discovery)
  • At tonymac boot menu, choose your USB drive
  • Choose Language and continue
  • Start Disk Utility and create a partition on the OSX boot drive. Quit Disk Utility
  • Install OS X -> Continue
  • -> Agree
  • Select Disk -> Install
  • Wait 23 Minutes or so
  • System will reboot, so be ready to interrupt boot with F12...

First Boot:
  • When system reboots after install, press F12 to boot to BIOS Boot menu and select your USB drive (your OSX drive does not have the boot code yet.)
  • At tonymacx86's boot menu, select your newly installed partition and press SPACE BAR.
    • At the “boot:” prompt, type the following
    • DSDT=NULL
    • And press return
    • Welcome -> select country -> Continue
  • "Select Keyboard" -> Continue
  • "Transfer Information…" -> Don’t Transfer -> Continue
  • "Sign in … Apple ID" -> Don’t sign in -> Continue -> Skip
  • "Terms and Conditions" -> Agree -> Agree
  • "Create Account"
    • Admin
    • admin
    • <pw> <pw>
    • <hint>
    • (decide if you want pw unlock)
    • (decide if you want local time zone)
    • Don’t send Diagnostics to Apple
    • -> Continue
  • "Register Your Mac" -> Don’t Register -> Continue -> Skip

MaciASL:
  • Start up MaciASL, go to MaciASL->Preferences
  • Close, Exit, and Restart MaciASL
  • Add Patches:
    • Click Patch icon at Top
    • Add Motherboard Patch:
      • Select PJALM Gigabyte->Z87X-UD7-TH
      • <wait for load and analysis>
      • Click Apply
      • <wait for both sections to clear>
    • Add Toleda HD4600 DSDT (v3, ID1) Patch
      • Select Toleda HDMI->Desktop-HD5K/AMD/Nvidia-A1
      • <wait for load an analysis>
      • Click Apply
      • <wait for both sections to clear>
      • Click Close
    • Add PJALM Generic Graphics Patch:
      • Select PJALM Graphics->Generic Discrete Graphics (AMD/nVidia)
      • <wait for load an analysis>
      • Click Apply
      • <wait for both sections to clear>
      • Click Close
    • Click Compile icon at top
      • A compiler summary appears, I got:
        • 0 Errors
        • 0 Warnings
        • 11 Remarks
        • 146 Optimizations
  • We will save both source and compiled:
    • File->Save As…
      • Location: Desktop
      • Name: DSDT
      • File Format: Disassembled ASL File
      • Don’t hide extension
    • File->Save As…
      • Location: Desktop
      • Name: DSDT
      • File Format: ACPI Machine Language Binary
      • Don’t Hide extension

multibeast, Mavericks Edition:

  • Quick Start:
    • UserDSDT
      • Open ~/Desktop/DSDT.aml
  • Drivers
    • Audio: Realtek ALCxxx->With DSDT->ALC898
    • Disk
      • 3rd Party SATA
      • TRIM Enabler
        • 10.9.x TRIM Patch
    • Misc
      • FakeSMC v5.3.820
      • FakeSMC v5.3.820 Plugins
      • FakeSMC v5.3.820 HWMonitor Application
    • Network
      • Intel hnak’s AppleIntelE1000e v2.4.14
  • Bootloaders
    • Chimera v2.2.1
  • Customize
    • Boot Options
      • Basic Boot Options
      • Use KernelCache
    • System Definitions
      • iMac->iMac 14,2
    • Themes
      • Tonymacx86 Black
  • Build
    • Review Current Configuration:
      • <multibeast-current-configuration.png>
  • Save to desktop: pixelstand.mb
  • Install
    • Click Install on the lower right
      • Agree
      • Type admin password->Install Helper
      • Multibeast will copy your DSDT.aml to /Extra, setup boot, and setup boot parameters.
      • Observe Install Succeeded

Chameleon Wizard 4.3.2

  • SMBios
    • Edit
    • Premade SMBioses->Select
      • iMac(14,2)
    • Week of Manufacture: Keep hitting Random until you get a week > 40
    • Unique Number: Random
    • Click Save
    • Type Admin password
  • Modules
    • Select FileNVRAM.dylib
    • <Keylayout.dylib already selected>
    • Verify target partition
    • Click Apply

Disk Utility:

  • Select your boot partition
  • First Aid->Repair Disk Permissions

Finish Up:

  • Quit all apps
  • Eject and remove USB Drive
  • Reboot
  • Hit down arrow a couple times at tonymacx86’s boot screen and..
  • select "boot ignore caches" (only first boot needed—you can use the caches for subsequent boots unless you change hardware settings.)

Done!
Thanks for the tutorial, I have followed your instructions to the "T" multiple times, after MaciASL install I get the same amount of warnings and no errors. I been trying to get audio through my EVGA gtx 770 4GB with absolutely no luck. I try to read through toleda's tutorial and I am just confused. His new guide is split into sections, I'm sure I follow the right one, v2 mav DSDT/ssdt hdmi audio #1 which states it's for HD4600/9series/8series (I gather the 8 and 9 series are in regards to the motherboard itself)... I can get audio HDMI to show up on the on board video, but not my video card. So I scroll down to discreet graphics guide v2 the 5the section and I select the #2 [Guide] Nvidia-HDMI audio v2.pdf.zip.... I think this is the one, but I have a serious problem he way the tutorial is set up, it's like a masters level. Any how, I started playing around with MaciASL and I did another compile after my system has been running for a while and I now get 2 errors... Compiler summery tells me line 62 code 6074 "Name already exists in scope (_SB_.PC10.PEG1)" and line 63 is he same but PEG2. I have tried to delete these lines, no matter what I do they reappear every time. I have started a fresh install (5th time now) and have tinkered, redone the extra folder, redo all the multibeast and MaciASL selections.... Here was a selection under toleda's that is AML-Clean_compile-8series that I read was supposed to solve my issue... Can somebody please help? I do support and donate, but every time I ask the question I get forwarded to toleda's tutorial and it is just way over my head. I can't message anyone, not enough posts. This is such a weird problem, especially to have these 2 errors reappear no matter what I do. I can delete every DSDT and it will still put those lines 62 and 63 as an error... I'm sure that has to do with my cards audio. Thanks
 
Joined
Jun 18, 2014
Messages
27
Motherboard
Gigabyte Z390 Designare
CPU
i9-9990K
Graphics
Vega 64
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Hello, guys.

I have this motherboard too. First of all, freezes doesn't are related to CPU, at least by my experience. I suffer them with two different processors (K and not K), and the only solution was installing Clover over my Unibeast / Multibeast Yosemite. Freezes gone. :headbang:

Only an odd problem. I have a Thunderbolt Lacie Little Big Disk, that was operational with previous install (without Clover). But now, it is shown in "About my Mac" without (aparently) problem, but Disk Manager nor Finder could access to it... :crazy: ¿Any clue?

Thanks
 
Joined
Nov 21, 2015
Messages
36
Motherboard
Gigabyte z87x-ud7-th
CPU
Intel core i7 4790k
Graphics
GeForce gt 740 sc
Mac
Classic Mac
Mobile Phone
hi i have the z87x ud7 th motherboard. i am following these steps you have listed but i have compile error syntax error parseop_argo. when i close maciasl and reopen it and click the patch icon there is nothing there?


thanks
 
Joined
Feb 26, 2013
Messages
41
Motherboard
GA-Z87X-UD7 TH
CPU
i7-4790K
Graphics
GTX 980
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. iOS
Thanks for the guide, trying it now.
 
Joined
Feb 26, 2013
Messages
41
Motherboard
GA-Z87X-UD7 TH
CPU
i7-4790K
Graphics
GTX 980
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. iOS
Thanks so much for this. Have how is your hardware running now? I have this board and want to get it going with an EVGA GTX 980. Cheers,
 
Joined
Feb 26, 2013
Messages
41
Motherboard
GA-Z87X-UD7 TH
CPU
i7-4790K
Graphics
GTX 980
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. iOS
This works well. Has anyone updated this to 10.11? Many thanks. The Memorial Day project here.
 
Top