Contribute
Register

Gigabyte GA-Z170X-Designare Thunderbolt Support Focusrite 4pre (help)

Joined
Dec 23, 2016
Messages
10
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Core i7-6700K
Graphics
(onboard)
I'm on F20. Not sure what the difference is. Be sure to update the thunderbolt drivers (from Gigabyte) using your windows OS. Cheers!
 

BoomR

Moderator
Joined
Dec 18, 2011
Messages
1,227
Motherboard
Gigabyte AORUS Z370 Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Apple, Performa, Power Mac, Quadra
Mobile Phone
Android
I have the same motherboard and I can't find the thunderbolt firmware update utility on gigabytes site. Can you assist me in finding it?
Try here:
http://www.gigabyte.com/Support/Utility#de

Note that there are several pages of utilities posted here. The updates on the first few pages are for the newest mobos (200-series). You need to page ahead to page 6/26 (as of the time of this writing), then scroll down mid-way. Pay close attention, as there are several Thunderbolt FW Update Tool options for the various motherboard models. Please look for the one specific to your motherboard (I think you said it was the same as the OP). You need Version B16.0718.1 for Z170X Designare.
 
Joined
Apr 16, 2016
Messages
68
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Core i7-6700K
Graphics
EVGA GTX 1080 Founders Edition
Mac
Mac Pro
I am willing to buy this same motherboard for video editing. Am I correct in saying that the card has 1 Thunderbolt 2 and 2 Type-C USB connetors that can transmit the Thunderbolt 3 protocol ?
I need to plug a Lacie RAID thunderbolt 2 and an apple display monitor to it and I was wondering if this was not too much to ask. Thanks for your input.
Alexandre
 
Joined
Feb 9, 2013
Messages
4
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel Core i7-6700K
Graphics
Gigabyte GTX980 TI
Mac
MacBook Pro, Mac Pro
Mobile Phone
Android
I know it might be a bit of an off-topic question in this thread but I do have the exact same motherboard but can't get to onboard audio to work properly. Did you guys get it to output correct stereo sound? I installed the realtek1150 and 100 series kexts trough multibeast and do get some sounds but the "main output" (think green plug) only outputs crackling distorted sound while optic spdif and center and rear audio DO work.

If anyone could help me out or point me in the right direction to fix this problem it would be awesome and much appreciated!
 
Joined
Sep 21, 2013
Messages
554
Motherboard
Gigabyte Aorus Z370 GA-7
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook, MacBook Pro, Mac mini
Classic Mac
Classic, iBook, Power Mac, PowerBook, Quadra, SE/30
Mobile Phone
Android, iOS
I just installed Sierra and have spent the last two days trying to get a resolution higher than 1024x768 and my UAD Apollo to work for audio over TB3. So far, no dice. I have, however, got Ethernet working. My device manager shows two devices where yours shows only one.

View attachment 248643

IIRC, I installed the second one first and got nothing. Try the AppleIGB.kext from MultiBeast.

For those with working Thunderbolt audio, did you have to install any kext files or anything or did it just work? I've updated the BIOS to F22 and the Thunderbolt software. It works on Windows 10, but nothing in MacOS Sierra.
Same boat. Thunderbolt drivers do not load. The same devices are recognized my build in Windows 10. I think there must be a magical kext out there for Thunderbolt. So far, it's a bust. I should have either kept my 6,2 and lived with the crashes, or I'm selling the Apollo 8. Not worth the hassle.
 
Joined
Jul 19, 2012
Messages
5
Motherboard
Z170X Designare
CPU
i7-6700K
Graphics
GT 710
Mobile Phone
iOS
I haven’t had any luck with my orion studio sometimes Sierra recognizes it. But cannot get audio in or out.
 
Top