Contribute
Register

Gigabyte GA-Z170X-Designare Thunderbolt Support Focusrite 4pre (help)

Joined
Dec 6, 2011
Messages
30
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
Nvidia Geforce GTX 780
I generally disable sleep once I get set up as I'm either using the computer or it is turned off. I believe it was working though out of the box before I changed my settings. I haven't throughly tested that though.

Ever since the 12.2 update I haven't had it reboot when I shutdown. It would do that randomly every so ofter but has not done that since the update. Also the mouse wheel works properly now since 12.2.

I have yet to experience USB issues and I didn't use any special kexts or fixes.

The only thing I'm still curious is how to truly disable speedstep or whatever it is called now to just run at full capacity all the time as OS X ignores the BIOS settings and the SSDT doesn't want to play ball either. I did it on my 2600k before but creating a SSDT that had just one frequency, that being my over clock speed. Either way, it is working fine and I'm recording tunes over Thunderbolt.
 
Joined
Nov 10, 2016
Messages
16
Motherboard
Gigabyte Z170X-Designare ATX
CPU
Intel Core i7-6700K
Graphics
Palit KalmX Geforce GTX 1050Ti 4GB GDDR5
Mac
MacBook Pro
Mobile Phone
iOS
Cool thread. I have the same motherboard and processor and am running Universal Audio thunderbolt gear. I'm having issues with the UA stuff on Windows while it works fine on my Macbook Pro so I figured that I would put MacOS on the PC. Sounds like a challenge, but I'm glad to see that you've got it working on the same mobo. No doubt I'll be back soon for some help!
 
Joined
Dec 6, 2011
Messages
30
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
Nvidia Geforce GTX 780
Thanks @monkeymanx any chance could have a look at your config..

Still suffering shutdown restart.
Cancel that. I still get a random restart when I want to shut down. It isn't very often though. In that case I don't believe my configuration will be of much help on that front. At this point though I would say everything is working in the good enough realm of things.
 
Joined
Dec 6, 2011
Messages
30
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
Nvidia Geforce GTX 780
One thing I really can't figure out is no matter what I do, throttling is always going on with this build. If any of you other gents with this board and CPU and figure out how to stop CPU throttling I would greatly appreciate it as I'm at my wits end with this.
 
Joined
Oct 30, 2010
Messages
46
Motherboard
Asus TUF-Z270-Mark 1
CPU
Core i7-7700K @ 5GHz
Graphics
Asus 980 TI
Mac
MacBook Pro, Mac Pro
Classic Mac
Performa
Mobile Phone
iOS
One thing I really can't figure out is no matter what I do, throttling is always going on with this build. If any of you other gents with this board and CPU and figure out how to stop CPU throttling I would greatly appreciate it as I'm at my wits end with this.
Have you tried to run it with NullCPUPowerManagement? You can find it in MultiBeast>Misc>NullCPUPowerManagement.
 
Joined
Dec 6, 2011
Messages
30
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
Nvidia Geforce GTX 780
Have you tried to run it with NullCPUPowerManagement? You can find it in MultiBeast>Misc>NullCPUPowerManagement.
Yes, and it seems odd but that didn't actually make a difference. It still throttled which doesn't make sense as that null kext is supposed to just keep it at stock speed I believe.
 
Joined
Oct 30, 2010
Messages
46
Motherboard
Asus TUF-Z270-Mark 1
CPU
Core i7-7700K @ 5GHz
Graphics
Asus 980 TI
Mac
MacBook Pro, Mac Pro
Classic Mac
Performa
Mobile Phone
iOS
Yes, and it seems odd but that didn't actually make a difference. It still throttled which doesn't make sense as that null kext is supposed to just keep it at stock speed I believe.
Try turn off RSR under MIT>Advanced Frequency Setting>Advanced CPU Core Setting.
 
Joined
Dec 6, 2011
Messages
30
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
Nvidia Geforce GTX 780
I will give that a try.

Just an update. I flashed from F20 to F21 bios and now OS X will recognize the Clarett 4pre with the Thunderbolt Boot Support option on. I also obtained a beta driver for the iMac 17,1 from Focusrite, I'm not sure if that did anything to effect it.

And, the noise I am getting from the USB mouse movement is specific to the mouse. I plugged in a old Microsoft USB mouse and no noise. I'm going to try getting a powered USB hub to see if it helps so the power will be coming from something other than the power supply itself as my current mouse is comfy.
 
Joined
Dec 23, 2016
Messages
10
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Core i7-6700K
Graphics
(onboard)
Hi guys. I just completed a build for live audio and am still working out the bugs. So glad this site is here! I have a Focusrite Saffire Pro 40. I have the Gigabyte Designare mobo on F20 BIOS; I do not have access to Windows.

@monkeymanx last post made me wonder: if I simply update to F21 BIOS will the Thunderbolt work? Or do I still need to install the Thunderbolt update from Gigabyte using a Windows based machine? If so, do you think I could run that *.exe file on MacOS using VirtualMachine?

Thanks in advance for the help.
 
Top