Contribute
Register

GIGABYTE GA-P85-D3 & Realtek network card

Joined
Feb 7, 2014
Messages
31
Motherboard
Gigabyte Designare Z390
CPU
i5 9600K
Graphics
2x RX580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hi All,
First time poster here, I have had the hackintosh up and running for a few months now and the only problem I seem to be having is the network port on the motherboard (GIGABYTE GA-P85-D3 LGA 1150 Intel B85).
The network card works on a fresh boot just fine, but when the ethernet connection gets unplugged then plugged in again, the network manager shows that the connection is back but I don't get a dhcp address. The only way to get the computer to get the ip address is to reboot the whole box.

I suspect that this is a driver issue. I have downloaded and tried the newest multi beast and tried both realtek drivers to no avail. Any recommendations?

Thanks in Advance,
Matt
 
Joined
Jul 6, 2014
Messages
1
Mac
Classic Mac
Mobile Phone
Hey bud; I'm looking at buying the same motherboard did you fix the problem?

Thanks!
 
Joined
Feb 7, 2014
Messages
31
Motherboard
Gigabyte Designare Z390
CPU
i5 9600K
Graphics
2x RX580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
yes I finally did. But I had to do it manually. I first had to uninstall every other driver that I had installed for that ethernet port. All the ones from multi - beast and all the drivers from RealTek that I found on the web. I found some instructions on how to do that somewhere on the web... sorry don't remember the link. Then I downloaded and manually installed this driver

http://lnx2mac.blogspot.ca/p/realtekrtl81xx-osx-driver.html

Since then it has worked perfectly.

Hope this helps,
Matt
 
Joined
Mar 26, 2010
Messages
7
Motherboard
asrock h110 pro btc+
CPU
i3 > Need Model > See Rules!
Graphics
Intel version # > See Rules!
Mac
  1. Mac Pro
Hi i have the same board (rev 2.0) and im strugglin to install any osx on it
Can you please tell what osx and HOW you installed it
Best wishes
 
Joined
Feb 7, 2014
Messages
31
Motherboard
Gigabyte Designare Z390
CPU
i5 9600K
Graphics
2x RX580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
I stopped using that board a long time ago. It's super old. I spent a couple of $$$ and got the Designare Z390 and using the files on this thread got opencore running no problem.

 
Joined
Mar 25, 2010
Messages
240
Motherboard
HP 400 G1
CPU
i5-4670k
Graphics
Kepler GT730
Mac
  1. Mac mini
Mobile Phone
  1. Android
I stopped using that board a long time ago. It's super old. I spent a couple of $$$ and got the Designare Z390 and using the files on this thread got opencore running no problem.

Sold it? What country are u in??
 
Joined
Feb 7, 2014
Messages
31
Motherboard
Gigabyte Designare Z390
CPU
i5 9600K
Graphics
2x RX580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
I still have it.
USA
 
Top