Contribute
Register

Gigabyte GA-EP45-UD3R 1.0/F12: First Hackintosh, en route to El Capitan

Status
Not open for further replies.
Joined
Dec 28, 2015
Messages
53
Motherboard
Gigabyte GA-EP45-UD3R 1.0/F12
CPU
Core 2 Quad Q9650 (4x3.00 GHz)
Graphics
EVGA GeForce GTX 750 Ti "FTW" (2 GB)
Mac
  1. MacBook
Mobile Phone
  1. iOS
Prologue: I need something to run the latest iTunes, for iOS 9.x support, for the latest iPhones (5s, 6, 6s), because that's what my new Honda demands. To run the latest iTunes, need at least ML, ideally El Capitan. To get El Capitan via a legit route, need something that can also run Lion, so I can get it via App Store. Unfortunately for my old MacBook, Lion is the end of the line...

...so I got this old Windoze-PC-turned-Linux box and made it into a Hackintosh. :mrgreen: Lion seems to run OK; I've updated to 10.7.5 without any major problems, though audio is still broken (and, for some reason, it demands a USB mouse even with PS/2 drivers installed and a PS/2 keyboard). My thanks to the whole CustoMac gang at tonymacx86.com! You rock! :headbang:

For the record, I used UniBeast 5.2.0 with the Lion app for the install, and MultiBeast 4.7.0 afterward. I've been fiddling with MultiBeast, the Realtek ALC889A kext, and the DSDT without much success.

Right now this beastie's got a Core 2 Duo E7300, GeForce 8400 GS graphics (256 MB), and 4 GB DDR2-800 RAM. With a trip to the App Store, I've also got El Capitan in hand, waiting. To run it, I'm looking to bump the CPU to a Core 2 Quad Q9650 (or Extreme QX9650) and RAM to 8 GB, probably also DDR2-800. (DDR2-1066, while possible, is outrageously expensive, and anything faster is probably vaporware. Ditto for compatible 4 GB sticks at any DDR2 speed--beware the recent market dump of "AMD memory"! That's probably why this box ended up at the local Free Geek.)

As for graphics, I'm conflicted. One idea is to use a graphics card appropriate for this vintage (q.v., a 2010 iMac), which would indicate a Radeon HD 4850 or some such. The other states that, since El Capitan relies so heavily on the GPGPU (or multiple GPGPUs!), I should simply get the most graphics this box will handle; since it has a 16x PCIe slot, that means that (with enough power) I should be able to use almost anything that doesn't require multiple slots and/or SLI--or that will break my budget.

Recommendations?
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,245
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
The 8400GS will do fine since you are not playing games or anything else demanding high end graphics. A 9500GT/GT120 from an old Mac Pro if you could find one would work as well. I have seen GT120s at Amazon and ebay for under US$100 for used models.
 
Joined
Dec 28, 2015
Messages
53
Motherboard
Gigabyte GA-EP45-UD3R 1.0/F12
CPU
Core 2 Quad Q9650 (4x3.00 GHz)
Graphics
EVGA GeForce GTX 750 Ti "FTW" (2 GB)
Mac
  1. MacBook
Mobile Phone
  1. iOS
Grabbed the CPU, RAM and an EVGA GT 730 (2 GB) from eBay, for about $140 for the lot.

Don't know what you mean by "no gaming". Granted, I won't be playing Crysis or Gran Turismo 5, anything like that...that's what consoles are for :D But I do have Angry Birds!

Anyway, thanks for the advice! :headbang:
 
Joined
Dec 28, 2015
Messages
53
Motherboard
Gigabyte GA-EP45-UD3R 1.0/F12
CPU
Core 2 Quad Q9650 (4x3.00 GHz)
Graphics
EVGA GeForce GTX 750 Ti "FTW" (2 GB)
Mac
  1. MacBook
Mobile Phone
  1. iOS
...and now I've run into my first snag.

I've got the 8 GB RAM. I've got the quad-core CPU (a Core 2 Quad Q9650, which it's calling an Xeon). So far, so good. Then I popped in my new GT 730 (it had an 8400 GS) and...no boot. Stuck at the gray-on-white Apple logo. Entering "GraphicsEnabler=NO" when prompted at the Chimera screen has no effect.

Tried using my El Capitan installer, which I'd tested before (though I haven't installed it yet). I'm using legacy boot mode with Clover, since (I'm assuming) this board uses a traditional BIOS, not EFI. Similar result: after the white-on-black Apple logo, the screen goes black and nothing else happens. Do I need nVidia graphics injection for the GT 730?

Put the 8400 GS back in, and all is well with Lion. Haven't tried the EC installer again.

EDIT: Downloaded nVidia alternate drivers. Will try EC again with the "nv_disable=1" flag, and install drivers once EC is running. Apparently this card isn't supported in Lion at all...will continue this in an EC thread.

To be continued: http://www.tonymacx86.com/graphics/...ud3r-el-capitan-gt-730-no-go.html#post1181913
 
Last edited:
Status
Not open for further replies.
Top