Contribute
Register

Gigabyte B550 Vision D (Thunderbolt 3) + AMD Ryzen 7 3700X + AMD RX 5600 XT

Joined
Aug 13, 2010
Messages
108
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700
Mobile Phone
  1. Android
Basak I think thats why @CaseySJ wanted everyone to replace the stock wifi with the Broadcom ones. The intel was spotty. I actually don't need wfi. For the hard drive, I never run tb harddrives. Always sata and this system i have used a nvme gen 4 for windows and a nvme 3 for hackintosh. The hackintosh tb is only for audio.


Side rant! To be honest, I hope thunderbolt just dies a hard death and all audio just goes ethernet. TB is a headache and intel money grab on it is sad. AVB practically is barley used in windows. I think Motu makes a a avb windows unit and i dont see avid making carbon support for windows until windows gets its act together with avb. Windows 11 will be the same jive push for win 10 customers. Right now I see AVB as push to get away from intel (apples new cpu chip) Audio should be easy, yet it still complicated and the fact the buffer sizes still are stuck at 32 ms shows the only thing the audio industry is good at is ...mic modeling and preamps and better pre amp not latency which is #1 in my book. How many emulations of neve and api do we have today???...too many
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,472
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Okay, I am having some weird minor issues, that seems to be beyond my understanding.

Mainly they are related to Thunderbolt, Ethernet and the BT/Wifi card, maybe it is related to some PCI weirdness?

- Thunderbolt, isn't working. The two older TB2 drives I have connected with the Apple adapter, showed up once, when I went to open a drive i the Finder, I saw the contents of the drive and then system crashed. They haven't appeared since. In windows the two drives do appear. I did install the Win10 drivers for TB before booting into Big Sur 10.4, as I remember you had to do in the Clover days.

I've tried cold booting, cold booting into windows first and rebooting into mac, and on and on. Security is set to NONE and the other settings are at 32 and 128.

I have added a screenshot from hackintool showing the Lacie D2 TB2 drive (marked as ASMedia), and what paths it has. See below.

I have no idea what is going on, but would really appreciate some help.

- Ethernet is simple: the i225-v doesn't work, if I use it the system hangs, so I have disabled it in the BIOS.
Please do the following:
  • Enable i225-V in BIOS, but do not connect Ethernet cable
  • Connect LaCie TB2 to either of the two Thunderbolt ports
  • Then run IORegistryExplorer and export the IOReg file with File --> Save As..., and post that file

- BT is the old trusty wdxxfu studio adapter (94360CS2 with 802.11AC and BT4), it is working more or less, but I've experienced it suddenly not working, although it is mainly in Win10, where it has stopped responding, it has happened in Big Sur. Seems to be stable now.
The wdxxfu is a PCIe add-in-card? Have you considered the BCM94360NG M.2 module that directly replaces the on-board Intel AX200 module?

Note: I did download the EFI from HackinDROM, but inside the AML is still called SSDT-TB-HackinDROM-B550-VISION-D.aml, and not VISION-DP or something like it (and has the same creation date as the one in the Vision D refi).
It also seems like that the ACPI folder in B550 Vision D and B550 Vision D-P are of the same size, but maybe that is irrelevant? :)
I wouldn't worry about this. Not all SSDTs in the ACPI folder are actually enabled in the config.plist.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,472
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ

I just spent a good 3 hours trying to figure why my tb doesn't work on the vision dp board. It did work once cause i sent u the photos. Anways i am on f12g bios as its the most stable. The hackindrom oc creater doesnt work for f11, it only works for f12g and yes everything works except thunderbolt. I went to f2 and none of my efi booted that was a pure disaster.

So i dont know what to do now and im in the same boat as basak. I made a efi with out the ssdt tb and also tried to disable the hot plug in open core configurator. Neither fixed it. It works fine in windows, cold booted and warm boot into mac os with no security and user security.

So im at a loss for the moment

ill be happy to give u any data
With any Thunderbolt device connected, please run IORegistryExplorer and post the IOReg file (File --> Save As...).
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,472
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I downgraded back to F11, even though all of my internal drives now in F11 are represented as external (in F12G they displayed correctly), because my Wifi/BT-card suddenly didn’t work under F12G. @mrfatcatt have you experienced any of this (internal drives represented as external in F1 1and BRC wifi/BT not working in F12?)

But it still strikes me as weird, that my TB2 drives did show up, but then the system locked up, and since then they were gone. My Lacie drive is clearly detected but not activated, almost like it needs a little push :)
When you say "all of my internal drives", are you referring to NVMe SSDs in the M.2 slots? Or SATA SSDs or spinning hard drives?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,472
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@mrfatcatt,

On your B550 Vision D-P, does macOS crash when you connect a live Ethernet cable to the i225-V Ethernet port? Please note that one port is Realtek and the other is Intel. Better yet, do both Ethernet ports connect and work when a cable is attached?
 
Joined
Jul 13, 2011
Messages
83
Motherboard
Gigabyte Z170MX Gaming 5
CPU
i7 6700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Please do the following:
  • Enable i225-V in BIOS, but do not connect Ethernet cable
  • Connect LaCie TB2 to either of the two Thunderbolt ports
  • Then run IORegistryExplorer and export the IOReg file with File --> Save As..., and post that file


The wdxxfu is a PCIe add-in-card? Have you considered the BCM94360NG M.2 module that directly replaces the on-board Intel AX200 module?
Attached.

Yes it is a PCIe add-in card, as I recall it was special, because it was an original Apple 943602CS card, adapted to be used in PCI-E 4x or 8x slots, back in the day and not x1 exclusively I do however have a 94360NG M.2 module on order, so that should sort it out. :)

I wouldn't worry about this. Not all SSDTs in the ACPI folder are actually enabled in the config.plist.
Check.

When you say "all of my internal drives", are you referring to NVMe SSDs in the M.2 slots? Or SATA SSDs or spinning hard drives?
I am referring to ALL other drives except my main NVMe 1TB WD 750. My two SSDs and my to spinning HDDs appear as external drives (see screenshot). Again this was fixed in F12G but then my broadcom card

And thank you @CaseySJ
 

Attachments

  • Screenshot 2021-06-23 at 19.13.05.png
    Screenshot 2021-06-23 at 19.13.05.png
    18.4 KB · Views: 8
  • Basak B550 Vision D-P.ioreg
    6 MB · Views: 5
  • TB2XsElciGO.eBjSZFEXXcy9VXa_!!41497093.jpg
    TB2XsElciGO.eBjSZFEXXcy9VXa_!!41497093.jpg
    76.3 KB · Views: 9
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,472
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Attached.

Yes it is a PCIe add-in card, as I recall it was special, because it was an original Apple 943602CS card, adapted to be used in PCI-E 4x or 8x slots, back in the day and not x1 exclusively I do however have a 94360NG M.2 module on order, so that should sort it out. :)


Check.


I am referring to ALL other drives except my main NVMe 1TB WD 750. My two SSDs and my to spinning HDDs appear as external drives (see screenshot). Again this was fixed in F12G but then my broadcom card

And thank you @CaseySJ
The IOReg file indicates that everything under GPP1 is mis-named, which includes Thunderbolt, WiFi, both Ethernet ports, and USB ports. This does not mean they won't work, but there can be problems.

This is a bit worse than expected.

Please provide the following:
  1. MaciASL --> File --> New from ACPI --> DSDT
    Screen Shot 2021-06-23 at 10.41.35 AM.png
  2. Hackintool --> PCie --> Export
    Screen Shot 2021-06-23 at 10.40.15 AM.png
  3. Your zipped EFI folder with serial numbers removed from config.plist --> PlatformInfo --> DataHub.
 
Joined
Jul 13, 2011
Messages
83
Motherboard
Gigabyte Z170MX Gaming 5
CPU
i7 6700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Please provide the following:
  1. MaciASL --> File --> New from ACPI --> DSDT
  2. Hackintool --> PCie --> Export
  3. Your zipped EFI folder with serial numbers removed from config.plist --> PlatformInfo --> DataHub.

I can provide 2 and 3, however MaciASL gives the following error:

Screenshot 2021-06-23 at 19.48.30.png


I'm trying to find out, how to fix that in the mean time here's pcidevices and my EFI
 

Attachments

  • basak pcidevices.zip
    9.5 KB · Views: 4
  • basak EFI.zip
    6.6 MB · Views: 5

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,472
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I can provide 2 and 3, however MaciASL gives the following error:

View attachment 522642

I'm trying to find out, how to fix that in the mean time here's pcidevices and my EFI
Please try MaciASL 1.6.1 from here. Just launching the app should open the DSDT by default.
 
Joined
Jul 13, 2011
Messages
83
Motherboard
Gigabyte Z170MX Gaming 5
CPU
i7 6700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS

Attachments

  • Basak System DSDT.aml
    23.1 KB · Views: 4
Top