Contribute
Register

Gigabyte B550 Vision D (Thunderbolt 3) + AMD Ryzen 7 3700X + AMD RX 5600 XT

Joined
Mar 3, 2013
Messages
138
Motherboard
Gigabyte B550 Vision D
CPU
5600X
Graphics
RX580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@CaseySJ, hi there! I just updated to 0.7.5, and everything works. I'm trying now to enable RBAR from BIOS and with -1 on the resize apple quirk in boot and -1 on the resize quirk on UEFI I can boot without problem. Here a screen of the resize bar from Windows. Unfortunately, I can't boot to Big Sur. Any idea? I don't how to set this 2 quirks. I know only they the Resize Apple GPU on boot is just for the macOS environment, and it can be set to 10 (1Gb) and the quirk in UEFI is for the other system like Windows, and it's better to leave to -1 so that it can't do nothing and leave the standard parameters for windows.
I read that Resize Apple GPU Bar is only for new 6000 series of AMD. So I don't know if I can start hackintosh with RBAR enabled on AMD RX580 4GB.

eheheheh.png



Update: just a little update. I tried with ResizeAppleGpuBars to 10, and it works! I'm on big sur 11.6.1 with RBAR enabled in BIOS with an AMD RX580 Nitro 4GB, and it works perfectly on Windows and macOS from OpenCore 0.7.5 ;)

Schermata 2021-11-03 alle 00.28.24.png


Schermata 2021-11-03 alle 00.31.28.png
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,915
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Update: just a little update. I tried with ResizeAppleGpuBars to 10, and it works! I'm on big sur 11.6.1 with RBAR enabled in BIOS with an AMD RX580 Nitro 4GB, and it works perfectly on Windows and macOS from OpenCore 0.7.5 ;)
I’m curious to know if setting ResizeAppleGpuBars to 0 will also work with Big Sur.
 
Joined
Mar 3, 2013
Messages
138
Motherboard
Gigabyte B550 Vision D
CPU
5600X
Graphics
RX580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I’m curious to know if setting ResizeAppleGpuBars to 0 will also work with Big Sur.
I will try 0 tomorrow!
Set it to 10 breaks my wake after sleep. Gpu seems to have some issue with 9 and 10 value.
 
Joined
Nov 3, 2021
Messages
9
Motherboard
Gigabyte Vision D B550
CPU
AMD Ryzen 3950x
Graphics
RX5700XT
First of all I would like to thank CaseySJ for the effort he puts in building various configurations, detailing the process and support he provides in these forums.

I am frequent reader at tonymacx86 but I just opened an account to post this message and provide some info and help based on the experience that I had with my build, Monterey and various hardware configuration tests.

I am using the GB Vision D B550 with a Ryzen 3950x, and a 5700XT. I am currently on F10 bios version but I have tested all them with a lot of pain.

I will address some of the issues mentioned in this thread, but also mentioned in the Z390 and Z490 threads in case they help someone.

1. Samsung 970 EVO and 970 EVO PLUS slow boot times and TRIM.
I have two 512GB 970 EVO and one 512GB 970 EVO PLUS, all of them experience the slow boot issue due to TRIM activity during the MacOS boot process. This issue appears only if the drives are formated as APFS, and it occurs in both Big Sur and Monterey. I found out that if you Overprovision the drives by 10% (Default value in Samsung Magician for Windows) the issue disapears. Because you cannot overeprovision an APFS drive in Windows, you have to do it with Disk Utility in macOS, with the following steps:​
1.1 Add a new partition to your disk (not a new APFS volume) and format it as FAT32. If you decide to erase the whole disk then add the OP partition as the last one.​
1.2 Note the location of the new partition in the format of diskXsX eg disk1s3​
1.3 Close the Disk Utility app and open Terminal and execute the following without the quotes and by replacing the diskname with yours: "diskutil eraseVolume free free diskXsX"​
1.4 You are done restart macOS and check the boot performance. If you have more than one Samsung drives the same technique needs to be applied to achieve normal boot performance.​
As a note a tested the Trim performance on an empty, half-empty and almost full drive and the performance was the same.​

2. Network issues with I211T in Monterey.
It is true that the Smalltree driver is not working in Monterey.​
The AppleIGB driver from Shaneee (https://github.com/Shaneee/AppleIGB) shared here as AppleI2xx.kext works but has at least two issues that affect normal usage.​
2.1 The network is disconnecting after sleep or after heavy RAM or CPU usage. In order to resolve this until another solution/kext is provided do the following:​
2.1.1 Download 'sleepwatcher" from https://www.bernhard-baehr.de or install through Brew.​
2.1.2 Then follow the directions and install the script not as a user launchagent but as a system launchdeamon. (I found out that sometimes the user launchagent hangs if not run as sudo)​
2.1.3 Then edit your rc.wakeup script and add the following lines for each I211T you have on your motherboard (I have two en0 and en1)​
networksetup -setMTU en0 9000
networksetup -setMTU en0 1500
networksetup -setMTU en1 9000
networksetup -setMTU en1 1500
These commands will set a new MTU value for each controller (9000) and then reset it back to 1500, if you are using Jumbo frames (MTU 9000) the reverse the order, or if you need any other default value then use that instead of 1500. The trick with the MTU change through Network Preferences was discovered by another user (I apologize, I do not remember which one and where.).​
2.2 The AppleIGB driver does not work with VirtualBox and probably any other Virtualization application in Bridge mode. You either have to use it in NAT mode or Bridge the VM with WiFi or another controller.​

3. USB Gigabit Network Devices
It is suggested here and on other forums, to buy a USB Gigabit adapter to "replace" the I211T. As a word of caution avoid Linksys USB3GIG V1 adapter as it has major issues with Monterey.​
3.1 It disconnects randomly and especially after sleep and requires to connect it in another USB port or even restart in order to reconnect. This is due to the RTL8153 chip used in this model.​
3.2 In fact I have found out that all RTL8153 and maybe even other RealTek adapters have this issue with Big Sur and especially Monterey. The issue was resolved temporalely in Big Sur from Apple but it has reappeared.​
3.3 I havent tested my self but reports indicate that ASIX based usb to Ethernet adaptors are compatible, as the ASIX company has provided a DEXT driver compatible with Big Sur and Monterey. Check Plugable.​

Finally, because this post is getting long, if anyone with the same hardware config is having issues with sleep in Monterey (Instant Wake) and didn't have them in Big Sur let me know, and I can provide a few suggestions on how to resolve it.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,915
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@macleap,

Welcome to the forum. Very helpful first post. Will link it to the 0.7.5 mini-guide and top of Post 1.
 
Joined
Jul 22, 2016
Messages
301
Motherboard
Gigabyte Z690 Aero G
CPU
i9-12900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Finally, because this post is getting long, if anyone with the same hardware config is having issues with sleep in Monterey (Instant Wake) and didn't have them in Big Sur let me know, and I can provide a few suggestions on how to resolve it.

@macleap

A very informative post. I will have to try your fix for Monterey Ethernet.

My configuration is different than yours with an AMD Ryzen 7 3700x and RX 580. Sleep/wake has worked for me with Big Sur and Monterey under BIOS F10. However, CaseySJ had reported that BIOS F10 had problems with TPM and Windows 11, but BIOS F13 worked.

I installed F13 and had instant wake in both Big Sur and Monterey. CaseySJ provided his F13 settings file, and OC 0.7.5 EFI folder for me to try, but neither helped. The instant wake seemed like the typical USB port misconfiguration, so I remapped ports and that didn't help. So I fell back to F10 since I probably won't install Windows 11.

Perhaps you have a few suggestions on instant wake with F10 that might carry over to F13 with Big Sur/Monterey. Please post your suggestions.

Thanks.
 
Joined
Aug 20, 2020
Messages
60
Motherboard
Gigabyte X570S Aero G
CPU
Ryzen 9 5950X
Graphics
RX Vega 56
@CaseySJ

Have you been experiencing any issues in relation to DRM on Monterey? I'm using shikigva=128 bootargs but getting green screen on AppleTV+ and no picture on Amazon Prime or Netflix. If I use the bootarg unfairgva=1, then I can get Netflix and Amazon Prime working but AppleTV+ shows a picture with loads of graphical glitches and blockiness. This is with a Vega 56 with hardware acceleration confirmed working.

Any ideas? Thanks.
 
Top