Contribute
Register

Gigabyte B550 Vision D (Thunderbolt 3) + AMD Ryzen 7 3700X + AMD RX 5600 XT

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,020
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thanks! I just tried it, it boots, but is the i225v ethernet not in device properties? it didn't show up in system info, in system preference-> network there is a PCI ethernet slot Internal@0,1,2/0,2/9,0/0,0. I plugged in a ethernet cable, it shows as self-assigned IP, and after a while, it go black screen and reboot. I did tried to add it in device properties, but it didn't work, it shows up in sys info but not in system preference-> network.

I attached my PCIdevice list and config.plist below, please help and take a look, thanks ahead!

View attachment 526787View attachment 526789
This is another reason why we don’t recommend the D-P board — and why I did not update the OpenCore EFI. If you can fix the Ethernet port, let us know. The EFI for this board is provided on an as-is basis.
 
Joined
Dec 7, 2019
Messages
16
Motherboard
Asus z390 Designare
CPU
i9-9900k
Graphics
rx5700xt
Oh, I thought the Ethernet can be fixed. IT wasn't it working in OC 0.7.1 by @mrfatcatt? So I will try some other methods. Thanks!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,020
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Oh, I thought the Ethernet can be fixed. IT wasn't it working in OC 0.7.1 by @mrfatcatt? So I will try some other methods. Thanks!
We initially thought it worked, but like other owners of AMD motherboards with on-board i225-V ports, it actually didn't work. Hopefully someone will find a solution if it exists...
 
Joined
Feb 19, 2018
Messages
796
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
I plugged in a ethernet cable, it shows as self-assigned IP, and after a while, it go black screen and reboot.
Random reboots on AMD hacks are often down to an incorrect MMIO Whitelist. The Whitelist is usually different for each motherboard, even those by the same manufacturer. It also often changes with each BIOS revision.

You should discover what yours are, using the Debug Version of Opencore, do the maths (convert from Hex to Dec) and then update your config.plist
 
Joined
Dec 7, 2019
Messages
16
Motherboard
Asus z390 Designare
CPU
i9-9900k
Graphics
rx5700xt
Just tried this method from the post:
Solution that worked for me:

1. Disable FakePCIID.kext and FakePCDID_Intel_i225-V.kext in config.plist,
2. remove everything concerning i225 in DeviceProperties/Add/PciRoot...
3. add "dk.e1000=0" (without quotes) to boot-args.

It works! I can go to safari, google and download things, even after around 30 mins, so it seems stable.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,020
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Just tried this method from the post:


It works! I can go to safari, google and download things, even after around 30 mins, so it seems stable.
Awesome! I'll make those changes to the EFI for B550 Vision D-P.

P.S. We tried that before but it didn't seem to work. Anyway, it seems you've confirmed it.
 
Joined
Feb 10, 2019
Messages
286
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Just tried this method from the post:


It works! I can go to safari, google and download things, even after around 30 mins, so it seems stable.
Hey, id like to see some proof that you got networking working with Monterey public beta on this Gigabyte B550 Vision D mobo please :)
 
Joined
Feb 10, 2019
Messages
286
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
@CaseySJ have you been able to test 8k Video on Youtube with Safari and get the decoding done with the dGPU on Monterey PB?

I got to test it with my Z390 Designare with igpu and gotten acceleration working. CPU usage very low around 8-10% only.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,020
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ have you been able to test 8k Video on Youtube with Safari and get the decoding done with the dGPU on Monterey PB?

I got to test it with my Z390 Designare with igpu and gotten acceleration working. CPU usage very low around 8-10% only.
I can try this soon.
 
Joined
Dec 7, 2019
Messages
16
Motherboard
Asus z390 Designare
CPU
i9-9900k
Graphics
rx5700xt
Update, the i225v only works if I plugged the Ethernet in before switch on the Mac.
If I unplugged it, and then turn it on, it will go into kernel panic after I log in shortly after.
And after I got it working and switched on, I can unplug and plug it no problem.

and BTW I think I should add in a screenshot if any of you are interested.

As for testing Monterey beta @xtreem.p , since I'm already daily-ing the machine, I will have to find another SSD to install it first...
 

Attachments

  • Screenshot 2021-08-14 at 9.12.35 PM.png
    Screenshot 2021-08-14 at 9.12.35 PM.png
    792.7 KB · Views: 31
Top