Contribute
Register

GIGABYTE Aero 15-W Hackintosh

Joined
Jan 16, 2011
Messages
73
Motherboard
Gigabyte P35X v7
CPU
i7-7700HQ/HM170
Graphics
HD 630, GTX 1070 (3840 x 2160)
I have a Gigabyte P35X V7 with very similar specs with everything working except sleep. Did you get sleep working on yours?
 
Joined
Mar 3, 2016
Messages
133
Motherboard
Razer Blade 15 Advanced - Clover
CPU
i7-9507H/C240
Graphics
UHD 630 / GTX 2070 Max-Q
Mac
MacBook Pro
Classic Mac
20th Anniv. Mac
Mobile Phone
iOS
I have a Gigabyte P35X V7 with very similar specs with everything working except sleep. Did you get sleep working on yours?
Yep. Maybe you should tweak more...
 
Joined
Aug 14, 2010
Messages
51
Motherboard
Aorus X5 V6
CPU
i7-6820HK/HM170
Graphics
GTX 1070,2880x1620
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hi, everybody I came to this thread because your AERO laptop seems to have the same Asmedia SATA controller found in my Aorus X5 V6 laptop wich it is causing me some issues with the hard disk drive connected to it.

Did you tune up your sata controller? Every time I put my laptop to sleep and after wake it up I get the "Disk drive not ejected properly" message for my sata HDD. You are using a SSD m.2 drive but it seems to me driven by the same Asmedia 1062 Sata controller.

Gigabyte is using this SATA controller from Asmedia for a few recent laptops.

So if you could share any info in this matter or an IORegistry save file so I can compare.

Thank you!!

Good Luck!
 
Joined
Mar 3, 2016
Messages
133
Motherboard
Razer Blade 15 Advanced - Clover
CPU
i7-9507H/C240
Graphics
UHD 630 / GTX 2070 Max-Q
Mac
MacBook Pro
Classic Mac
20th Anniv. Mac
Mobile Phone
iOS
Hi, everybody I came to this thread because your AERO laptop seems to have the same Asmedia SATA controller found in my Aorus X5 V6 laptop wich it is causing me some issues with the hard disk drive connected to it.

Did you tune up your sata controller? Every time I put my laptop to sleep and after wake it up I get the "Disk drive not ejected properly" message for my sata HDD. You are using a SSD m.2 drive but it seems to me driven by the same Asmedia 1062 Sata controller.

Gigabyte is using this SATA controller from Asmedia for a few recent laptops.

So if you could share any info in this matter or an IORegistry save file so I can compare.

Thank you!!

Good Luck!
I don't think I have anything to share... indeed I did nothing. It just works on aero 15x v7.
 
Joined
Aug 14, 2010
Messages
51
Motherboard
Aorus X5 V6
CPU
i7-6820HK/HM170
Graphics
GTX 1070,2880x1620
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I don't think I have anything to share... indeed I did nothing. It just works on aero 15x v7.
Ok thank you!! I´ll keep searching.

And what about your P35X rrusek? It seems your laptop it´s almost the same machine and also your sata controller it is this Asmedia, maybe your issues with sleep are related to mine, do you installed MacOS on the HDD or the SSD?

Can you please shrare an IORegistry file save so I can compare?

Good Luck!!!
 
Joined
Mar 3, 2016
Messages
133
Motherboard
Razer Blade 15 Advanced - Clover
CPU
i7-9507H/C240
Graphics
UHD 630 / GTX 2070 Max-Q
Mac
MacBook Pro
Classic Mac
20th Anniv. Mac
Mobile Phone
iOS
Hi, I have the Aero 15x v7 version but can't even install high sierra or mojave, with or without your EFI files. Can you share your config.plist for the v7 please?
All the documented should be in Github folders categorized by system version. You can go fork that repo from GitHub and it should contain all of my engineering files.
 
Joined
Mar 3, 2016
Messages
133
Motherboard
Razer Blade 15 Advanced - Clover
CPU
i7-9507H/C240
Graphics
UHD 630 / GTX 2070 Max-Q
Mac
MacBook Pro
Classic Mac
20th Anniv. Mac
Mobile Phone
iOS
Ok thank you!! I´ll keep searching.

And what about your P35X rrusek? It seems your laptop it´s almost the same machine and also your sata controller it is this Asmedia, maybe your issues with sleep are related to mine, do you installed MacOS on the HDD or the SSD?

Can you please shrare an IORegistry file save so I can compare?

Good Luck!!!
I don't have a P35X. You can go to GitHub and fork my repository and there's everything I have. The files are organized by system version.
 
Joined
Mar 8, 2016
Messages
7
Motherboard
Asus X99 Deluxe
Mac
Classic Mac
Mobile Phone
GitHub -> "AppleALC is becoming problemsome and periodically not working"

Can you reproduce the error repeatedly? In my desktop (5820k, x99 platform) I have audio ONLY if I switch from win to mac powering off, if I use restart system the audio don't work in mac, is that your case?
 
Joined
Jan 15, 2019
Messages
1
Motherboard
Gigabyte
CPU
i7
Graphics
GTX 1060M
Hi Errrneist, I'm attempting to install 10.14 on a Gigabyte Aero 14W v7. I've used your Aero 15W EFI folder under the assumption the kexts and modified config.plist also apply to this machine. I get to the point where diskutil loads but my internal drive (also Liteon 512gb SSD) doesn't show up.

Please could you advise on the BIOS settings you used, on the off-chance you still have this info handy?

Kind Regards,
GD
 
Top