Contribute
Register

Giacomoleopardo Silent MacMini 6,2 | Step by step guide

Status
Not open for further replies.
Joined
Apr 17, 2010
Messages
59
Motherboard
ASRock Z77E-ITX
CPU
i3-3225
Graphics
GTX 760
Classic Mac
  1. Apple
Mobile Phone
  1. Android
Hey I still can't get my system to boot without -x (with -x it will boot). Now trying Mavericks. Here's my latest stuck verbose boot (without -x, no KP, just "stuck", lots of errors thou).

View attachment adriangb 10-23-13.zip
IMG_20131024_210213.jpg

Edit: noticed I need to add ethernet to get into app store, will solve at a later date, first priority is to be able to boot right.
 
Joined
Oct 28, 2012
Messages
19
Motherboard
Asrock Z77E-ITX
CPU
3770k
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
@flicka

I can confirm this. Works fine. Network never crashed. I did several reboots since than and had no issues.

Only issue I have is that my USB3 Ports are not working, even with USB3 devices. I installed GenericUSBXHCI.kext (with Multibeast 6). Maybe there is a newer version available? Maybe i need to update mit DSTD.aml? I'll try that later today.

UPDATE:
1.2.7 for GenericUSBXHCI.kext is available. Will try that now.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,233
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
...UPDATE:
1.2.7 for GenericUSBXHCI.kext is available. Will try that now.
Becareful. As noted in this release notes:
On OS 10.9, when installing GenericUSBXHCI, you need to edit the file /System/Library/Extensions/AppleKextExcludeList.kext/Contents/Info.plist and make sure GenericUSBXHCI is allowed up to the version you install.
I'd wait for MultiBeast to be updated unless you're having a problem and can't wait for GenericUSBXHCI.kext to be approved.
 
Joined
Jan 3, 2011
Messages
136
Motherboard
Gigabyte GA-Z97X-SLI
CPU
Core i5 4690K
Graphics
GeForce GTX 970 (eVGA ACX 2.0)
Mac
Classic Mac
Mobile Phone
  1. Android
The Power stuff in #3 is not working for me. Apple AppleGraphicsPowerManagement.kext doesn't have a info.plist anymore. Hope this guide will be upgraded for Mavericks :)

It's there; it's just hidden. You just need to show hidden files in Finder or else "sudo chflags nohidden Info.plist" from the terminal.
 
Joined
Oct 28, 2012
Messages
19
Motherboard
Asrock Z77E-ITX
CPU
3770k
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
Thanks Stork. 1.2.7 works fine (USB3.0 Front Ports are working again).

Will look into GraphicsPowerManagment later.
 
Joined
Oct 28, 2012
Messages
19
Motherboard
Asrock Z77E-ITX
CPU
3770k
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
GraphicsPowerSettings worked fine too :)
 
Joined
Apr 17, 2010
Messages
59
Motherboard
ASRock Z77E-ITX
CPU
i3-3225
Graphics
GTX 760
Classic Mac
  1. Apple
Mobile Phone
  1. Android
Can anyone with a nVidia GPU upload their current /Extra folder + extensions for me? I would then only have to generate a SSDT specific for my i3 3225 (correct me if I'm wrong). I really need to get mac working again asap for some projects. Thank you guys.
 
Joined
Oct 28, 2012
Messages
19
Motherboard
Asrock Z77E-ITX
CPU
3770k
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
One weird issue I still have. I'm using an SSDT for my i7-3770k. SystemDef is MacMini 6,2.

When all four CPU's are running at full the clock frequency is 3,7 Ghz (instead of 3.5Ghz) (HwMonitor). That's weird? Why does it overclock my CPU? I thought overclocking should only be done when only 2 cores are running (Turbo).

In the Bios the CPU is also clocked at 3.5Ghz.
 
Joined
Jul 25, 2012
Messages
7
Motherboard
Asrock Fatal1ty Z77 Professional-M
CPU
i5-3570K
Graphics
GTX 660 ti
Mac
Classic Mac
Mobile Phone
  1. iOS
@plantoschka
tried the mentioned kext but it is not working for me. Can you please control in system information if your ethernet is 0x16b0 or 0x16b1 ( My is 0x16b0)
No sucess too (0x16b1 here).

@plantoscka
Could u up your kext?
 
Joined
Oct 28, 2012
Messages
19
Motherboard
Asrock Z77E-ITX
CPU
3770k
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
Here is my IONetworkFamily.kext (ASRock Z77E-ITX 0x16b1).

Works perfectly fine for me (Mavericks 10.9).

Don't forget to fix permissions ! Hope it works for you :)
 

Attachments

  • IONetworkingFamily.kext.zip
    724 KB · Views: 108
Status
Not open for further replies.
Top