Contribute
Register

Giacomoleopardo Build - ZOTAC Z77-ITX WiFi - Core i7-3770T - MacMini 6,2

Status
Not open for further replies.
Joined
May 13, 2011
Messages
57
Motherboard
ASUS P8P67 Deluxe
CPU
i7 2600K
Graphics
XFX ATI HD 6870 2GB
Mac
Classic Mac
Mobile Phone
  1. iOS
I must say that on 10.8.3 everything works properly.
Did you re-edited AppleIntelFramebufferCapri.kext? Or just installed from a backup? The combo update surely reinstalled the original Capri kext. That may cause artifacts, I'd suggest to re-edit the kext following post #3 instructions or install my actual edited kext attached here.
I'd appreciate if you'll post results.
G.

I admit I hadn't / haven't edited the kexts, but that was because I didn't get artifacts in 10.8.1 and I hadn't edited them there. So I will try that and report back. Not going to be at my rig until Sunday. Bloody work!!!!!

Thanks for the feedback regarding mirroring. Forgive me, since your second post suggests you do, but you are aware AirPlay mirror is display duplication to an Apple TV? Of course my issues are probably related, so I'll keep you updated.
 
Joined
Apr 28, 2011
Messages
911
Motherboard
Asus Prime Z690M-Plus D4
CPU
i7-12700KF
Graphics
Lenovo Radeon RX 560 4 GB
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks for the feedback regarding mirroring. Forgive me, since your second post suggests you do, but you are aware AirPlay mirror is display duplication to an Apple TV? Of course my issues are probably related, so I'll keep you updated.
Of course I am :D I don't actually have Apple TV, but with Reflector App I can get Airplay mirroring either, tested with iPhone 5!
 
Joined
May 13, 2011
Messages
57
Motherboard
ASUS P8P67 Deluxe
CPU
i7 2600K
Graphics
XFX ATI HD 6870 2GB
Mac
Classic Mac
Mobile Phone
  1. iOS
OK, I'm beginning to pull my hair out. I've followed the guide, including trying new updates 8 and 9 as alternatives to manual patches, but can not get 10.8.3 to boot further than Mac swapon success, then after about a 30second pause, I get a DRMStatus message about iTunes playback and thats it. The only way I can boot is safe mode, which disables graphics acceleration. I've tried using your dsdt, but that produces kernel panic. I'm beginning to think it may be linked to the version of Bios I patched and flashed. do you have a copy of your patched bios file you could share please?
 
Joined
Apr 28, 2011
Messages
911
Motherboard
Asus Prime Z690M-Plus D4
CPU
i7-12700KF
Graphics
Lenovo Radeon RX 560 4 GB
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
OK, I'm beginning to pull my hair out. I've followed the guide, including trying new updates 8 and 9 as alternatives to manual patches, but can not get 10.8.3 to boot further than Mac swapon success, then after about a 30second pause, I get a DRMStatus message about iTunes playback and thats it. The only way I can boot is safe mode, which disables graphics acceleration. I've tried using your dsdt, but that produces kernel panic. I'm beginning to think it may be linked to the version of Bios I patched and flashed. do you have a copy of your patched bios file you could share please?

I've noticed that since april 2013 a new bios version is out A2290426
I tried to patch it with PMPatch, but I had no luck. I've asked help to CodeRush, and hopefully something will be figured out.
I guess you have that bios (that would explain why my dsdt doesn't work on your pc. Check your first screen in "BIOS Information" and "Build Date and Time", this is mine
zotac bios.JPG
I attach my patched bios, flash it and then follow the guide, I'm pretty sure it will work, then.

Also check this post to flash it, or try DPCI Manager (I never tried, but it's reported working good)
 

Attachments

  • A2291116.bin.zip
    2.6 MB · Views: 95
Joined
Sep 24, 2012
Messages
12
Motherboard
Hackintosh
CPU
i7-3770S
Graphics
Intel HD 4000
Mac
Classic Mac
Mobile Phone
Hey Giacomoleopardo,

Did you have any issues getting your optical drive to work? I have a similar build to yours, but my optical drive is Optiarc DVDRWBD 5600S (Blu Ray).
Currently, it just appears greyed out in Disk utility and doesn't accept disks if I try and insert them. I read somewhere that maybe its because storage config is set to AHCI and not IDE??

Any thoughts?

Thanks
 
Joined
Apr 28, 2011
Messages
911
Motherboard
Asus Prime Z690M-Plus D4
CPU
i7-12700KF
Graphics
Lenovo Radeon RX 560 4 GB
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey Giacomoleopardo,

Did you have any issues getting your optical drive to work? I have a similar build to yours, but my optical drive is Optiarc DVDRWBD 5600S (Blu Ray).
Currently, it just appears greyed out in Disk utility and doesn't accept disks if I try and insert them. I read somewhere that maybe its because storage config is set to AHCI and not IDE??

Any thoughts?

Thanks
Honestly, I've never heard about nor experienced that. Can you try another sata port? Or perhaps another drive? AHCI mode is mandatory for OSX, you can not turn into IDE.
 
Joined
Apr 28, 2011
Messages
911
Motherboard
Asus Prime Z690M-Plus D4
CPU
i7-12700KF
Graphics
Lenovo Radeon RX 560 4 GB
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Joined
Jan 26, 2012
Messages
20
Motherboard
Zotac Z77ITX-A-E
CPU
Intel Core-i7 2500K
Graphics
AMD Radeon HD 5850 1Gb
Mac
Classic Mac
Mobile Phone
There is no need to patch BIOS for this board anymore.
I proposed this patch (as long as some other overclocking-related stuff) to Zotac BIOS developers and they agreed to integrate it.
More to say, check out the changes in vanilla DSDT. ;)

I don't have OS X to test right now, but certainly I'm waiting for new DSDT and other stuff for new BIOS. As far as I have tested, it's much better then all previous releases, at lest in terms of overclocking.
 
Status
Not open for further replies.
Top