Contribute
Register

Geforce GTX 970m (laptop) sierra not working

Status
Not open for further replies.
Joined
Oct 22, 2013
Messages
11
hello!, someone has successfully been able to use a 970m with osx Sierra? I have tried to use the latest web drivers (346.03.04f02) but didn't have any success.
 
Last edited:
Joined
Apr 23, 2012
Messages
22
Motherboard
MacOS 10.12 & Windows 10 & Kali 16.2
CPU
I7-6700HQ
Graphics
NVIDIA GTX 970M 6GB
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
hello!, someone has successfully been able to use a 970m with osx Sierra? I have tried to use the latest web drivers (346.03.04f02) but didn't have any success.
In El-Capitan gtx970m works right away but in Sierra in both versions 12.0 12.1 I could not manage to make it work. It gives black screen but when I press any key I hear my preconfigured alert sound. In addition my onboard Intel HD530 has glitches too, that seems nobody find solution yet for it.
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,220
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
hello!, someone has successfully been able to use a 970m with osx Sierra? I have tried to use the latest web drivers (346.03.04f02) but didn't have any success.

Those are not the latest web drivers for Sierra. Download and install the correct drivers. 346.03.04f02 is for OS X 10.11.2 only. Additionally, since this is a laptop I don't believe you can use the 970.
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,220
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
In El-Capitan gtx970m works right away but in Sierra in both versions 12.0 12.1 I could not manage to make it work. It gives black screen but when I press any key I hear my preconfigured alert sound. In addition my onboard Intel HD530 has glitches too, that seems nobody find solution yet for it.

GTX 970 requires the correct web drivers in all versions of OS X. My desktop 970 works flawlessly.
 
Joined
Apr 23, 2012
Messages
22
Motherboard
MacOS 10.12 & Windows 10 & Kali 16.2
CPU
I7-6700HQ
Graphics
NVIDIA GTX 970M 6GB
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
GTX 970 requires the correct web drivers in all versions of OS X. My desktop 970 works flawlessly.

My build: 6700HQ + GTX 970M 6G Laptop

Edit: My laptop's built-in display connects on DP rather than LVDS and Nvidia is linked to PEG0@1 object in ioreg. Also my onboard Intel HD530 is linked to GFX0@2.

Before Sierra I was using El-Capitan and it worked by just installing the appropriate web driver. But in Sierra I'm getting black screen after boot. But desktop still functions I can hear alert sound when I press random keys.

1- I have 970M(Mobile) not 970(desktop) there are so much difference I believe.
2- I downloaded and installed this 367.15.10.15f01 from your post here for my 10.12.1
3- I use latest Clover_v2.3k_r3882 and added NvidiaWeb -> yes to clover.

If you kindly show the point that I must be focusing on regarding my issue I'd be ultimately happy sir.

 

Attachments

  • Screen Shot 2016-10-29 at 08.11.15.png
    Screen Shot 2016-10-29 at 08.11.15.png
    50.4 KB · Views: 294
  • Screen Shot 2016-10-29 at 08.11.44.png
    Screen Shot 2016-10-29 at 08.11.44.png
    16.3 KB · Views: 304
  • Screen Shot 2016-10-29 at 08.12.02.png
    Screen Shot 2016-10-29 at 08.12.02.png
    57.2 KB · Views: 262
Last edited:
Joined
Mar 12, 2014
Messages
7
Motherboard
MSI GT72 6QD
CPU
Intel i7 6820HK - Mainboard model: MS1782 Chipset: Intel Skylake-H 7 series
Graphics
Nvidia GeForce GTX 970m 1920x1080 3GB GDDR5 Integrated RAMDAC
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
In El-Capitan gtx970m works right away but in Sierra in both versions 12.0 12.1 I could not manage to make it work. It gives black screen but when I press any key I hear my preconfigured alert sound. In addition my onboard Intel HD530 has glitches too, that seems nobody find solution yet for it.

Hi, I managed to install El Capitan on my laptop, which has GTX 970m

I installed web drivers, and added NvidiaWeb in clover.

in “about this macbook” it says the graphics nvidia geforce gtx 970m 2GB, although it’s 3GB Vram card.

However, the OS uses built in drivers, rather than web drivers. When I switch to web driver, it asks for restart, after restart it goes back to built in driver, and does not use the web drivers. I could not get it to work..

Could you help me to get it working!! Thanks...

Specs:
MSI GT72 6QD ...
i7 - 6820HK
GTX 970m
16 GB RAM
 
Status
Not open for further replies.
Top