Contribute
Register

GeForce GTX 780 – Nvidia Driver Install Issue

Joined
May 17, 2015
Messages
19
Motherboard
GA-X99-UD5 WIFI
CPU
i7-5820K
Graphics
EVGA GeForce GTX 780 6GB
Mac
MacBook Pro
Mobile Phone
iOS
[SOLVED] GeForce GTX 780 – Nvidia Driver Install Issue

System:
Intel i7-5820K 6-Core @ 3.3GHz
Gigabyte X99 UD5 WIFI
32GB (4 x 8GB) Crucial Ballistix Sport DDR4 @ 2400MHz
EVGA GeForce GTX 780 6GB Superclocked ACX


MBR Clone OS Drive: Samsung 850 EVO 250GB (Boot Drive)
GUID OS Drive: Seagate Barracuda 3TB 7200RPM


Hello everyone,

I successfully installed Yosemite 10.10.3 using Bob Roche’s tutorial. I used the boot flags -x -v -f npci=0x3000 nv_disable=1 to boot.


In Multibeast I used
Realtek ALC1150
Intel Generic AHCI SATA
10.10.3 TRIM Patch
Fake SMC
VoodooTSCSync 6 Core
RealtekRTL81xx
Chimera 4.1
Basic Boot Options
Generate CPU States
Hibernate Desktop
Kext KernalCache
Mac Pro 3,1
Tonymacx86 White




The issue is when I go to install the nVidia Drivers for the currently unsupported GTX 780, they install but I cannot access the preference pane and I still have to boot with nv_disable=1 or else I can’t boot. I tried adding nvda_drv=1 to the kernel flags in org.chameleon.Boot.plist before rebooting after install but that didn’t work either. I tried booting without -x, with npci=0x2000 instead of 3000, along with trying to install with different versions, but they all give me the same results. I also don’t seem to be getting any dual monitor support.

Preferences Pane Screenshot.jpg

There is a BIOS update available for my motherboard (I’m running version F7) but the "how to update page" as well as the user guide don’t recommend updating if you don’t encounter instability or bugs, which I really haven’t I just want to get my GPU working with Yosemite. Would updating help?

I’ve also read (http://www.tonymacx86.com/graphics/161256-solving-nvidia-driver-install-problems.html) that I might have to install the drivers and/or do a clean install of Yosemite without the GPU installed, but my motherboard doesn’t support integrated graphics. If this is a solution that could work, could I in theory just pick up a cheap GPU and use that as an integrated graphics replacement?

Anyone have any suggestions or observations as to what this problem might be? Could it be the kernels I used in Multibeast? I’m not currently connected to the internet on my hackintosh, do I need to be in order for the drivers to install properly?




Users ncnettech and Gergelyc posted threads about having the similar issues but neither seemed to find any resolution. Any help would be greatly appreciated.





Mac Stats Screenshot.pngDisplay Stats Screenshot.pngGraphics Report Screenshot.pngInstallations Report Screenshot.png



SOLUTION:

This issue was solved after I did two things:
- In my BIOS, VT-d was enabled; I disabled it (Also stopped booting with -x)
- I reinstalled Yosemite 10.10.3 and installed the nVidia drivers before starting Multibeast post-installation.

Not sure if it was one or the other or both that solved the issue but nonetheless it works properly now.
 
Last edited:
Top