Contribute
Register

GeForce 9800GTX black screen in 10.6.4

Status
Not open for further replies.
Joined
Apr 3, 2010
Messages
16
Motherboard
ASUS ROG Strix Z390-I
CPU
i5-9600K
Graphics
UHD 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
Hi Y'all. I have the EVGA GeForce 9800GTX graphics card. It works great with OSX up to 10.6.1. It works in 10.6.2 with the 10.6.1 drivers. I skipped to 10.6.4 and now I get no video output. It doesn't work anymore to roll back to the 10.6.1 drivers. Has anyone else experienced this?
 
Joined
Jan 19, 2010
Messages
101
Motherboard
Blach
CPU
Blacjh
Graphics
fefe
Mac
Classic Mac
Mobile Phone
Are you using GraphicsEnabler=Yes? If you can try, try to use NVEnabler. Try DSDT edits if that doesn't work. Then after that, if all else fails roll back the drivers to 10.6.1. Or even try the new fermi drivers.
 
Joined
Jul 9, 2010
Messages
2
Mac
Classic Mac
Mobile Phone
I also have this problem, I have a gigabyte 9800 GT silent cell. I have spent lots of time searching for a solution but yet to find one. I am trying to build a HTPC. I have tried NV enabler and also graphicsenabler=yes and using a DVI to HDMI cable still no go. I read that its to do with HDCP handshake from the graphics adapter to display.
 
Joined
Jan 19, 2010
Messages
101
Motherboard
Blach
CPU
Blacjh
Graphics
fefe
Mac
Classic Mac
Mobile Phone
I didn't really think that the HDCP handshake could be so serious that it would shut off the display entirely, but now you have two options to solve this:

1. Delete AppleUpstreamUserClient.kext that handles HDCP.
2. Look in this thread for the other fix involving installing the Disabler.kext which disables the AppleUpstreamUserClient.kext.

Granted, this may only work for you, not the OP, because you have a 9800 GT. I haven't heard it being needed for 9800 GTX+, but considering the similarity of the cores, I don't doubt it. I have an EVGA 9800 GT, and I was told to use that, although when I installed the card, I had no problems with HDCP.
 
Joined
Jul 6, 2010
Messages
49
Mac
Classic Mac
Mobile Phone
Insanelymac's site appears to be down right now, but there's a guy there that has 9800GTX working with HDMI(HDCP translation) and has a tutorial in his Sig. I had it working on an AMD build a month or so back with a rom file but doesn't work on my current setup. I think his handle on Insanelymac is Tmongl. Or something like that.

Jay
 
Joined
Jul 13, 2010
Messages
5
Mac
Classic Mac
Mobile Phone
@Jammol

Off topic but do you know a guide for AMD?

I have an old board and AMD CPU would ove to convert it into a server.

Jimmy
 

MacMan

Administrator
Staff member
Joined
Feb 2, 2010
Messages
8,108
Motherboard
ASUS TUF Z390-PRO GAMING - 2606 - UEFI
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
jimbaran said:
@Jammol

Off topic but do you know a guide for AMD?

I have an old board and AMD CPU would ove to convert it into a server.

Jimmy
Apple has never support AMD CPUs so the retail install methods here won't work.
 
Joined
Apr 3, 2010
Messages
16
Motherboard
ASUS ROG Strix Z390-I
CPU
i5-9600K
Graphics
UHD 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
Okay, here's an update... I got tired of trying to fix the 9800GTX, so I ordered the 9800GT Silent Cell, as recommended by tonymacx86 here. I installed the card today and wouldn't you know, IT HAS THE SAME ISSUE!!

I saw the posts about HDCP and it reminded me that I had this issue before. I tried connecting the card to the monitor with a VGA cable and voila! I went through my past install notes, but I didn't write down the solution when I fixed it before. I'm working on it now. So far the disabler.kext didn't work.
 
Joined
Jul 6, 2010
Messages
49
Mac
Classic Mac
Mobile Phone
It probably isn't going to work at all. I've noticed that it only works with a .rom file if you're AMD, which I'm thinking DSDT? I don't know anything about Mac but that's where I would look.

Jay
 

jpa

Joined
Jun 13, 2010
Messages
873
Motherboard
10.8
CPU
i7 930
Graphics
6870
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
The problem is a boot cd, iboot fail in card....

The solution is used boot cd, empire efi and solution, my pc is full, is work nividia 9800gtx etc

Enjoy
Visit my install guide
 
Status
Not open for further replies.
Top