Geforce 9600GT 512mb in Dell Precision 490: blank screen when using kernelcache

Not open for further replies.
Nov 10, 2013
  1. MacBook Pro
Classic Mac
Mobile Phone
[Solved!] Geforce 9600GT 512mb in Dell Precision 490: blank screen when using kernelcache

Hello everyone

This week I did my first attempt installing Mavericks 10.9 using the tonymacx86 method on the following machine:

type: Dell precision 490
chipset: x5000
processor: 2x Intel Xeon 5320 1,86Ghz LGA771
memory: 8GB DDR2 (4x 2GB FB-dimm)
Graphics: Asus Nvidea Geforce EN9600GT/HDTI/512m Silent (512mb vram)

I added the folowing Kext's tot the /extra/extensions of my tonymacx86 install USB: "NVEnabler 64.kext" for my geforce 9600gt and "ApplePS2keyboard.kext" for my ps2 keyboard. I changed SMproductname in my smbios.plist to MacPro1,1 because that MacPro model also used the x5000 chipset, DDR2 FB-dimm's and LGA771 xeon processors.

At first, everything turned out fine, Mavericks installed without problems. Rebooting to my Mavericks installation using the Install USB went fine. Everything was recognized perfectly.

Schermafbeelding 2014-02-06 om 04.59.25.jpg

Post installation:
I used Multibeast to install the Chimera v2.2.1 bootloader and the "VoodooHDA v2.8.4 audio kext" on my harddrive. After that, I copied the Extra/Extensions and smbios.plist from my USB Installer to the /Extra on my harddrive. I also installed these extensions to System/Library/Extensions. Finally I installed "BCM5722D.kext" to get my Network chip working. I rebooted and everything was working fine. (including network and audio)

I have to boot using the boot flag: UseKernelCache=No which takes a very long time to boot, because the kernel uses 3 minutes to read al the available kext's

When I first used UseKernelCache=Yes the boot proces stopped at the "Still Waiting for root device" Error. With a good DSDT.aml from an Precision 690 (almost the same machine, but in a bigger case) I was able to bypass the "Still Waiting for root device" Error. But now, the screen turns blank (black, standby) a few lines later. The same thing happens when I try to boot with UseKernelCache=No and "NVEnabler 64.kext" removed (although I'm not sure if that is the right relation between those two blank screens). I added the DSDT.aml as an attachment to this post below.

View attachment DSDT.aml

I also noticed that "NVEnabler 64.kext" is being started several times. (In Both cases: using UseKernelCache=Yes or UseKernelCache=No) All the NVEnabler Debug lines (As you can see in the screenshot) pass about 5 times, before we get A: UseKernelCache=Yes -> blank screen B: UseKernelCache=No -> Desktop


Can anybody help me with fixing this problem?

Thank you in advance :)
[Solved!] Geforce 9600GT 512mb in Dell Precision 490: blank screen when using kernelcache

Hello everyone

After a few weeks I decided to give the mavericks installation another try.
This time I replaced the "NVEnabler 64.kext" with "Natit.kext"
Now, the computer starts perfectly fast with the boot flag: "UseKernelCache=Yes"!
Although the amount of videomemory is not longer displayed correctly in the systemprofiler,
Benchmarks seem to run at the same speed reagardless of using "Natit.kext" or
"NVEnabler 64.kext"

It's always nice to see a benchmark even running faster on OS X than with dedicated Nvidea drivers on Windows 7:
test1 os x.pngtest1 windows.PNGtest2 os x.pngtest2 windows.PNG

Summarized: The Dell precision 490 runs OS X Maverics 10.9.0 perfectly!
I will add my complete /Extra folder below! (Remember that you have to install a bootloader and install those extensions to /System/Library/Extensions when using the boot flag UseKernelCache=Yes. Also, some files in my /Extra folder are hidden files)

View attachment

Have a nice day!

Use the teminal command "defaults write AppleShowAllFiles 1 && killall Finder" to show hidden files

Edit: upgrade to 10.9.2 possible without a problem, Graphics performance increased slightly with Nvidea OpenGL engine update!
is your system already working?
please need your help. i went to install yosemite on my Dell Precision with unibeast. witch flags would i use. thanks
Have either of you been able to install El Capitan to the precision 490?
Have either of you been able to install El Capitan to the precision 490?

Sorry to be back this late, the system was working fine however I never tried to go beyond OS X mavericks (10.9)
Not open for further replies.