GC-ALPINE RIDGE(rev2) --> Thunderbolt3 --> Thunderbolt2 --> iMac (27-inch, late 2013) target display mode => [Cmd+F2 = BLACK SCREEN on ALL displays.]

Not open for further replies.
Apr 17, 2022
gigabyte b550 aorus pro ac
Ryzen 9 5900X
GTX 1050 Ti
Long story short.. I have a `MacBook Pro (Retina, 15-inch, Late 2013) - 16gb 1600MHz DDR3 - NVIDIA GT 750M 2gb / intel ires pro 1536 mb` it is running `macOS High Sierra - Version 10.13.3` it took a large CHUNK out of my collage funds to purchase, back in 2013.. I had to buy it for a video editing class at the `college of creative studies` because i did not have enough gas money or time to commute, to Detroit, EVERY day to work on homework using the available the iMacs that they had on campus. I am `white` but I am NOT privileged, I ran out of college money, i have the talent to get into a `prestigious art school` but my pockets are not deep enough. Recently I have received a `iMac (27-inch, Late 2013)` from a relative, who wanted to help me out.. being a `starving artist` i do truly, appreciate the gesture but the computer is from 2013, the BASE model, it is too slow to run Photoshop, or InDesign, ect. BUT the `iMac (27-inch)` it has a freaking BEAUTIFUL 10bit display! and Ebay is the `great equalizer` i have, built an `AMD Ryzentosh` with a `gigabyte b550 aorus pro ac - motherboard` because that motherboard has a `thunderbolt header` to plug in a `GC-ALPINE RIDGE (rev. 2.0)` at an affordable price! i had to purchase a `kit` from amazon, to flash the `alpine ridge` and when FLASHED, the hackintosh recognizes it, and it works as an ALMOST fully functional thunderbolt port.

The problem, to sum up my `short story` is that.. i PLANED to use `target display mode` to get the VIDEO output from my `AMD Ryzentosh` to the `iMac (27-inch) with the BEAUTIFUL 10bit display - to use it as a monitor for my Ryzentosh running: macOS Catalina Version 10.15.7` , and it freaking WORKS. when i press `Cmd+F2` the `AMD Ryzentosh` it ACTUALLY connects to the `iMac (27-inch)` except.. when it connects ALL my displays turn BLACK. How do i dix it? that is my question.

This is my first post, idk how to ask, or if this is `where` to ask, but i invested too much of my time.. to get so close, and not be able to get it working. lol

What does the `MacBook Pro (Retina, 15-inch, Late 2013)` have to do with anything? well, it has an HDMI port on it! and i can plug an old monitor into it, to extend the `MacBook Pro` to use a second display. and THEN when i plug the old `MacBook Pro` into the `iMac (27-inch)` via `thunderbolt2 cable` it allows.. me to extend my `MacBook Pro` to use 3 displays!! so, i know for a FACT that the.. `thunderbolt2` cable works, because i own a `MacBook Pro` and have tested it, none of the displays turn BLACK. it should work, all my hardware works, nothing is faulty, the `target display mode` works with the `MacBook Pro` so it should, work when i use the Ryzentosh in its place for OUTPUTING to the `iMac(27-inch)`. i have done lots of trouble shooting, and tried plugging this into that, and installing that to run such and such.. and can try, whatever else, that may need to be done, or tested, if ANYONE could possibly help.

The problem is with the `AMD Ryzentosh - running macOS High Sierra 10.13.6` i need to use it as my `main computer` because the `MacBook Pro` is from `2013` it is also VERY old and can barely run anything now days. and i would really like to use the `iMac (27-inch)` as the main display, for my hackintosh build!! the 10bit display is beautiful, and if when pressing `Cmd-F2` it didn't trip, the computer to turn off ALL my displays, and if it would just CONNECT and output the desktop, i would be able to use it for extending my desktop to its `iMac (27-inch) 10bpc beautifulness `.. did i mention how beautiful the `iMac (27-inch)` display is?? yes, pretty sure I did.

The `AMD Ryzentosh - gigabyte b550 aorus pro ac - motherboard` is recognizes the `GC-ALPINE RIDGE (rev. 2.0)`, and the card works FULLY when running it with `windows 11`. I am using the apple `usb-c thunderbolt3 to thunderbolt2 adapter`.. plugging that into the `GC-ALPINE RIDGE` to convert it to `thunderbolt2` and then plugging that `thunderbolt2` end into the `iMac (27-inch) - so i can use it as a 10bpc display`. The firmware on the `GC-ALPINE RIDGE` did not work, when running on the `AMD Ryzentosh - macOS High Sierra 10.13.6` so, i bought a kit on amazon, flashed it, and NOW the `GC-ALPINE RIDGE` shows up, in the `Ryzentosh - about this mac - System Report - Thunderbolt` and after flashing the `GC-ALPINE RIDGE` pressing `Cmd-F2` triggers, the `target display mode` but when doing so, all my displays turn black. The whole `all displays turn black` does NOT happen, when i use the `MacBook Pro` only the `AMD Ryzentosh`. when i press `Cmd-F2` again the displays turn BACK, and all displays work again. its only when i try to use `target display mode`, the reason i embarked on trying to use the `iMac (27-inch)` as a display.. when any issue occur. is there a `kext` that i need to install? has anybody else been able to get, a setup like this working? does the `apple thunderbolt3 to thunderbolt2 adapter - not send DisplayPort signal`, or could it be an `integrated graphics` issue? is there some way to `redirect` the video output, to work on a `AMD Ryzentosh` that has a `discrete graphics` gpu?

I really don't know how to ask a short question, but i think that covers the gist of it.. i could add more details, or upload screen shots, but idk what would be helpful, and my question, is already very long. if anyone could possibly help, i have an `AMD Ryzentosh` and would, like to use `target display mode` to send output over thunderbolt to use an `iMac (27-inch) - 10bpc display` as a monitor.

I have a feeling that this is a VERY niche question, and my question will end up along with the few questions on this website.. that never end up being resolved. but thanks in advance, if anyone can help.
Not open for further replies.