GA-Z97x Gaming 3 i7-4790K GTX960 SC, Killer™ Ethernet E2200

Not open for further replies.
Feb 19, 2016
ASUS ZenBook UX430UA-DH74
Intel 620 1920x1080
Intel core i7 4790k
Gigabyte GA-Z97X Gaming 3
(Intel based graphics, Killer™ Ethernet E2200)
GeForce GTX 960 SuperClocked
Samsung 850 Evo 500GB
Corsair Vengeance 32GB RAM
CoolerMaster G650M 650W
Blackmagic Design Decklink mini monitor 4K SDI

Please also see other OSX version guides:

Z97x Gaming-3 I7-4790k GTX960 10.11 El Capitan - Guide
Z97x Gaming-3 I7-4790k GTX960 10.12 Sierra - Guide
Z97x Gaming-3 I7-4790k GTX960 10.13 High Sierra - Guide

After struggling to get Mountain Lion working on my new hardware (see thread) I decided to give El Capitan a try because it was available for download through my app store.

I had a lot more success with El Capitan so thought I'd share my steps so far along incase it helps anyone. This is a work in progress, I have not gotten all the way to the end but I did get the most important part done which is to install OSX and have it running with network support on this super speedy hardware. I will continue to document my journey with it all here.

I'm largely using the guide on this website but also adding my own steps along the way:

1. After downloading the app from App store (around 6.5GB) I used UniBeast 6 to create the USB. To create the USB I followed the steps as outlined here in the Yosemite Desktop Guide. (see above link if you need it)

2. For UniBeast options I used Legacy boot mode and didn't check off any extra boxes under optional graphics configuration.

3. My bios is version F6. I have no idea if newer version exists as I haven't checked yet. But I went through and made some changes in my bios as follows:

Load Optimized Defaults
Peripherals>xHCI Mode>Auto
Peripherals>xHCI Hand-off>ENABLED
Peripherals>EHCI Hand-off>ENABLED
BIOS Features>Boot Mode Selection>Legacy
Save and Exit

4. My first round booting off the USB I didn't know how to add any boot flags using Clover so naturally the install never completed because of Nvidia based GPU. So I tried the verbose preset from the Clover menu and ended up with black screen which just showed ended showing how many million nanoseconds had been run. I was really stumped here so I decided to pull out my 960 GTX and use the integrated Intel graphics card. This worked and I got the Apple El Capitan install screen.

[EDIT January 15th 2017] To add extra boot flag nv_disable=1 follow this:
1. At Clover Boot Screen click/highlight Options and hit Enter
2. Highlight Boot Args: and hit Enter
3. Move arrow keys to end of line, type desired flag, and hit Enter
4. Press Escape to return to the initial Clover Boot Screen

5. After El Capitan finished its installation booting into OSX was super fast and resolution really high with the integrated Intel graphics card. Network full functioning. Haven't tested the sound yet or poked around yet to start fixing any drivers I'm going to need.

6. I have not started the Clover configurator, MultiBeast, or other post-installation tools. That's on the list for tonight.

7. I finally found how to add your own boot flags. Found them in this guide:

[update: Feb 23rd 7:10pm EST]

I've been having a lot of fun installing and testing various software under my new 10.11 install running on my x86 system, but embarrassingly I'm still booting off the USB - so next I will go through my steps to get booting off the SSD, get my audio working, and whatever other parts I find going through this post installation.

Running the MultiBeast:
After all my blood sweat and tears I wasn't really comfortable using the QuickStart so I'm using this guide which similar specs to my build to go through my setup.

Under DRIVERS I selected AUDIO and then selected the ALC1150 option. DISK I skipped past. Under MISC I selected all three FakeSMC's. For the NETWORK options I selected AtherosE2200Ethernet v2.0.1.

Next I selected BOOTLOADERS and selected Clover v2.3k r3320 UEFI Boot Mode.

Under the CUSTOMIZE option and under SYSTEM DEFINITIONS I picked iMac 14,2. SSDT options nothing is selected. 'Graphics Configuration' nothing selected.

Now I'm ready to BUILD it so make sure the right install drive is chosen, in my case it's "Macintosh HD". I click INSTALL and shortly after success!

It's time to shut down now, pull out the boot USB and reboot into OSX 10.11 off the SSD.

So what's next on my list? Getting USB 3.0 to work, and I still haven't put the GTX 960 SC back in.

[more coming]

[update: Feb 25th 11:46am EST]

Today I installed EVGA GTX 960 Superclocked with success.

I downloaded WebDriver-346.03.05f02.pkg as per NVIDIA Releases Alternate Graphics Drivers for OS X 10.11.3 (346.03.05) installed them then BEFORE restart, I loaded the configurator and enabled argument for nvda_drv=1.
Selected "restart" but after OS shut down I turned computer off.

Went into BIOS, disabled Intel onboard graphics card, switched monitor cable to GTX 960 and booted up no problem.

OSX bar shows nvidia logo.

Next I download CUDA drivers from and run installer. I need this to get my DaVinci Resolve to work...

Machine running really good so far in the meantime. So happy with this system, my USB 3.0 ports are working but I have not idea if working at USB 3.0 speed so its on the list of things to test/check. I still need to install bluetooth, and eventually dual boot so I have Windows 7.
Last edited by a moderator:
Feb 19, 2016
ASUS ZenBook UX430UA-DH74
Intel 620 1920x1080
GA-Z97x Gaming 3 i7-4790k GTX760 SC, Killer™ Ethernet E2200


My Geekbench 3 Benchmark (32-bit test only, I don't own software to do 64-bit test)

My BruceX Final Cut Pro X Benchmark score: 26 using ProRes 422 HQ

BruceX Final Cut Pro X reference scores:


Novobench score 1529

Last edited:
Aug 3, 2011
Z97X-Gaming 3
i5 4690K
MSI R9 390X
  1. MacBook Air
Mobile Phone
  1. Android
Hey I own the same motherboard and I'm running 10.11.5 but how did you get USB 3.0 working ?
I didn't work on 10.11.3 also.

EDIT: Installing Intel series 7/8/9 driver from Multibeast 8.2.2 seem to solve the issue
USB 3.0 is now working at 3.0 speed

EDIT 2: Now I need to solve these random freeze I get on El Capitan (Mouse cursor is still moving but I can't select anything), I must restart manually to solve it until it happens again.
I experienced these freezes on 10.11.3 and 10.11.5 so if anyone got an Idea

EDIT 3: Freezes are caused by the R9 390X, don't know what to do...
Last edited:
Not open for further replies.