Contribute
Register

GA-Z77X-UP5-TH + ML 10.8.4 - wont stay ASLEEP, wake reason: ECH1??

Joined
Dec 25, 2011
Messages
51
Motherboard
Gigabyte UP5-TH
CPU
3770k
Graphics
ATI 7950
Mac
Classic Mac
Mobile Phone
Hey there,

I can't get my install to stay asleep. It will go to sleep for 2-3 seconds before waking up at the lock screen. The wake log gives reason as "ECH1".

Hardware:

Z77X-UP5-TH
Corsair DDR3 1600 (XMP Profile 1)
i7-3770k
AMD 7950 gpu

assertions log:

Assertion status system-wide:
PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
PreventUserIdleSystemSleep 0
ExternalMedia 0
UserIsActive 0
ApplePushServiceTask 0
BackgroundTask 0

Kernel Assertions: 0x0004
* Kernel Assertion ID = 500
Created At = 9/21/13 1:07:44 PM EDT
Modified At = 9/21/13 1:12:32 PM EDT
Owner ID = 0xffffff8020567000
Level = 255
Assertions Set = None (4)

* Kernel Assertion ID = 501
Created At = 9/21/13 1:07:45 PM EDT
Modified At = 9/21/13 1:12:32 PM EDT
Owner ID = 0xffffff80200ee000
Level = 255
Assertions Set = None (4)

* Kernel Assertion ID = 502
Created At = 9/21/13 1:08:30 PM EDT
Modified At = 9/21/13 1:15:15 PM EDT
Owner ID = 0xffffff8020579000
Level = 255
Assertions Set = None (4)


wake reason log:


Sep 21 14:29:38 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 14:29:59 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 14:30:31 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 14:32:19 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 14:32:53 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 14:56:00 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 14:56:49 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 15:05:23 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 15:10:18 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 16:06:24 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 16:13:03 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC2 EHC1
Sep 21 16:32:13 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1
Sep 21 16:57:16 Thomass-Mac-Pro kernel[0] <Debug>: Wake reason: EHC1




THINGS I HAVE TRIED:

* disabled Internal CPU PLL Overvoltage
* removed AppleIntelCPUPowerManagement.kext
* removed GenericUSBXHCI.kext (accidentally installed, believe it is not needed for this board)
* installed nullAppleIntelCPUPowerManagement.kext to negate the other one
* set hibernate mode to 2 with "sudo pmset -a hibernatemode 2"
* disabled Wake On LAN in BIOS
* disabled Wake On Thunderbolt in BIOS



This is driving me crazy. How do I fix sleep? Why does my build keep waking when others dont?
 
Joined
Dec 25, 2011
Messages
51
Motherboard
Gigabyte UP5-TH
CPU
3770k
Graphics
ATI 7950
Mac
Classic Mac
Mobile Phone
I have discovered the solution to the sleep issue.

The cooler I use, the Corsair h100i, is an all in one liquid cooler that connects to the motherboard internal usb2 header. I completely had forgotten about that - I was getting ECH1 wake reason because ECH1 = USB2 header, and the cooler is connected to the internal USB2 header. Apparrently Corsair coolers don't play nice with OSX and it was causing the wake issue.
 
Joined
Feb 17, 2011
Messages
6
Motherboard
Power Mac G4 Quicksilver
CPU
2.0 GHz 7447A
Graphics
BFG 7800 GS OC
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I too have a Corsair H100i cooler connected to the internal USB header of my mATX build and am also getting ECH1 wakes.

You state that you have a solution. What is it, please?
Or, is it that you just know the reason... the cooler.
 
Joined
Feb 17, 2011
Messages
6
Motherboard
Power Mac G4 Quicksilver
CPU
2.0 GHz 7447A
Graphics
BFG 7800 GS OC
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Well, I disconnected the USB link. It is not needed except to use Corsair Link software, which is, of course, Windows only...
Double checking temps with Temperature Monitor shows that the CPU is cooled just as it was with the USB link connected.

Testing showed the continuance of immediate wake after sleep, but Console showed the cause to have changed to EHC2.
I changed the port connecting my Aten KVMP and the spontaneous EHC wakes ceased.

Anyhow, my mATX build now sleeps and wakes as it should.
 
Joined
Oct 5, 2012
Messages
3
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. Apple
  2. Centris
  3. Color Classic
  4. iMac
Mobile Phone
  1. Android
  2. iOS
Thanks Pr3Fix and rockyroad. I also have a Corsair water cooler that was connected to an internal USB header. For months, I had not been able to use Sleep, because it would immediately wake back up.

Thanks to your tips, sleep is working normally now, after disconnecting the water cooler from USB.

Woohoo! :lol:
 
Top