Contribute
Register

GA-Z77X-UD5H - RX570 - Black Screen

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,987
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
And you think that CPUFriendDataProvider.kext is the issue? Are any other topics like this in the past?

I am still reverting the Monterey Backup, after this I am going to install Ventura on a separate hard drive to to some tests.
may be the issue if you are not using it correctly
 
Joined
Jan 13, 2017
Messages
267
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
I'm also with Z77 / rx570 and have a balck screen on bootloader.. I try HFSplus and give me error #[EB|LOG:EXITBS:START]

wen change to OpenHfsPlus.efi give me black screen on bootmenu.

here is my EFI
 

Attachments

  • Archive.zip
    9 MB · Views: 23
Joined
Dec 15, 2015
Messages
386
Motherboard
MSI Z270 M7
CPU
i7-7700K
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
If you boot in safe mode (hold shift + enter at opencore boot entry), what happens ?

To me you lack the AVX2.0 instruction with your Ivy Bridge that is needed to drive the RX570 with Ventura. It loads the default macOS drivers. As I have an Ivy Bridge system too, I think we need to wait for OCLP to be updated to install the required drivers.
 
Joined
Aug 17, 2012
Messages
508
Motherboard
Gigabyte Z490 Aorus Pro AX
CPU
i7-10700K
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@CrashMidnick

I guess you are right, and this is the issue. Because it looks like the RX 570 does not work as expected. On the Cryptofixup Page it states:

This kext does not drop the requirement for AVX2.0 in some of Ventura's Graphics Stack
  • AMD Polaris, Vega and Navi Drivers in Ventura will not function without AVX2.0 support, end users will need to find alternative ways to achieve graphics acceleration
 
Joined
Dec 15, 2015
Messages
386
Motherboard
MSI Z270 M7
CPU
i7-7700K
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
See change log here, V 0.5.0 :


Graphics Acceleration for legacy Metal GPUs
  • Intel: Ivy Bridge, Haswell, Broadwell and Skylake
  • Nvidia: Kepler
  • AMD: GCN 1 through 3
  • AMD: Polaris (on pre-AVX2.0 systems)
    • Boot in safe mode to avoid stock driver loading

EDIT : V5 has been pushed 18 hours ago : https://github.com/dortania/OpenCore-Legacy-Patcher/releases/tag/0.5.0
Maybe you can try it. If I have time I will do it on my side this evening.
 
Last edited:
Joined
Dec 15, 2015
Messages
386
Motherboard
MSI Z270 M7
CPU
i7-7700K
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
But in safe mode is not a very nice option. But I guess it should work. I hope for more progress in the future.

It is just the time to launch OCLP and apply the patch. I tested on my Ivy Bridge Hack and I could not boot into safe mode for some reason.

I added to my config.plist NVRAM boot arg : -amd_no_dgpu_accel

And here is a working Ivy bridge with Ventura :

Capture d’écran 2022-10-28 à 17.39.33.png
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
8,452
Motherboard
Gigabyte Z590i Aorus Ultra - OC 0.8.0
CPU
i5-10600k
Graphics
Dell RX560
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
I guess it is time for a system change. I already ordered a Z490 Gigabyte Board with a i7-10700k.

You did well to find a Gigabyte Z490 motherboard. Rare as hens teeth now in my part of the world, but a great one to hackintosh. :thumbup:
 
Top